1. #1

    Game not launching.

    Game worked just fine this morning, but after i restarted my pc, it no longer launches. Game process shows up for a few seconds after cloud sync and then shuts down. I have been trying to fix this for almost 4 hours now. I have tried everything reasonable i have been able to find on the internet related to this issue. If anyone has any useful inputs to this issue, they would be highly appreciated.
    Share this post

  2. #2

    My best guess

    And regarding the solutions i have tried... My guess at this point in time is that the likely culprit is EAC, although i have uninstalled/reinstalled it numerous times today. It would seem that the game closes as soon as EAC process starts, after which the EAC itself will close as well. I do not know in what way EAC could be messing this up, but honestly at this point i have no clue to what else could be causing this issue, since i have thoroughly gone over all other issues/fixes people have pointed out including for example not running the game/uplay as admin, firewall/AV issues, disabling all overlays, internet connection/router issues, conflicting programs, deleting temporal files and documents for gwr, system updates/drivers (including directx, and visuals) . And a whole bunch of other things i already forgot. I have not tried installing the game on a clean install of windows, since i don't have that possibility right now, and if that would be necessary, i don't think it would be worth the trouble anymore.
    Share this post

  3. #3

    I have confirmed a solution.

    !!!! FIX !!!!

    If you have used any trainers for any games with EAC, you MUST run malwarebytes rootkit remover to remove the EAC bypass files from your computer. These will cripple the EAC in ANY game you play. Including especially GRW. This was the culprit for me. If malwarebytes doesn't find these files, and you still have the problem, try searching for those files manually, if you have an idea where you could find them. But in conclusion, DO NOT use ANY cheating software for games that use EAC, as they will often screw you over in other EAC games as well. Don't cheat gentlemen. It will come back and haunt you.
    Share this post

  4. #4
    If this is true, i will find you and i will kiss you!
    Share this post

  5. #5
    I think this is the file:

    Latest (and mentioned) version of trainer will create EACGuard.sys file in C:\Users\[your profile]\Cheathappens\Work (windows 10) which blocking normal function of EAC service.

    And you need to remove it in safe mode or else you cannot delete it.
    Share this post

  6. #6


    i am running windows 8 and the root kit remover is not working. any other ideas?
    Share this post

  7. #7

    If the rootkit tool can't find it

    If you can't find a file restricting EAC with the rootkit remover, then just about the only way you have is to try and look for it manually, if you know you have used programs that stop EAC from working, for example trainer software. What i would do is just search the pc with keywords like "eac" and "easyanticheat", and hope that something pops up. Other than that i have no suggestions. If this does not work, it is highly likely that this is not the problem you are having in the first place.
    Share this post

  8. #8
    Ubi-Redbeard's Avatar Ubisoft Support Staff
    Join Date
    Mar 2017
    Glad to hear that you managed to resolve this.
    Share this post