Thread: [HELP] Cant Join My Brothers Game (We're on the same network) | Forums

  1. #1
    GTWV's Avatar Junior Member
    Join Date
    Dec 2017
    Posts
    2

    [HELP] Cant Join My Brothers Game (We're on the same network)

    So me and my brother is literally sitting on the same network (But different computers obviously)
    And when one of us invites the other and the other person accepts we get in a UPlay lobby (You know when you press Shift + F2)
    However.. We do not get placed in the same game group.

    These are the steps we are taking.
    1. We load up the game
    2. We both go to "Multiplayer"
    3. One of us clicks the guys name on the right side of the screen where you can see your friends
    4. We press Invite to group
    5. The other person accepts

    And then nothing happends, we dont get placed in the same game lobby.
    It's at a point where we cant even play quick games with each other because it cant find us, we've tried portforwarding ALL the freaking ports, unblocked uPlay and Trails in the firewall etc.

    Any ideas?
    Hamachi wont work because how would we connect to the server? There is no freaking console.. Hire me Ubisoft and let me work on the development for this game since it seems like you guys have given up. No offense.
    Share this post

  2. #2
    Ryphyz's Avatar Junior Member
    Join Date
    Jul 2016
    Posts
    24
    I think we had the same problem when I was playing with a friend, and it worked when did not both go to Multiplayer, but only the person who invites, while the other waits for the invitation first and only enters Multiplayer via the invitation. Have you tried that?

    Forwarding port 3074 should be enough.
    Share this post

  3. #3
    Not sure off the top of my head how it is in Fusion but in Evolution, there was an added step required after grouping up in Uplay. The one hosting the match also had to press on "invite party to game" so that might be your issue? I know it's a silly suggestion but sometimes it's the silly things we miss!
    Share this post