Thread: This game has a high CPU usage 80%-100% | Forums

  1. #1
    Voidolt's Avatar Junior Member
    Join Date
    Feb 2012
    Posts
    17

    This game has a high CPU usage 80%-100%

    Hey while playing this game has very high CPU usage, im pretty sure someone already posted it. I hope you can fix something with this. I've never had before 100% usage CPU.
     30 people found this helpful
    Share this post

  2. #2
    Ubi-Keo's Avatar Ubisoft Support Staff
    Join Date
    Jul 2017
    Location
    UK
    Posts
    481
    Can you please confirm your PC specifications
     2 people found this helpful
    Share this post

  3. #3
    Voidolt's Avatar Junior Member
    Join Date
    Feb 2012
    Posts
    17
    GTX 970
    I7-4790K
    16GB RAM

    Also a lot people reported this problem with their i7 6700k .
     4 people found this helpful
    Share this post

  4. #4
    makavelli1012's Avatar Junior Member
    Join Date
    Oct 2017
    Posts
    4
    I have the same issue im checking with the benchmake and its a cpu issue its mostly occuring in citys
    im running in 1920x1080 and 2560x1440 no problems with that almost no extra usage
    im running a i5 6600k 4.7 overclock liquidcoold
    with a gtx 1080 ti liquidcoold

    on

    very low i see my gpy 45/50% and cpu 100% from the start of the benchmark or game
    lvery high my gpu 55/60% and cpu 100% framerate in citys to almost 30 normal on 90 or higher
    so it must be a cpu problem with the 6xxx series can you guys check out if itsd also in the 7xxx series and let us know what you guys find out

    oh btw i also had the problemw ith the logitech headsets.
    i find out that it is the adapter i think the audio options in game need some tweaking for headsets who have that build in.
    a qucik fix for now is put you headset back oin the cable with the 3.5 audio jack
     1 people found this helpful
    Share this post

  5. #5
    The_Warhound's Avatar Junior Member
    Join Date
    Oct 2017
    Posts
    3
    Running 8700k and 1080ti still get insane usage and temps
     2 people found this helpful
    Share this post

  6. #6
    Gackt54's Avatar Junior Member
    Join Date
    Aug 2013
    Posts
    4
    Same thing for my i7 3930K with gtx980 and 16go DDR3

    Can't see the temperatures but my PC is very noisy. Like I am rendering a video with Sony Vegas...
     1 people found this helpful
    Share this post

  7. #7
    JohnyW_PL's Avatar Junior Member
    Join Date
    Mar 2011
    Posts
    10
    For me (i5 4690K, 16GB RAM 2400MHz and GTX 1080 Gaming X) I have very high usage on Core 1, 2 and 3. Core 0 is loaded 30-89% (never 100%) and during benchmark, in the city, I see that FPS is going down from 60 FPS to around 42-45.

    I saw that it help me when I change colligation to Core 0 only and then I change it again to all cores. When I run benchmark again CPU usage was also high (that is good because it shows that game is using all PC power) but now game is running much more smooth (city part was 42-45 FPS and now it is 55-60 FPS) and all cores are loaded more equally
    Share this post

  8. #8
    Duckers_Mcquack's Avatar Member
    Join Date
    Oct 2012
    Posts
    40
    SAme cpu here and also 100%, same with the gpu too (1080 SC)
    Share this post

  9. #9
    AOD_SN0ST0RM's Avatar Junior Member
    Join Date
    Dec 2013
    Posts
    27
    Same.6700k at 100% in cities while my 1080ti isn't hitting 60% usage. This shouldn't be happening
    Share this post

  10. #10
    Animator_Alex's Avatar Member
    Join Date
    Feb 2013
    Posts
    217
    Same here on an i5-4670K. Only really happens in this game. Not an issue in almost every other game.
    Share this post

Page 1 of 33 12311 ... Last ►►
//Uplay Overlay login for community forums