Thread: Game Breaking Bug In World 2-3 Toad Escort | Forums

  1. #1

    Game Breaking Bug In World 2-3 Toad Escort

    I'm reporting a potential game breaking bug that occurred when I went back to Peach's Castle after the first fight of 2-3. After I fought the first battle, I got frozen Rabbid Mario to Toad and attempted to immeadiately go back the opposite way, thinking I was able to just simply take him back to Toadette. Needless to say, it didn't work since it warns you that your current progress will not save. So I ended up resetting the game, think it'll let me start back right after the first battle.

    It ended up starting up right before the first battle, but no problem, I go ahead and fight them again and the proceeded to the second battle where you escort Toad to the other side of the battlefield. I finish up the second battle and I push the blocks on top of the ice in order to exit and expect to be able to head back to Toadette, but instead, the bridge with the green trigger switches have reset to the way they were initially and I am unable to get across the barrier to trigger them to get back to Toadette.

    I tried looking for other ways to go around and there wasn't any other way unless I completely missed it. There's no way restart the level over so even if I exit the world and come back in, it starts me right after I beat the second battle and I still am unable to exit to get back to Toadette. Can someone please present me with a solution? I really don't want to lose all of my progress and have to start over.

    Thanks,

    Tony
    Share this post

  2. #2
    UbiChrisMANG's Avatar Community Representative
    Join Date
    Jun 2015
    Posts
    1,289
    Hi Luminite91, welcome! There is a page with lots of information in a FAQ format here where you can also search for specific issues, this may help:

    https://support.ubi.com/en-US/News/0...Battle-Players

    There is also a forum thread here which has links to Support if you still cannot find a solution:

    http://forums.ubi.com/showthread.php...ror-READ-FIRST
    Share this post

  3. #3
    Same problem here. Have been an issue for over 2 weeks and have been reported to the support. 2 weeks and no simple fix. For someone that pre-ordered the game I am highly disappointed.
    Share this post

  4. #4

    mario+rabbids 2-3 game breaking bug

    i too am highly displeased with ubisoft and there lack of help and trying to patch this problem, ive sent two tickets in within 3 weeks of each other and the only reply I get is the same thing they are aware of it and it will be in the new patch... wtf when will this patch come through? its been a month. steam devs seem to work faster than this. I am highly upset I wasted 60$ on this game and the only info they can give is they are aware of it and will fix in a patch that has been a month in delay. If I could get a refund I would sadly.
    Share this post