Thread: PCFar Cry 4 Anisotropic filtering problem or something else | Forums

  1. #1

    Far Cry 4 Anisotropic filtering problem or something else

    I don't understand what is happening with my game,i played few months ago on GTX 650 Ti Boost and it was fine. Today i decided to play it again but this time on the GTX 950,and i noticed a bug or a glitch i don't know how to call it. When i put terrain quality on high or ultra road texture becomes blurry like it's forcing anisotropic filtering to 2x,but if i put terrain quality to low or medium it looks normal. Also on ultra and high distance mountains are looking normal only problem is that terrain texture is blurry. I tried to reinstall drivers and game too but it did nothing. I didn't had this problem on my previous card so i don't understand what is going on. Also i don't have this problem in Far Cry 3 or Far Cry Primal.
    Share this post

  2. #2
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    1,966
    open Nvidia control panel

    find far cry 4 in your list of games

    in Nvidia control panel, i made these changes
    Anisotropic Filtering = 16 X
    Max Pre Rendered Frames = 1 or 3
    Set Power Management Mode = Adaptive


    i used to have a factory Overclocked ASUS STRIX GTX 960 ..your 950 is a lower end card ..do not expect miracles out of it
    set your settings lower then mine

    here are my settings i used in case it helps ..

    my in Game settings are Custom
    resolution 1920 X 1080
    vsync - on
    Quality settings
    motion blur off - not a fan of it ..
    Textures - Ultra
    Shadows - High <--- (Nvidia PCSS Soft Shadows will kill your FPS )
    Post FX -Ultra
    Geometry - Very High
    Vegetation- Ultra
    Environment - High
    Water - Ultra
    Ambient Occusion setting is SSBC
    Antialising settings is SMAA
    God rays - off- not a fan of how it looks (can make the game unstable..even on Titan X and GTX 980 Ti cards )
    Fur - on
    Trees relief -on
    in Advanced settings
    Triple buffering - off
    Vsync mode - Normal


    in Nvidia control panel, i made these changes
    Anisotropic Filtering = 16 X
    Max Pre Rendered Frames = 1 or 3
    Set Power Management Mode = Adaptive


    game looks fine to me and plays stutter free on my system with zero crashes


    also i did install Razer Cortex game booster version 7.0 as it does seem to help with this game
    http://www.filehorse.com/download-ga.../old-versions/
    *(note newer versions of cortex do not seen to work as well , at least for me so i stick with 7.0 )

    you can see here what to expect from a GTX 960 ..

    http://www.hardocp.com/article/2015/...4#.VpPpwBUrIdU
    (if i lower my settings to match that page, i get those FPS)

    again your 950 = not as powerful ..you should have bought a GTX 1060 .. gotta say im loving the gigabyte 6 gig one i bought and installed

    also DO NOT USE ANY NVIDIA GAMEWORKS features ..they were busted in the drivers a long time ago

    please see the following threads about this problem .
    http://forums.ubi.com/showthread.php...n-FC4-crashes?


    and this one on the official Nvidia forums
    https://forums.geforce.com/default/t...-in-far-cry-4/

    and yep thats not a game issue that Ubisoft can address ... that = Nvidia ignoring the problem at the driver lvl
    since Ubi nor any Dev has acess to Nvidia gameworks .. thats a closed system , all they need to do is make sure the features are enabled .. if its screwy in the drivers .. then it = busted till they correct the drivers
    Share this post

  3. #3
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    1,966
    and just a note far cry 3 as well as Primal did not use Nvidia game works at all ..so try to use drivers Direct from your card makers site too .. with my Srtix GTX 960 .. all my games ran better with drivers direct from ASUS rather the the crap Nvidia slops out every month with geforce experience

    i never install that bloatware with any of my Nvidia drivers
    Share this post

  4. #4
    Nothing helped,terrain is still blurry if i set it to high or ultra only on medium or low it looks ok but on medium and low distance mountains are ugly,.......i changed my GTX 950 to GTX 1050 Ti and i have same problem.
    Share this post