Thread: PCMap editor won't load | Forums

  1. #1

    Map editor won't load

    Hello out there!

    So.. I can't load Map editor in fc4?
    I'm using ubisoft, and it loads for a few seconds, then it just stops?
    What to do about it?
    Share this post

  2. #2
    Anyone? I played it with no trouble before, on my other pc?
    Share this post

  3. #3
    AKAFootloose's Avatar Member
    Join Date
    Mar 2015
    Location
    USA
    Posts
    416
    What is your PC specs? It must have at least 4 cores. The editor uses a separate core and won't work on a 2 core machine.
    Share this post

  4. #4
    Originally Posted by AKAFootloose Go to original post
    What is your PC specs? It must have at least 4 cores. The editor uses a separate core and won't work on a 2 core machine.
    My specs ain't the problem. I'm running with an i7-6700K and a asus GeForce GTX 1070 DUAL, and 16 gb ram. I can play the game with no trouble, just can't load editor, it loads for 2 seconds, then take me back to uplay.

    Also tried it on my other computer, which runs with i5-7500 and an asus geforce gtx 1060 3gb version oc. and 8 Gb ram
    Share this post

  5. #5
    AKAFootloose's Avatar Member
    Join Date
    Mar 2015
    Location
    USA
    Posts
    416
    Have you tried "Verify Files"? Also, make sure Uplay and FC4 run as administrator "before" you verify files.
    Share this post

  6. #6
    Originally Posted by AKAFootloose Go to original post
    Have you tried "Verify Files"? Also, make sure Uplay and FC4 run as administrator "before" you verify files.
    Yup, did that too.
    Share this post

  7. #7
    Well... I guess i get a Crack for it.
    Share this post

  8. #8
    Anyone else with suggestions?
    It's ubelievable that i cannot get help from support (or whatever you call it).
     1 people found this helpful
    Share this post

  9. #9
    Steve64b's Avatar Senior Member
    Join Date
    Jul 2016
    Location
    http://maps.farcry.eu/
    Posts
    894
    1. You can't load the map editor if Far Cry 4 is already running. Perhaps you have the game running in the background?
    2. In Windows Explorer, navigate to:
    Code:
    %USERPROFILE%\Documents\My Games\Far Cry 4\
    In there, you'll see a folder with random numbers and letters. In that folder, rename the Editor configuration file "EditorGamerProfile.xml" to anything else. This will force the editor to re-create that configuration file, hopefully solving your issue. If not, try opening the XML with Notepad, and tinker with the RenderProfile settings in there to see if you can fix it somehow.
    Share this post

  10. #10
    I know this is sort of an older thread but maybe it will help others out. I had same issue. First thing I tried was to disable MSI Afterburner and Rivatuner. Fraps may also keep it from loading. I'm by far an expert but my guess is that these programs have similar dll files that keep the FC4 Map Editor from hooking it's own dll files when you try to open it.
    As soon as I closed MSI Afterburner it fired up right away. Hope this helps
    Share this post