1. #1

    Absolutely livid with Ubisoft/Uplay support

    TL;DR: Got For Honor in early April. Uplay/For Honor breaks network connectivity when downloading, doesn't work after downloading, support provides four copypasta replies, can't upload additional files for support, and still haven't gotten game to run once nor any meaningful help or resolution from support.

    6/14:
    Ubisoft "regrets" the requirements not being clear 71 days ago. Requirements have still not changed.
    Claims they aren't responsible for a "3rd party" promotion with their logo and "©2017 Ubisoft Entertainment. All Rights Reserved. For Honor..." posted on the Uplay only promotion.
    Cannot get game working and will not provide new game or meaningful support.



    I am extremely frustrated with Ubisoft and Uplay support.

    At the start of April, I wanted to redeem a For Honor key, but couldn't remember my Uplay login. Based on the privacy issues with Origin years ago, I made a very consciously effort to avoid installing Origin and allowed Uplay to install for Far Cry 3 Blood Dragon, but otherwise only purchased games that would run stand alone or in Steam.

    Turns out that was a very smart move.

    First problem I had was when I was trying to log in to Uplay after years of not using it. My error message was that my password was incorrect. Turned out the issue was that I was using a different e-mail than the e-mail I created the account with, so I ended up locking myself out because by the time I was using the right e-mail, Ubisoft has identified my client as having excessive failed logins. To Ubisoft's credit, that error message now reads: "Your login e-mail or password is incorrect. Please try again."

    So almost a month ago, I go to download and play For Honor. After a bit over 10 GB in files being downloaded, my computer's network connectivity dies. Nothing will load. I reboot, everything works again. This continues multiple times as I download For Honor, but between the network connectivity breaking and my slow 12 Mbps down connection, it takes a long time to get the game downloaded.

    Game doesn't work.

    Splash screen comes up, then disappears and Task Manager shows For Honor and Easy Anti Cheat both running. Trying to quit Uplay gives me a warning about quitting For Honor first. Force quitting For Honor shuts down Easy Anti Cheat and allows me to quit Uplay without warning.

    Alright, fine, new PC, let me come back to it after I have all my drivers and software installed and updated.

    I come back to it weeks later. Still broken.

    So now I open a case.

    First reply is literally just: Thank you for reporting this issue. I sincerely apologize for any inconvenience this may have caused you.
    This issue has been forwarded up to the development team for further review.
    If any additional information becomes available, it will be posted to the game's official forum at http://forums.ubi.com and our Support Website (http://support.ubi.com).


    Second reply tl;dr is: Some users had an issue with 1.6 (I had an issue before that), uninstall and reinstall the game. (Which I've already done, and I let Duncan know that)

    (I'm now 100+ GB of downloads and 9 reboots into trying to get this game to work)

    Third reply is: Hey peteer01,
    We apologize for the duration of the issue. Reinstalling the game is the solution that fixes the majority of issues and since the hotfix solved the original issue, this is a key step to take for your issue.
    Let us know if the issue persists after this and we'll be sure to help you.


    Fourth reply tl;dr: I know you already did all the other troubleshooting, and installed the game three times, but why won't you install it on your C:? Install it on your C: and see if that works.

    For a variety of reasons, I do not install any games on my C:, but since it seems impossible to get any support for this without confirming whether or not that solves the issue, I went ahead and put For Honor on my C:. Moved the files. Validated the files. Same exact behavior as the first three attempts to install this game.

    Does not solve the issue.

    Duncan continues to copy and paste dated template replies that reference a folder "ForHonorAlpha" and only provides uninstall instructions for Windows XP through Windows 8. He has never once addressed the network connectivity issue I have with Uplay after 10.5 GB or so.

    I told Duncan I'm ready to cut my losses with this game and Uplay and wanted to either get a Steam code (Steam doesn't have issues with my downloading, regardless of whether or not it's more than 10GB or not) or a different game so that I simply play a game instead of wasting my time with these technical issues, but Duncan curtly replied, "We are unable to provide new keys or games."

    Between privacy and security concerns, this poor support and the lack of stability, this is why I avoid clients like Origin and Uplay.

    I did try to chat once, but it was during the 1.6 issue, and my browser couldn't even come up with an estimate of how long I'd have to wait in queue in a reasonable period of time, so I submitted my ticket update through the website and waited.

    I am beyond disappointed at the slow, unhelpful, dated template replies. I created and shared all the logs that the For Honor troubleshooting steps requested and shared that information. I've documented and taken screenshots of every step in hope of giving Ubisoft the info they need to provide support...and, well, I don't think Duncan cares at all, and I doubt anyone else is seeing my ticket from the 26th.

    I can't even update my ticket with the screenshot of For Honor running in Task Manager because the ticket won't allow more than 5 MB of files, and I've already exceeded that.

    ::sigh:: This is so unnecessarily frustrating. It's certainly making me glad I buy all my games through Steam, and steering me away from Ubisoft games altogether.

    For anyone who wants to see some of the steps I've documented, there's a whole album here:
    http://imgur.com/a/fKUjZ
    Share this post

  2. #2
    UbiChrisMANG's Avatar Community Representative
    Join Date
    Jun 2015
    Posts
    1,332
    Hi peteer01, welcome to the forums!

    I'm terribly sorry about the frustrating time you have had with this. I received your private message and will step in and help from there, look for a private message reply from me shortly.
     1 people found this helpful
    Share this post

  3. #3

    Thank you, Chris

    Thank you, Chris. I got your PM, and hope you can help with this. I appreciate your intervention.
    Share this post

  4. #4

    update

    Good, bad or ugly, I figured I'd update this thread occasionally so people don't have to wonder what happened:

    Initial support guy followed up with me again, with this as his only troubleshooting step:
    We suggest to try an sfc scan to see if a Windows file or service is conflicting with For Honor and creating this download/launch issue.
    If he had read my case notes, he would have seen that on April 29th I had already tried that step on my own and included that in my case notes in my update two messages ago:
    At this point, I have downloaded 100 GB in data for a game that I have never been able to play. I have run "SFC.exe /SCANNOW" and "dism /online /cleanup-image /restorehealth", and I do not have these issues with any other game.
    (Granted, I didn't explicitly confirm that no problems were found, but I think the issue was that that support engineer really just wasn't paying any attention to the feedback I was giving him.)

    New engineer is off to a better start, so here's my latest reply to him after he asked me to uninstall and reinstall video drivers, and then upload System Information > Software Environment > Windows Error Reporting as an .nfo file if that didn't resolve the issue. Here's my reply/thread update:

    Thank you for the detailed reply. Unfortunately, these troubleshooting steps were unsuccessful, but I didn't get my hopes up too much because I'd already tried reinstalling the driver.

    Yes, Uplay is installed in C:\Program Files (x86). When installing ForHonor, I copy the game files from an E: to C:\ForHonor. I then discover the folder in Uplay, which avoids spending several hours and rebooting multilple times to download the game.


    Here's the steps I took:

    1. Uninstalled all AMD drivers and software, including some registry entries to ensure the OS was as free from AMD drivers and Radeon Software as possible. (Confirmed no AMD software was installed or running)
    2. Upon shutting down for a reboot, a major Windows patch was applied.
    3. Upon reboot, confirmed no AMD software was installed or running, and specifically downloaded the 400 Series AMD driver install file, as I've already used the autodetect install file more than once, and wanted to try a different method in case it gave a different result.
    4. Installed the latest Radeon driver install .exe file.
    5. Declined optional Relive software (again, just trying something slightly different, in case it helped.)
    6. Rebooted again.
    7. Without anything else manually started, ran Uplay as an Administrator from the Start menu.
    8. Copied ForHonor folder to C:\
    9. Discovered ForHonor with Uplay on C:\ (same drive as Uplay is installed to)
    10. Clicked on Play for For Honor through Uplay
    11. As always (on first attempt after install), For Honor splash screen comes up with Installing Direct X 1/2.... under it. (This shows up on whatever screen Uplay is residing in)
    12. After that, For Honor splash screen shows up on center of center (primary) screen for several seconds, before disappearing.
    13. Open Task Manager and confirm that For Honor and Easy Anti Cheat are running. Force quit For Honor.
    14. Verify For Honor files to confirm nothing has happened to files since the last time I verified them. ("All game files have been successfully validated.")
    15. Followed your steps below to run msinfo32 and save Windows Error Reporting output as an .nfo file. Please see "170503-peteer01.nfo", uploaded to this support ticket.

    I am hopeful the new information will be helpful. At the very least we can rule out all the initial troubleshooting steps, including driver, file, drive and OS corruption.
    I won't be providing every single update (unless lots of people chime in saying they want that), but I'll try to update this periodically in hopes it helps someone else in the future.
    Share this post

  5. #5
    Was updated on 5/4, replied back on 5/4 after ensuring DirectX, C++ and .NET were all installed and up to date:

    Followed all steps:

    1. DirectX
    Installed per instructions. Most time consuming install.

    2. Microsoft Visual C++ 2010
    Told newer version already installed.

    3. Microsoft Visual C++ 2010 SP1
    Given option to repair or uninstall. Selected repair.

    4. Microsoft .NET Framework 3.5 SP1
    Told already installed, no option to repair.

    5. Microsoft .NET Framework 4.0
    6. Microsoft .NET Framework 4.5
    Told already installed, no option to repair.

    I attempted to run For Honor, and just like every other attempt, it started by throwing a splash screen up on the right screen, saying it was installing Direct X (which is already installed), then it threw a splash screen up on the center screen, then the the splash screen disappeared, the game did not start, and the game shows as running in Task Manager.

    Those steps did not fix the problem. Have the logs provided any insight? What is the next step?
    Haven't gotten any contact from Ubisoft since sending that almost a week ago. ::sigh::
    Share this post

  6. #6
    UbiChrisMANG's Avatar Community Representative
    Join Date
    Jun 2015
    Posts
    1,332
    Hi peeter01! I received your private message and have replied back, go ahead and check it when you have a chance.
     1 people found this helpful
    Share this post

  7. #7
    Originally Posted by UbiChrisMANG Go to original post
    Hi peeter01! I received your private message and have replied back, go ahead and check it when you have a chance.
    Looks like Chris (who is the one awesome person I've interacted with at Ubisoft) was able to shake a reply out of the support tree. Here's what I got:

    What I would be worried about in this case is the possibility that the hardware you are playing on is not the hardware that the game was tested for. I can see that most of it is meant to be fore a server and we have seen occasions where are games don't run properly on such hardware. In this case, due to the processor you have, I'm worried the game isn't running properly when it tries to use the 28 processors available, as it wasn't tested on a system with that configuration. Something you can do, but I'm not able to provide specifics on, since it is outside the realm of our normal troubleshooting, is change the affinity settings for For Honor. This is a way to cap the processors it uses and hopefully allow it to run properly.
    For anyone who's wondering, my home PC has a 14 core ("28" hyperthreaded) Xeon 2690 v4 with 256 GB of 2400 MHz ECC RAM with a 480 RX graphics card running Windows 10 Pro. According to the minimum and recommended specs, there's no reason my computer shouldn't be able to run this game, and while I understand that I have more server level hardware than the average gaming PC, none of my other +100 games has problems running on this OS/SW/HW combination.

    It's getting scarily close to feeling like Ubisoft's support's message is, "because you're computer's high end modern hardware isn't what we test for, you might be out of luck."

    I tried several core permutations with both task manager (which is not persistent) and "start /affinity..." to launch the game, and no combination of cores changed the game's unwillingness to start past the splash screen.

    I've made it crystal clear that after the hours of reinstalls, reboots, and other troubleshooting efforts that at this point I'd be fine with just changing the game for something that works. (I would have been able to buy several copies of a full price retail game for the amount of time I've invested trying to get this one to work.)

    As always, I'll update this one way or the other. If I don't, just assume Ubisoft support stopped replying and I don't have an update.
    Share this post

  8. #8
    4/26 Proactively sent support DxDiag.txt
    5/3 Send first Windows Error Reporting file after requested by support
    5/15 Support asks for DxDiag.txt and Windows Error Reporting files. (I create new versions of each and upload)

    No reply since then...

    More than a month and a half with a non-working game now. Hope this helps other people with avoid the same experience.

    The last time Steam made me wait for a response, they proactively gave me a game from my wishlist without me even complaining.
    Share this post

  9. #9
    peteer01

    Expect a LONG wait or no help at all. Worst support in this business. Best thing you can do is find a solution elsewhere or get you money back, move on and never look back at this company again.

    Someone suggested this game to me, so I came back to see whether anything had changed with this company. Apparently nothing has changed.

    Hope you find a solution and can enjoy the product you paid for.
     1 people found this helpful
    Share this post

  10. #10
    Originally Posted by Dolgothir Go to original post
    peteer01

    Expect a LONG wait or no help at all. Worst support in this business. Best thing you can do is find a solution elsewhere or get you money back, move on and never look back at this company again.

    Someone suggested this game to me, so I came back to see whether anything had changed with this company. Apparently nothing has changed.

    Hope you find a solution and can enjoy the product you paid for.
    9 months for me and they have are an absolute joke. No money back offer. I have never even been able to play the damn game I bought.
     2 people found this helpful
    Share this post