Thread: PCFar Cry 3 Windows 10 x64 NOT WORKING-CRASHING pathetic ubisoft | Forums

  1. #1

    Far Cry 3 Windows 10 x64 NOT WORKING-CRASHING pathetic ubisoft

    so far i already tried
    compatibility mode
    verify game files
    EVEN CRACKING THE GAME

    NO LUCK

    in this situation i GLADLY say to UPLAY

    USUCK ring a bell?

    ...................../´¯/)
    ..................../¯../
    .................../..../
    ............./´¯/'...'/´¯¯`·¸
    ........../'/.../..../......./¨¯\
    ........('(...´...´.... ¯~/'...')
    .........\.................'...../
    ..........''...\.......... _.·´
    ............\..............(
    ..............\.............\...
    edit
    now i played
    PLAY CRY 3
    and i know WHY the game title is FAR CRY = MADE CRY
    no need teach me to cry bozo


    update : problem solved see post #7
    Share this post

  2. #2
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    2,031
    works perfect here with Win 10 Pro 64 .. i finished the game a week ago and i'm halfway thru it again on a laptop with Win 10 Home 64 bit

    Specs Desktop Windows 10 Pro 64 bit (Clean install latest version 1511 build 10586)

    Asus P5 B motherboard
    Intel Q 9650 core 2 Quad @ 3.0 ghz / ran fine on my Intel core 2 quad Q6600 as well
    8 gig of DDR 2 800 ram
    Asus Strix GTX 960
    Creative labs SB live 24 bit card
    2 PNY 256 gig SSD drives , one for os the other for games

    Laptop Windows 10 Home 64 bit (clean install latest version 1511 build 10586)
    Lenovo model G505s
    AMD A 10 5750 APU with AMD 8650 G graphics
    16 gig of DDR 3 ram
    Samsung evo 840 500 gig SSD drive

    no problems at all , set both steam as well as uplay to run as administrator on both systems

    if your getting a crash with Xaudio2_7.dll see this thred .. you only need to make one change with a stupid win 10 setting thats enabled by default , its not a ubisoft or Uplay problem at all :lol http://steamcommunity.com/app/220240...1136920428261/
     1 people found this helpful
    Share this post

  3. #3
    I'm also having this same issue, AGAIN. Back when the updated uplay in nov I was crashing with almost every uplay game that I had through steam, something with steams beta client was causing some conflict so I revered to the standard version. The only way to get the games to play was to set to admin (for some games anyway) here is a link to the thread that was created,
    http://forums.ubi.com/showthread.php...er-2015-update
    Now that they've finalized their clients the problems are persisting and ubisoft ignores the issue again. Now I have to go back and try all my suggested methods to see if all these games are unplayable again. Thank you for that.

    Computer specs
    Windows 10 home
    i7 4790
    RAM 16gb
    Videocard: AMD R9 270 2gb

    Here are some of the workarounds I had to use
    Child of light - Will not play through steam unless setting the "run as administrator" box checked, will play through steam after change.
    Assassin's Creed: Freedom Cry - Will not play through steam unless setting the "run as administrator" box checked, will play through steam after change.
    Farcry 3/blood dragon - Will not play though steam, will play if starting the farcry3_d3d11.exe file (does not register the game as being played on steam ). Setting the farcry3_d2d11.exe to "run as administrator" will cause Error 740.

    Community managers, this is not an isolated issue. If people are angry it's because they do not like being ignored when they've paid to play these games and wish some level of service.

    Edit: upon further testing, these games seem to crash when qutting to the desktop, I'm not sure if that means anything but its pretty odd it's only happening to Uplay games.
    Share this post

  4. #4
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    2,031
    i just installed and tried Far Cry blood dragon , it also works perfect . the only thing i did was i set Steam to launch as Administrator

    clicked on my start button and did the same thing with Uplay (right clicked it and selected run as administrator )

    went to my games library , installed Blood dragon

    hit my Play button and the game worked fine

    Asus P5 B motherboard
    Intel Q 9650 core 2 Quad @ 3.0 ghz / ran fine on my Intel core 2 quad Q6600 as well
    8 gig of DDR 2 800 ram
    Asus Strix GTX 960
    Creative labs SB live 24 bit card
    2 PNY 256 gig SSD drives , one for os the other for games
    Windows 10 Pro 64 bit <-clean install

    you may have a problem because your running an AMD video card ..
    they did release a bad driver last month that caused both Far Cry 3 and 4 to crash on launch
    try back dateing your Video Driver see
    http://forums.ubi.com/forumdisplay.php/741-Far-Cry-4-PC-Discussion

    other AMD drivers also have had problems with some games contact AMD support
    i got sick of bad AMD driver support and pulled my Asus R 9 270 X months ago , and installed my Asus Strix GTX 960

    the AMD driver i use on my only system that has Win 10 home and my AMD APU in it is version 15.2
    and on both of my systems i used the windows 10 show hide driver update tool to keep my drivers from updating from Microsoft update
    https://support.microsoft.com/en-us/kb/3073930

    you may also be experiencing problems if you installed windows 10 as an upgrade only , sometimes with a windows upgrade its best to perform a clean install of your operating system and all of your drivers , even after i did perform a Clean install of my Windows 10 operating system i did have to check my drivers as the OS did not install the proper driver for my sound card , my network adapter also had a better updated drive i had to get , windows 10 also installed an outdated driver for my Nvidia GPU and my Intel chipset
    i also had the same experience with my Lenovo Laptop , several drivers that the operating system installed were incorrect driver versions for my hardware , and better drivers were available from my system manufacturer

    with your R 9 270 X card you may be able to run older Windows 8.1 64 bit drivers under Windows 10 (the best driver i had when i had my 270 x in was 14.12 from last December)
    these drivers may lack full direct X 12 support , but there are only 2 games out so far that even support Direct X 12
    Ashes of Singularity and Ark survival evolved , neither of these games are complete yet

    right now i am running an Nvidia Windows 8.1 64 bit driver for my GTX 960 , it gives me more stable frame-rates in games and applications then the current Nvidia Windows 10 drivers do , as far as Direct X 12 support , by the time any games DO ship that need Direct X 12 .. there will be better drivers from both AMD as well as Nvidia to support them
    Share this post

  5. #5
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    2,031
    also these games were created well before Windows 10 was even in development, windows 8 shipped in September 2012 , far cry 3 was released only a few months later
    so of course Ubisoft will say Windows 10 is not a fully supported operating system for the games , as Windows 10 only shipped in July of 2015 and the games were created years before that

    i have not found a single game that does not run on windows 10 perfectly , once you make the appropriate adjustments to allow it to run, this includes running as an Administrator , having the proper drivers installed , and limiting the amount of overlays and back round applications you have open when you launch the games

    if you have a realtek audio device installed you may get crashes , again Microsoft blamed Ubisoft for the Xaudio2_7dll unloaded problem with Far Cry 3 ..
    http://blogs.msdn.com/b/chuckw/archi...audio-2-7.aspx

    which is bull, since windows 8 used the same module ..and the crash didn't happen with the Windows 8 operating system


    when after all its a default Windows 10 Tablet setting for an onscreen Keyboard that causes the problem
    http://answers.microsoft.com/en-us/w...?page=2&auth=1

    to correct the problem you need to check your windows 10 settings

    open Action center
    go to all settings

    open system

    open tablet settings

    move the two sliders to the left to disable tablet modes , those settings allow for an on screen keyboard which may act as an overlay that many games and applications may not like

    also try to disable the Uplay overlay in its settings same with the Steam overlay
    if your not useing the Steam overlay.. disable it in Steam settings \ ingame
    if your not useing the Uplay overlay in game... disable it in Uplay settings \ General

    i have only the uplay overlay enabled .. the Steam overlay i always keep shut off , as some games do not like alot of overlay programs running
    Share this post

  6. #6
    Hey thanks for your help it's much appreciated, I should mention I had no problems playing these games before on windows 10 before it was only after this last update to uplay that all my games that use uplay all crash when launching, Farcry 3, blood dragon, Assassin's creed freedom cry, Child of light to name a few. All these games require me to set them as admin to play now except farcry which won't launch as admin, but will launch if I launch it from parent folder. These workarounds are ok for now, but I'm dreading the moment when these tricks stop working and I am left with some dud new game like RB siege or any future assasins creed games. I will try to revert my drivers like you suggested since it seems the only thing I can do right now but I just don't see how this only effects uplay games that are on steam (games on uplay only are not effected) and not others.

    Edit: sorry I forgot to mention I also tried to disable the overlays from Raptr, Steam and UPlay, as well as the standard compatibility settings. Running as admin does help but I am concerned for future games.
    Share this post

  7. #7

    problem solved like a million bucks

    Originally Posted by WID992007 Go to original post
    works perfect here with Win 10 Pro 64 .. i finished the game a week ago and i'm halfway thru it again on a laptop with Win 10 Home 64 bit

    Specs Desktop Windows 10 Pro 64 bit (Clean install latest version 1511 build 10586)

    Asus P5 B motherboard
    Intel Q 9650 core 2 Quad @ 3.0 ghz / ran fine on my Intel core 2 quad Q6600 as well
    8 gig of DDR 2 800 ram
    Asus Strix GTX 960
    Creative labs SB live 24 bit card
    2 PNY 256 gig SSD drives , one for os the other for games

    Laptop Windows 10 Home 64 bit (clean install latest version 1511 build 10586)
    Lenovo model G505s
    AMD A 10 5750 APU with AMD 8650 G graphics
    16 gig of DDR 3 ram
    Samsung evo 840 500 gig SSD drive

    no problems at all , set both steam as well as uplay to run as administrator on both systems

    if your getting a crash with Xaudio2_7.dll see this thred .. you only need to make one change with a stupid win 10 setting thats enabled by default , its not a ubisoft or Uplay problem at all :lol http://steamcommunity.com/app/220240...1136920428261/
    hi WID
    thanks for the reply earlier, hen you post about this post [quote] i already uninstalled the game, when i read your post i installed the game again [after i updated my win 10]
    yes now my game is working fine under win 10 x64
    i dont know why but its suddenly work fine after the 2nd installation

    here my step by step from the trouble - problem solved solution [i hope it can help the ppl who having same trouble]


    installed FC3
    auto update...note when you update fc 3 try to backup ur RAW update exe the file location is C:\Users\[ur user name]\AppData\Local\Ubisoft
    the patch about around 250MB seek the file when its done update dont launch it yet but copy the patch [backup] after backup you can execute "yes" in update launcher
    crash
    uninstall
    update win 10 to the latest update and restart
    install FC3 again
    then update again but now i using the patch i saved earlier [not auto update]
    and its works until now


    additional, dont launch RAPTR from AMD [maybe this software can cause ur game crash...maybe] so i disable it
    to prevent auto update after installing FC3 DONT LAUNCH THE GAME after installed
    Share this post

  8. #8

    Oyun açılmıyor

    Window 10 a yukledim oyun acilmiyor. Aciliyor belli bi süre sonra kapaniyor lutfen yardimci olun
    Share this post

  9. #9

    0xc000007b crash

    Вылетала ошибка 0xc000007b при запуске FarCry 3 на Windows 10 x64
    скачал msvcp100.dll, msvcr100.dll и xinput1_3.dll для 32-bit и скопировал в папку C:\Windows\SysWOW64\
    Заработало!
    Share this post

  10. #10
    Try the DX9 version of the game. DX11 is touch and go when it comes to stability.
    Share this post