Thread: PCUplay - A Ubisoft service is not available at the moment | Forums

  1. #11

    You legend, you

    Originally Posted by Kimochuwi Go to original post
    I fixed mine by going to: C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher and changing UbisoftGameLauncher.exe (and the 64 one), upc.exe, uplay.exe uplayservice.exe to run as admin.

    Right-click > Properties > Compatibility > Run as Administrator

    I love you, you freaking legendary beast!
     1 people found this helpful
    Share this post

  2. #12
    I am getting this error non stop the past 2 days and Ubisoft has been NO HELP. I even chatted with their support and they gave me no good info on how to fix this. Anyone else still running into this?
    Share this post

  3. #13
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    sounds like you have a backround app issue ????

    i connect fine here in the USA

    BACKROUND APPLICATIONS may also cause the game to not launch properly and you may need Exit out of them, or reconfigure them to work properly with Far Cry 4 known apps that can cause this are



    C. Riva Tuner Statistics Server

    D. DXtory

    E. Motionin Joy

    F. Anti Virus or Firewall software (AVG , Comodo, Bullguard etc.. <-- check settings)

    G. MSI true Color

    H. Evolve gameing client

    I. AMD Raptr \ AMD Gaming Evolved

    J. TeamViewer

    K. Overwolf

    L. Nvidia Geforce Experience Shadow Play as of Driver 361.75 in Jan 2016

    see this thred to possibly fix issues with afterburner causing black screen!?

    Please see this Page where it mentions Backround Applications and how you can try to see if one is possibly causing your issue with the game NOT starting or hanging

    And if your running windows 10 make sure you launch both Steam and Uplay as Run As ADMINISTRATOR

    this game was shipped well before windows 10 did ...and yes you may need to take that extra step to run the game
    this games engine was created years before windows 10 shipped and that change may needed to allow the game to write any save files and or configuration files , windows 10 may handle file security \ permissions in a different way, then previous operating systems did.

    if you have a problem... try this

    right click on the games .exe file

    select properties

    select the compatability tab

    check the box that says run as Administrator

    set it to run in a windows 7 compatabilty mode

    you can also run the windows 10 compatablilty trouble shooter from that same window
    Share this post

  4. #14
    I'm getting the exact same thing now. Was fine two days ago when I played some GR Wildlands. Did not use the PC at all yesterday, and tonight I get this error with every attempt. Nothing has changed since I played last, no ports have been adjusted on my PC nor within the router, my rig hasn't even been powered on since I last played.
    Share this post

  5. #15
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    they may have had a server issue you can always check here


    as they do post if there is any problem with the servers

    and yes they were doing maintenance most likely
    Scheduled maintenance on April 20th.PS4: 10:00-10:30AM ETXB1: 10:30-11:00AM ETPC: 11:00-11:30AM ET
    Share this post

  6. #16

    This will work

    Hi! I had that issue for around several weeks and I only fixed it about 15 minutes ago all you wanty to do is go to your settings on the Uplay launcher before it asks you to sign in then it will bring you to your VPN at the bottom you want to click on LAN settings and deselect use LAN as proxy and then try and login and it should work

    Hopefully this works for you just try it even if you do not think it will work as it worked for me!
    Share this post

  7. #17

    A ubisoft service is unavailable at the moment

    Hi guys, i installed far cry 4 pc and completed the setup then i needed to activate the code for which i needed to login but it showed me that the service is unavailable. I don't know if the servers are down or something is wrong from my side. But i tried many solutions but none were after almost one day past it is giving me the same error
    Share this post

  8. #18

    Well it did something.

    So I made some things run as admin, but now when I try to open Watch_Dogs 2 using Steam, the splash screen lingers for a second like normal, but then closes without opening the Uplay thing. So it did something.
    Share this post

  9. #19

    Something new.

    Well, changed the setting on the game itself, so now we're back to the beginning. Open Steam, open the game, Uplay menu pops up after the splash screen, then the message.
    Share this post

  10. #20
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    please contact Ubisoft support Directly if your still having an issue

    If you continue to have issues PLEASE
    open a support ticket or contact Ubi support for your region
    you can find phone number\ support options \ and support hours information @

    everythikng is working just fine here on my end .. so it may be an issue with your PC

    please see this page and clear your DNS cache too

    as well as launch Uplay or steam as run as Administrator and verify your game files

    To verify your files if you bought the game thru Steam ..\EXIT Steam ..right click your steam icon run as Administrator

    to launch Steam

    then go to your Steam games library

    right clik on far cry 4

    select properties

    select local files

    select verify Integrity of game cache

    it takes a few min to do but its faster the redownloading your entire game , if its only a few files that were corrupt or installed incorrectly .... this in many cases will fix your problems

    If you have the U play only Version of the game you can also verify your game files with U play

    if you have the game via u play only here are instructions how to verify your game files thru their client
    Again its probably best to make sure you launch Uplay as RUN as Administrator when you do a file verify
    see the bottom of the page

    1. In the Uplay client, click on Games.

    2. Click on the game you wish to verify the files for. You will land on a window that looks like the one below. Click on the Properties and choose Verify files.

    3. Uplay will then begin the process of checking your files.

    4. When the process is complete, you will be met with the following window that will display the results of the scan and tell you whether or not files need to be redownloaded or not.
    Share this post