PDA

View Full Version : [PC] Uplay Overlay Not Working



TechiCanadian
12-19-2014, 09:10 PM
Hi there, My name is Byron.

I have a problem with the Uplay Overlay, when I do (Shift+F2) nothing happens, even when I click the in-game Uplay button nothing opens up.
I made sure i have no Software interfering, all my PC drivers are up to date. And i have tried to disable and re-enable the Overlay and still nothing.
I have search the web and tried everything. All i want to do is buy In-Game Money (Crew Credits).
Please someone help me with this.

Thank you for your time :)

-Byron (TechiCanadian)

Ubi-Leorthian
12-22-2014, 02:55 PM
Hello TechiCanadian,

Thank you for contacting us with your question. I just opened up a game and the overlay opened without issue for me when I pressed Shift + F2. I know that when Watch_Dogs was released, players of that game couldn't initially open their Uplay overlay if they had recording software (fraps, bandicam etc) running when they opened it, but they could start those programs after the game was already running and it would work fine. However I've not seen other users reporting this issue with The Crew though, so I'm uncertain what could be causing it for you.

I'd suggest you contact the Ubisoft Support team to see if they are aware of a solution. The support team have information on game-specific issues and technical details that forum moderators don't have. You can contact support through our ticket system's webform found by clicking on "My questions" on this page: https://support.ubi.com and then clicking "Ask a Question".

If you have any issues using the webform, or if you cannot access your account, you can contact support for assistance through their Facebook page (https://www.facebook.com/UbisoftSupport), Twitter account (https://twitter.com/UbisoftSupport) or by phone (https://support.ubi.com/en-us/FAQ.aspx?platformid=60&brandid=2030&productid=3888&faqid=kA030000000eiChCAI).

Exxoc
12-24-2014, 12:09 PM
We are in the same boat, just a few days ago the overlay was working fine but up untill recently it doesn't start. When launching The Crew the message telling me that I can press Shift-F2 to open doesn't appear like it normally would. I tried to press the Uplay buttons in the main menu but like you mentioned nothing happens. I as well have no other software running but Uplay itself, and no other overlay is interfering with it. It's like the game isn't compatible.

Ubi-Leorthian
12-24-2014, 01:35 PM
Just to check, you haven't accidentally turned off the option to use the overlay have you? If you go to the settings menu in your Uplay client (click on the gear icon in the top right then choose Settings) there is an option labelled "Enable in-game overlay for supported games". Is the box next to that options marked with tick? If not, make sure it is then click Save.

Exxoc
12-24-2014, 02:27 PM
I have disabled and enabled it, redownloaded Uplay and The Crew + verified it's files. Only thing I haven't done is test it on another of your games which I will once Unity has finished downloading.


Well, haven't changed anything since I wrote the above text, and now it works for both mentioned games. I don't know why or how come it was broke before but I guess you'll never understand these computers will you? :D

cobra272
03-10-2015, 06:35 PM
Funny when I press shift f2 in the crew the overlay opens up then game hangs, have to bring up task manager which says uplay running the crew not responding ever since version 5 fiasco. :confused: