PDA

View Full Version : AC Unity - 1.4.0 - Performance is a nightmare compared to 1.3.0 (downgrade possible?)



Yamatsan
12-19-2014, 03:29 PM
Hello everyone,

So I recently just updated to version 1.4.0 of Assassins Creed Unity and I am really disappointed.
Patch 4 is supposed to increase performance and resolve performance problems. Well, sadly enough for me this is not the case...

On version 1.3.0 my fps was an average of 45-50 on the High graphics preset. This was perfectly playable for me.
On version 1.4.0 my average fps is 24 on the High graphics preset, the game is unplayable for me.

And that's not all, the game now shows all kinds of bugs I have never experienced before. I am really disappointed by Ubisoft.
Due to this low framerate I can't play/enjoy the game anymore. For me it was perfectly fine on version 1.3.0.

I would like a possibility to downgrade back to version 1.3.0.
I did not make a backup of the entire game before updating, which I of course could have done but I trusted Ubisoft in that this update would not introduce any problems.
So reverting to version 1.3.0 from a backup is not an option.

I suggest to everyone that is satisfied with the experience on version 1.3.0 to not update to version 1.4.0!

Below you can find my system specs and other information.
CPU: Intel i7 4770 @ 3,9 Ghz
GPU: Nvidia GeForce GTX 670
RAM: 8GB DDR3 1600 Mhz
OS: Windows 8.1 64-Bit
The game is running of an 3TB 7200 RPM HDD and the OS and Uplay are on a 128GB SSD.
Running the GeForce Game Ready Driver - WHQL (344.75) as stated by Nvidia GeForce Experience.

Framerate on version 1.3.0 of AC Unity with the High graphics preset (Resolution: 1920x1200 Anti-Aliasing: FXAA)
Min: 30
Average: 45-50
Max: 60

Framerate on version 1.4.0 of AC Unity with the High graphics preset (Resolution: 1920x1200 Anti-Aliasing: FXAA)
Min: 20
Average: 24
Max: 30

Greetings,
Björn (A.K.A Yamatsan)


UPDATE:
Ubisoft, I would like the possibility to downgrade back to version 1.3 of ACU.
That's all, if you give me back version 1.3 I am the happiest man on earth!

(A moderator on this forum already tried to help me with downgrading, but without succes. It's unpossible to downgrade without the help of you, Ubisoft.)

UPDATE 2:
Still no solution.
After a long discussion with support they could not find a solution tot this problem. They also told me that there is no possibility to downgrade back to version 1.3.0. The latest NVIDIA driver (347.25) did improve performance (±3 FPS) but not enough to give me the same performance as on version 1.3.0 of ACU. I hope that if there is ever an patch 1.5.0 it will restore my performance back to how it was on version 1.3.0.

Smrda94
12-19-2014, 03:35 PM
Hello everyone,

So I recently just updated to version 1.4.0 of Assassins Creed Unity and I am really disappointed.
Patch 4 is supposed to increase performance and resolve performance problems. Well, sadly enough for me this is not the case...

On version 1.3.0 my fps was an average of 45-50 on the High graphics preset. This was perfectly playable for me.
On version 1.4.0 my average fps is 24 on the High graphics preset, the game is unplayable for me.

And that's not all, the game now shows all kinds of bugs I have never experienced before. I am really disappointed by Ubisoft.
Due to this low framerate I can't play/enjoy the game anymore. For me it was perfectly fine on version 1.3.0.

I would like a possibility to downgrade back to version 1.3.0.
I did not make a backup of the entire game before updating, which I of course could have done but I trusted Ubisoft in that this update would not introduce any problems.
So reverting to version 1.3.0 from a backup is not an option.

I suggest to everyone that is satisfied with the experience on version 1.3.0 to not update to version 1.4.0!

Below you can find my system specs and other information.
CPU: Intel i7 4770 @ 3,9 Ghz
GPU: Nvidia GeForce GTX 670
RAM: 8GB DDR3 1600 Mhz
OS: Windows 8.1 64-Bit
The game is running of an 3TB 7200 RPM HDD and the OS and Uplay are on a 128GB SSD.
Running the GeForce Game Ready Driver - WHQL (344.75) as stated by Nvidia GeForce Experience.

Framerate on version 1.3.0 of AC Unity with the High graphics preset:
Min: 30
Average: 45-50
Max: 60

Framerate on version 1.4.0 of AC Unity with the High graphics preset:
Min: 20
Average: 24
Max: 30

Greetings,
Björn (A.K.A Yamatsan)




Omg same problem here .... i had to download beta drivers few min ago just to be able to enter game .. patch 1.3 was best 1.4 is big fail ...i get random freezes for 1-2 sec even on high setigs and on 1.3 i used Ultra high details and no problem
Fx 6300
Gtx 970
8 GB ram

holydruid
12-19-2014, 03:44 PM
What resolution were you playing on? no way 1080p with a 670 and getting over 30 fps.

Smrda94
12-19-2014, 03:46 PM
And i just crashed now ACU exe stopped working again this **** .. rly Ubisoft rly .....

CaptainKao
12-19-2014, 03:47 PM
Patch 1.4 fixed all the issues I had with the game. The frame rate stays around 60fps no matter what's on screen (occasional drop to 55). Stuttering is gone.

I play the game at 1080p ultra settings with VSync on, shadows high, HBAO+, AA - Fxaa, and refresh rate 60.

Check the update didn't change your refresh rate to 30 or 24.

Yamatsan
12-19-2014, 03:53 PM
What resolution were you playing on? no way 1080p with a 670 and getting over 30 fps.

I am playing on 1920x1200.

holydruid
12-19-2014, 04:01 PM
I am playing on 1920x1200.

find it very hard to believe you had average of 45+ fps with that spec and graphics card.

Yamatsan
12-19-2014, 04:21 PM
Patch 1.4 fixed all the issues I had with the game. The frame rate stays around 60fps no matter what's on screen (occasional drop to 55). Stuttering is gone.

I play the game at 1080p ultra settings with VSync on, shadows high, HBAO+, AA - Fxaa, and refresh rate 60.

Check the update didn't change your refresh rate to 30 or 24.

My refresh rate is still at 60hz.

DarkSolitudeX
12-19-2014, 04:57 PM
I see people that have problems with 1.4 and others that don't. I really don't know if I should update from 1.3

Yamatsan
12-19-2014, 05:06 PM
I see people that have problems with 1.4 and others that don't. I really don't know if I should update from 1.3

Make a backup of the entire game and then update, if you have problems you could always try to restore the backup.

Trih333
12-19-2014, 05:16 PM
find it very hard to believe you had average of 45+ fps with that spec and graphics card.


What the hell are you talking about, i also have a 670 and had the same 45+ fps with FXAA and Low shadow(i don't see the difference) and everything else max

I still haven't played with the new patch on though, so I 'll see if I have the same problem


EDIT
OH I SEE
I have a gtx 970 not 670
Yeeaaaaah i can't see how you can have those framerate with a 670

CaptainKao
12-19-2014, 05:16 PM
I see people that have problems with 1.4 and others that don't. I really don't know if I should update from 1.3

What's your system spec?

DarkSolitudeX
12-19-2014, 05:25 PM
What's your system spec?

i5 4670
16GB DDR3
GTX 970 FTW (no SLI)

CaptainKao
12-19-2014, 05:32 PM
Bite the bullet. Download the update. Your system is similar to mine. The game is running great for me.

JacqueTheReaper
12-19-2014, 05:34 PM
Well 1.4.0 didnt make anything worse for me...it just stayed as ****ty as before. No improvement at all.
Texture draw distance is still awful, every building farther away than 1 Block is looks horrible.

bbucha
12-19-2014, 05:43 PM
Patch 1.4 fixed all the issues I had with the game. The frame rate stays around 60fps no matter what's on screen (occasional drop to 55). Stuttering is gone.

I play the game at 1080p ultra settings with VSync on, shadows high, HBAO+, AA - Fxaa, and refresh rate 60.

Check the update didn't change your refresh rate to 30 or 24.

Well i would say that what you claim is impossible.
I have played during day morning and night i also run an OC 970GTX Vsync and the same settings and i notice drops from 60-45 FPS so there is no way that you have the special olympic GTX that only drops 5 FPS maximum sorry but that simply cant be true.

I also have the same FPS with Nvidia soft shadows turned on for some reason in patch4 and that does not make any sense to me.

Overall it pretty much feels the same as before...

Blackred689
12-19-2014, 05:59 PM
I'm mostly reading not much has changed and wondering what is exactly in the uplay 5.4GB patch? MGS GZ is 3GB lol.

Do I want 5GB of space just taken up for nothing

CaptainKao
12-19-2014, 06:01 PM
Well i would say that what you claim is impossible.
I have played during day morning and night i also run an OC 970GTX Vsync and the same settings and i notice drops from 60-45 FPS so there is no way that you have the special olympic GTX that only drops 5 FPS maximum sorry but that simply cant be true.

I also have the same FPS with Nvidia soft shadows turned on for some reason in patch4 and that does not make any sense to me.

Overall it pretty much feels the same as before...

I'm not joking. Huge improvement. Generally 60fps all the time. The frame rate drops to 49 and fluctuates up to 60 at the Cafe Theatre. I've only played the game with the new update for a couple of hours. I haven't checked out every area. But the ones I have, the frame rates stay around 60 fps.

Tammy2505
12-19-2014, 06:20 PM
Hi please do not laugh, because I only have a small PC.

I can play the game with the third patch without stutter.
After the fourth patch only slide in the same resolution and color settings.

Age monitor since I can not afford a new me.

Resolution: 1280x1024
Ambient Quality: Ultra-high
Texture Quality: Ultra-high
Shadow Quality: High
Ambient Occulusion: SSAO
Anti-aliasing quality: 2x MSAA
Blooming: On

FPS with Patch 3: 20-25 FPS
FPS with Patch 4: 5-15 FPS

system:
AMD Phenom II 965 @ 4x3,4 Ghz
AMD 790GX Motherboard Sapphire Crossfire
8 GB DDR3 RAM
AMD Sapphire Radeon 7870 OC 2GB
1 TB HDD with Windows 8.1 pro 64 bit
LG 19 "Monitor

Why the game was previously so well and smoothly, and now it is unplayable with the same attitude?
AMD now be forced players to Nvidia to upgrade? Or forced to buy expensive new hardware? Is the patch 4 intention?
I'm a big fan of the AC series, but I have only a small budget. Does it now for me to throw the game away, just because I can not afford better hardware?

thexray
12-19-2014, 06:21 PM
i tested it for several hours now, and i still have massive framerate drops.

for example in a sequence 5 mission i get drops down to 6-12 fps in a cut scene and other cut scenes with talking also.

after this mission i had a lot of stutter while running around paris and had to end the game.

the fps was just increased (if at all) by 2 fps maximum.

so i don't see any advantages over 1.3 so far, and there are still flickering textures.

the framerate in the cafe is a bit better than before, but ok, it's the main save point where your money chest is, so i guess they optimized this place, but not the rest of the game really.
and the 2 fps more are just there because of lowered LOD for textures and objects in paris.

to make it short: they really did not optimize the game.

i expected some 5-10 fps increase and no stutter, no frame drops anymore, but wrong.

they will never get it right imo.

it's just empty talk to get more people buy the game and believe that it will be fixed and running smooth.

but at least for me, it won't.

Yamatsan
12-19-2014, 08:39 PM
Does nobody knows how to downgrade back to version 1.3.0? I really want to downgrade, I can't enjoy this game anymore now :(

GhostAssassinLT
12-19-2014, 09:11 PM
Unless the patches are available for download I think you, just like me, are focked..... :mad:

Xazbot
12-19-2014, 09:28 PM
I ****ING QUIT UBI godamn!!!
You gave me Far Cry ok. So I ll play it. Just know that I won't buy your games anymore... The only thing you are good at is generating hype jeez.

DanonMight
12-19-2014, 09:32 PM
Game is really running worse than 1.3.0. I was playing on Ultra details 1080p and at street level I use to have 50-60 FPS while on buildings It drops to 45 and It was still comfortable to play but now I have 30 or less fps on street lvl while on the rooftops I havent noticed any change. Please Ubisoft can you give us an instruction or way to go back to 1.3.0 so I can prove you (by testing both patches and uploading a videos) how your "refurbish of paris" made the game even worse. You just do not know how to make a proper PC game anymore don't you. Oh wait you guys seen this?

Seems that Ubi have problems even with simple game as tetris.
http://gamerant.com/ubisoft-tetris-ps4-problems/

Blackred689
12-19-2014, 10:55 PM
Well i would say that what you claim is impossible.
I have played during day morning and night i also run an OC 970GTX Vsync and the same settings and i notice drops from 60-45 FPS so there is no way that you have the special olympic GTX that only drops 5 FPS maximum sorry but that simply cant be true.

I also have the same FPS with Nvidia soft shadows turned on for some reason in patch4 and that does not make any sense to me.

Overall it pretty much feels the same as before...

I can back up what Captainkao is saying.

Since the beta drivers there's been an increase of around 10fps. Around most areas I'm seeing 60-65-70fps and up to 80 with the said settings. minimum I see is 55 in more taxing areas. I dare say a 980 with a little OC on a newer CPU should have this locked easy now.

I posted ages ago how Unity was around 50-70 at 1080p, going down to 45 at odd times, now its 60-80, going down to 55. Anyhow, what I like to do is play at 1440p locked at 30 for image quality. I must admit playing 1080p is quite tempting now its mostly 60fps. I enjoyed the smoother gameplay while testing. I would use adaptive vsync 60.

DAIMONDAMPS
12-19-2014, 10:59 PM
For me is running very well (30-40fps) on ultra with MSAx2 .
I have old HD4950 Radeon (below the minimum ) and i74790K cpu.
Just upgraded MB, RAM, and CPU - I have had quad core 9400 CPU(bellow the minimum) and it was a bottle necking the graphics card.
Before i had 15-25fps.
Now the Graphics Card is the problem.
Free Far Cry 4 is working with 60 FPS right now with ultra settings:D

D51-ClaudioACSy
12-19-2014, 11:16 PM
I gain 5 fps with this patch, or maybe it's only the last beta driver who did it :) BTW, the game is running smoothly for me.

CaptainKao
12-19-2014, 11:17 PM
Well i would say that what you claim is impossible.
I have played during day morning and night i also run an OC 970GTX Vsync and the same settings and i notice drops from 60-45 FPS so there is no way that you have the special olympic GTX that only drops 5 FPS maximum sorry but that simply cant be true.

I also have the same FPS with Nvidia soft shadows turned on for some reason in patch4 and that does not make any sense to me.

Overall it pretty much feels the same as before...

I'm afraid my claim is quite possible and it simply is true. Here's a video proving it. https://www.youtube.com/watch?v=-OZoMdXOo8g

Another thing that's possible is you don't really know what you're doing as regards graphical settings. Or it simply could be true that you have a crappy Cpu.

Shoiti2
12-20-2014, 06:29 AM
After Patch to 1.4, my game crashes everytime, seriously!! 1.3 was running smoothly, now I can't even play!!!

Yamatsan
12-20-2014, 07:05 PM
Bump.

Ubisoft, I would like the possibility to downgrade to 1.3.0.

WaR-UK
12-20-2014, 09:21 PM
Bump.

Ubisoft, I would like the possibility to downgrade to 1.3.0.

Im with you , i need to be able to downgrade to 1.3 ,,, i was thinking about using system restore thats built into windows , but i've checked and i would have to reinstall farcry 4 and bf4 and a couple of other big games and programs if i used this feature ,as i'm on a clean install of windows 8.1 only 2 days before the patch came out , so i don't know if i can be asred to reinstall these and programs again just to see if it would roll unity back to 1.3 .

WaR-UK
12-20-2014, 09:29 PM
I just need a fix for the dam sli flickering that makes this unplayable to me ,,,,,, i guess im just going to leave it as is and go and play other games that work good not like this trud of a game is now,, ok i got my free game (farcry 4 ) that one didn't really want, but i have the other games that were on offer anyway so i for one had no real choice

WaR-UK
12-20-2014, 09:36 PM
I'M DISGUSTED IN YOU UBISOFT ,, please make right your wrongs , i did not want a free game i just wanted the one i purchased to work ,thats all

2 X MSI GAMING GTX 780 SLI
=================
I7 3770K @ 4.5, H105
==============================
2 X Corsair Force GT 120 GB SSDs RAID 0
=================================
=======================
Gigabyte GA-Z77X-UD5H
==================== PS please acknowledged the said problems and that you are working on a fix

jeffies04
12-21-2014, 12:26 AM
I made a backup before I upgraded to 1.4 in case I wanted to go back to 1.3. Whether or not uPlay would be happy about it even in offline mode, I don't know.

Alas, 1.4 is running pretty well for me. I am noticing some definite improvements.

Darkmantik
12-21-2014, 12:46 AM
Guys.... Ubisoft are frenchies @ the origin... So they work as frenchies do... 35 hours a week never more (25-30 if possible) and eat baguette all the day. Don't worry the game will be playable for everyone on march or april maybe june if strikes... For now it's christams and the ACU team is in hollidays till end of january with the money you paid their game with.

Merry Christmas and buy UBISOFT !

MrT31500dtc
12-21-2014, 01:17 AM
the game is a multi country team devellopment . Not only french.

And 1/ french people works more than 35 hours believe me and 2/ france is a country with very productive workers more than USA (and german too) .

NightmareGK13
12-21-2014, 01:58 AM
game got worse for me
sure im playing with a below min gpu, but it was better with 1.3 that I assure you in my case

I--Skeptik--I
12-21-2014, 02:05 AM
I think a lot of these problems on these forums are due to people's own hardware (or lack thereof) and how they have their machines setup because I'm playing at 2103x1183 with everything on ultra and I'm not getting any hitching or lag. I'm getting a consistent 45-60 fps. Maybe some of these people don't know how to optimize their own machines?

I see a lot of people that are complaining about their games not running that great and they don't even meet the minimum requirements....duh

Voyager456
12-21-2014, 03:18 AM
I think a lot of these problems on these forums are due to people's own hardware (or lack thereof) and how they have their machines setup because I'm playing at 2103x1183 with everything on ultra and I'm not getting any hitching or lag. I'm getting a consistent 45-60 fps. Maybe some of these people don't know how to optimize their own machines?

I see a lot of people that are complaining about their games not running that great and they don't even meet the minimum requirements....duh
What do you mean optimizing their own machine?what should these people do to make any noticebale diffrence? i have similiar rig as you playing at same resolution and settings also getting 45-60 FPS also have most of the unnesesary background services turned of but i cant say i didnt notice any stuter its not terrible but it happens from time to time also sometimes game freezes for 10 seconds and just keeps going normaly this was reported by a lot of people here on forum altough it donst happen as much with patch 4 maybe once in 2 hour and no nothing is wrong with my machine

BCFreeman
12-21-2014, 03:42 AM
Honestly I'm able to reach 70-80+ FPS with FXAA- ultra nvidia settings 1080p with non-sli configuration GTX 980 (sli makes some textures flicker). BUT here's the thing, MSAA x4/TXAA kills the fps MORE than 1.3. In 1.3 fps is 50-60+, 1.4 fps is max 45 fps, WTH UBI :mad:

naumaan
12-21-2014, 07:28 AM
game got worse for me
sure im playing with a below min gpu, but it was better with 1.3 that I assure you in my case



For me .. atleast the crash is minimized ... not yet fully recovered but i can manage ... however now that the game is running i can see a lot of bugs ..

sometimes when climbing, espacially near some ledge or a place where we can stand it just do not get control or what, arno gets in a free fall jump, which is obviously not a leap of faith .. and if I am at a height .. arno dies ..

and sometimes when I am at rooftops .. arno moves in space .. like .. when i was at notre dame viewpoint for the very first time, arno went further then the v point, walked through space and got stuck .. then i had to fast travel to the other viewpoint .. and doing that again, arno got stuck in the solid surface, this happens not only on the rooftops .. but also on ground,.. sometimes I have to restart from the last checkpoint in a mission and if not in a mission i have to travel a lot from one view point to another .. as told .. it do not crash as much as before .. may be I am having trouble with ram or something ..

so i dont know if i should say this patch was bad .. as it solved many problems yet opened up a lot problems too ..

what kind of errors are you experiencing .. ?

Yamatsan
12-21-2014, 11:16 AM
I think a lot of these problems on these forums are due to people's own hardware (or lack thereof) and how they have their machines setup because I'm playing at 2103x1183 with everything on ultra and I'm not getting any hitching or lag. I'm getting a consistent 45-60 fps. Maybe some of these people don't know how to optimize their own machines?

I see a lot of people that are complaining about their games not running that great and they don't even meet the minimum requirements....duh

On version 1.3 the game was perfectly playable for me. Only now with version 1.4 it's unplayable. Isn't that weird? The game performance in general was fine for me on version 1.3 but now on 1.4... Unplayable. I am not complaining about the game's performance in general but about the impact patch 4 had on performance.

Ubisoft, I want the possibility to downgrade back to version 1.3 of ACU.
That's all, if you give me back version 1.3 I am the happiest man on earth!

NightmareGK13
12-21-2014, 11:52 PM
For me .. atleast the crash is minimized ... not yet fully recovered but i can manage ... however now that the game is running i can see a lot of bugs ..

sometimes when climbing, espacially near some ledge or a place where we can stand it just do not get control or what, arno gets in a free fall jump, which is obviously not a leap of faith .. and if I am at a height .. arno dies ..

and sometimes when I am at rooftops .. arno moves in space .. like .. when i was at notre dame viewpoint for the very first time, arno went further then the v point, walked through space and got stuck .. then i had to fast travel to the other viewpoint .. and doing that again, arno got stuck in the solid surface, this happens not only on the rooftops .. but also on ground,.. sometimes I have to restart from the last checkpoint in a mission and if not in a mission i have to travel a lot from one view point to another .. as told .. it do not crash as much as before .. may be I am having trouble with ram or something ..

so i dont know if i should say this patch was bad .. as it solved many problems yet opened up a lot problems too ..

what kind of errors are you experiencing .. ?

my fps weren't good to begin with, but they were decent, after patch they dropped a little I believe that volumetric fog is the issue
free running issues are as usual present, Arno frequently just wont do what I want him to do, on one occassion he just froze... i could shoot i could draw my sword, but that was it, i couldn't walt nor jump

in some cases arno just gets stuck in mid air, holding on to nothing

mission wise... oh god why
i was doing a coop mission and being very stealthy guards started popping inside the house, and i'm not talking about one or two, almost felt like an army in there

while on a murder mistery, the right person to accuse didn't have the marker, had to reload the game but by then i had accused everyone else because the game led me to believe it wasn't him to begin with bah

jeffies04
12-22-2014, 12:02 AM
mission wise... oh god why
i was doing a coop mission and being very stealthy guards started popping inside the house, and i'm not talking about one or two, almost felt like an army in there

while on a murder mistery, the right person to accuse didn't have the marker, had to reload the game but by then i had accused everyone else because the game led me to believe it wasn't him to begin with bah

These two made me laugh a little bit. Would have liked to have been a fly on the wall for your reaction. :)

NightmareGK13
12-22-2014, 12:18 AM
These two made me laugh a little bit. Would have liked to have been a fly on the wall for your reaction. :)

i was doing the coop with Kannuhbhis i think, we were just getting inside the building after some stealth assassinations and bam! a buttload of exclamation points and an army just popping out of nowhere o.O

jeffies04
12-22-2014, 12:24 AM
i was doing the coop with Kannuhbhis i think, we were just getting inside the building after some stealth assassinations and bam! a buttload of exclamation points and an army just popping out of nowhere o.O

Did you both have it happen??

BTW, I thought they were supposed to fix the club list in 1.4... When I open up the club it just lists me 50 times. I'd like to see who all is in our club.

NightmareGK13
12-22-2014, 02:38 AM
Did you both have it happen??

BTW, I thought they were supposed to fix the club list in 1.4... When I open up the club it just lists me 50 times. I'd like to see who all is in our club.

we both got it, we had to fight them off... lost half our bonus right there -_-

ahah i thought the same thing... yet the result is the same... nothing fixed
i wonder what did I download that was 4.2gbs... air?

USAdystopia
12-22-2014, 06:30 AM
Hmmm...hmmm....hmm (voltage)...shhhh....(voltage)...

Power Management...(keep it to yourselves).

Temperatures...nothing to see here...move along. What in-the-hell is airflow?

Overclocking...what good does THAT do?

Voltage and Power Management...didn't he say that before?

CPU, RAM and the Memory Controller...don't care, right?

Am refusing to Optimize Windows as I only have 53 processes and Applications running in the background and anyways I bought a real high end video card and have all of 8 gigs of RAM...

Yamatsan
12-25-2014, 10:06 AM
Bump.

Ubisoft, I would like the possibility to downgrade back to version 1.3 of ACU.
That's all, if you give me back version 1.3 I am the happiest man on earth!

(A moderator on this forum already tried to help me with downgrading, but without succes. It's unpossible to downgrade without the help of you, Ubisoft.)

ChorongSquad
12-25-2014, 11:27 AM
I appreciate their time to make a new update but 1.4.0 is bad for me too. My FPS drop and whenever i move or run around, im like lagging and lagging @_@
Can't even experience a smooth gameplay once. Sigh.

Yamatsan
12-27-2014, 11:14 AM
Bump.

Ubisoft, I would like the possibility to downgrade back to version 1.3 of ACU.
That's all, if you give me back version 1.3 I am the happiest man on earth!

(A moderator on this forum already tried to help me with downgrading, but without succes. It's unpossible to downgrade without the help of you, Ubisoft.)

dtlaw
12-27-2014, 02:17 PM
This patch has introduced rediculously bad flickering with SLI. It was totally fine in previous versions, but now wherever there is water i.e puddles or... The entire River!!! it flickers uncontrollably.
Im so glad there has been alot of other good game releases in the past few months to take my mind of this rubbish...

i7 4770k @4.5ghz
2x gtx 980s @ 1445 mhz
16gig ram @ 2133 mhz
win 7

Yamatsan
12-28-2014, 10:39 AM
This patch has introduced rediculously bad flickering with SLI. It was totally fine in previous versions, but now wherever there is water i.e puddles or... The entire River!!! it flickers uncontrollably.
Im so glad there has been alot of other good game releases in the past few months to take my mind of this rubbish...

i7 4770k @4.5ghz
2x gtx 980s @ 1445 mhz
16gig ram @ 2133 mhz
win 7

Yeah, many people are complaining about that. Well, I submitted a ticket (1 week ago) about the huge impact on performance patch 4 has, but Ubisoft is not responding...

varun777
12-30-2014, 07:45 AM
hi guys i have the same issue with my nvidia gtx 690 as well. the only quick fix i found to stop the flickering is to go in the settings and disable multi gpu or sli. :( hopefully the next patch will address this issue but for now this solution works.

javedalam
01-06-2015, 10:31 AM
BUMP

I have made another thread about this (which only received one reply).

Patch 1.4: - ~ 5 - 10 avg fps reduction
~ TERRIBLY REDUCED DRAW DISTANCE RESULTING IN HORRIBLE POP-IN TEXTURES AND NPC's

I CAN NOT PLAY THE GAME LIKE THIS - PLEASE PROVIDE AN OPTION TO REVERT.

In the meantime, my only recourse is to pirate the game and update it to 1.3

This YouTube video gives a clear representation of the effect of 1.4 on framerate: https://www.youtube.com/watch?v=ffzLMJIUhnc

The effect on texture and NPC pop-in is even worse.

Revert or refund.

wootwoots
01-06-2015, 05:22 PM
So, when the patch 1.5 come ?

need a REAL optimization patch..

Wrath2Zero
01-06-2015, 11:29 PM
All 1.4 did improve performance on the consoles because they needed it. Ubisoft had to do a lot of work on the city to make it run better on the consoles just to get nearer a stable 30fps, and still doesn't.

Yamatsan
01-25-2015, 12:51 PM
Bump.
Reason: Update.

UPDATE 2:
Still no solution.
After a long discussion with support they could not find a solution tot this problem. They also told me that there is no possibility to downgrade back to version 1.3.0. The latest NVIDIA driver (347.25) did improve performance (±3 FPS) but not enough to give me the same performance as on version 1.3.0 of ACU. I hope that if there is ever an patch 1.5.0 it will restore my performance back to how it was on version 1.3.0.

DELTA Kristian
01-25-2015, 07:52 PM
Optimization is horrible. Hiccups to 40 fps and down to 25 on ULTRA (R9 270X 4 GB VRAM). That`s unnacaptle. I run it well,but statisticly looked upon - ewwww.