PDA

View Full Version : ACU warns me that my NAT type is strict



iAmTheTot
12-07-2014, 02:57 AM
Except absolutely nothing else on my PC has any trouble connecting. No other games tell me my NAT is strict, I can play MP on any other game, I can browse the web fine. I tried turning off my firewall and antivirus before playing AC:U, but to no avail.

I can access most online features like browsing clubs and stuff. But with the strict NAT time, I go to join a mission and it just sits there for minutes upon minutes finding a match and nothing happens. Does anyone else have this issue where only AC:U is being difficult?

YazX_
12-07-2014, 11:44 AM
This game and all AC games rely on P2P connections for MP, you need to open and forward required ports in your router, please follow this FAQ:

https://support.ubi.com/en-GB/FAQ/9/4043/multiplayer-connection-issues-in-assassins-creed-unity/kA030000000eibzCAA

Anykeyer
12-07-2014, 01:07 PM
Most Ubi games are based on some weird network middleware called "rendez-vous". They should have thrown this crap away long ago.
The universal fix is to make sure your UPnP works. UPnP allows automated port forwarding. Read your routers manual and enable UPnP in its settings (in most cases it should be enabled by default). Then make sure your system listens to ports 1900 UDP and 2869 TCP. This can be done by opening them in your firewall. If you are using windows built-in firewall enabling network discovery (in network and sharing center) should be enough, this automatically adds/enables all required rules to windows firewall.

Aenigmatix
12-07-2014, 07:37 PM
Most Ubi games are based on some weird network middleware called "rendez-vous". They should have thrown this crap away long ago.
The universal fix is to make sure your UPnP works. UPnP allows automated port forwarding. Read your routers manual and enable UPnP in its settings (in most cases it should be enabled by default). Then make sure your system listens to ports 1900 UDP and 2869 TCP. This can be done by opening them in your firewall. If you are using windows built-in firewall enabling network discovery (in network and sharing center) should be enough, this automatically adds/enables all required rules to windows firewall.

You seem to know what you're talking about. I was wondering if you could help sort of walk me through how to port forward with AT&T Uverse router.

Here's a screen capture of what I'm looking at:

http://i.imgur.com/Q8bYQzo.jpg

And here's a screen cap of the main page that comes up when I click on NAT/Gaming, where I guess I'm supposed to specify which device (i.e. my desktop computer) needs the open ports:

http://i.imgur.com/epCozey.jpg

Could you help me try to understand what port numbers I should input in which field? I'd like to think I'm semi-computer literate but this sh*t goes way over my head.

Apparently, my router doesn't allow me to simply enable UPnP. At least, I cannot find an option anywhere in the settings to do so.

I'm also using AVG Anti-Virus Free 2015, which doesn't allow me to open ports through it. Could that be part of the problem? I've disabled and uninstalled it to see if that would improve my NAT, but that didn't help.

If you or anyone else can provide some help with this, I would be HUGELY grateful. Because my NAT Type is Strict, I can't use a microphone in co-op. Which is really getting on my nerves.

Diarmuid_III
12-07-2014, 08:07 PM
I started getting this message for the first time yesterday after playing on and off over a couple of weeks. What really pisses me off is we are supposed to know this, HOW exactly! There was nothing on the jewel box for AC Unity that said anything about having to configure firewalls or port forwarding blah blah blah. I bought a game to play not a 101 course on technology. Never have I spent so much time sorting out the technical issues with a game as I have with AC Unity! Rant over!

Aenigmatix
12-07-2014, 08:13 PM
I started getting this message for the first time yesterday after playing on and off over a couple of weeks. What really pisses me off is we are supposed to know this, HOW exactly! There was nothing on the jewel box for AC Unity that said anything about having to configure firewalls or port forwarding blah blah blah. I bought a game to play not a 101 course on technology. Never have I spent so much time sorting out the technical issues with a game as I have with AC Unity! Rant over!

I completely agree. If this were a simple problem with a simple solution, that's one thing. But I'm not educating myself on P2P networking and port forwarding in order to enjoy the game the way it's meant to be. If it's this middleware called rendezvous that's causing these problems in Assassin's Creed only, and none of my other games give me this problem, then Ubisoft needs to scrap it immediately. This is ridiculous.

Anykeyer
12-08-2014, 01:43 PM
Input all ports (except companion) listed here https://support.ubi.com/en-GB/FAQ/9/4043/multiplayer-connection-issues-in-assassins-creed-unity/kA030000000eibzCAA
enter your local IP (you can get it from networks and sharing center, should be in the range of 192.168.1.x for you) in "device" field
you can enter any text in "service" field, it doesnt matter, just a friendly name for you

Aenigmatix
12-08-2014, 08:50 PM
Input all ports (except companion) listed here https://support.ubi.com/en-GB/FAQ/9/4043/multiplayer-connection-issues-in-assassins-creed-unity/kA030000000eibzCAA
enter your local IP (you can get it from networks and sharing center, should be in the range of 192.168.1.x for you) in "device" field
you can enter any text in "service" field, it doesnt matter, just a friendly name for you

Not to pester you, but...

What do I enter into "Global Port Range?"

What about Base Host Port?

And what protocol? TCP/UDP?

Thanks for trying to help!

Anykeyer
12-09-2014, 06:55 AM
For each rule you add enter the same port in all fields
Protocols specified in that support article.

iAmTheTot
12-15-2014, 01:37 AM
I'd like to consider myself computer literate but for the life of me I cannot forward these ports. I'm so frustrated with this game I've barely even played it since I bought it because it's just caused me nothing but grief. Which is a shame because other than the technical issues, I really like the game.

iAmTheTot
12-15-2014, 02:10 AM
Is there a reason I would not be able to forward some ports while being able to forward others? I don't seem to have any trouble getting 80 and 443 to forward, but no matter what settings I use nothing seems to work for 3074, 13000, etc. Pics below.
http://puu.sh/dv37z/a569d19003.png
http://puu.sh/dv3aS/79c8c0a8c1.png
http://puu.sh/dv3cr/08d20befdf.png

Mr_Shade
12-15-2014, 12:18 PM
Hi Guys,

If you have trouble with port forwarding, or don't really understand it - best to speak to your Internet Service Providers technical support, since they will have detailed knowledge of your hardware - and - will ensure you don't alter a setting you shouldn't!

Anykeyer
12-15-2014, 01:04 PM
Is there a reason I would not be able to forward some ports while being able to forward others? I don't seem to have any trouble getting 80 and 443 to forward, but no matter what settings I use nothing seems to work for 3074, 13000, etc. Pics below.
http://puu.sh/dv37z/a569d19003.png
http://puu.sh/dv3aS/79c8c0a8c1.png
http://puu.sh/dv3cr/08d20befdf.png

You just dont have anything running that listens to this port. Try again with Uplay/game open. Maybe you even need to start MP to get any response.

The-Bob
12-15-2014, 06:41 PM
Ubisoft this is a load of crap, I know we have to open ports and ****, but as a pc technician, I once spent an entire day trying to fix the strict nat problem, it was a horrible job !!!!

But 80% of the gamers, don't even know what the difference is between a browser and an explorer, so you expect them to mess around with opening ports for an entire week before they can play the game they bought ?
No other game has this problem, you install it, it puts a firewall restriction and fix, it works, but with AC, you need to be some kind of expert, which makes no sense, because be real, how many smart people are still on this planet ?

As AC_Mako said, they should have gotten rid of their "online coop service" a long long time ago.

Diarmuid_III
12-15-2014, 08:18 PM
Ubisoft this is a load of crap, I know we have to open ports and ****, but as a pc technician, I once spent an entire day trying to fix the strict nat problem, it was a horrible job !!!!

But 80% of the gamers, don't even know what the difference is between a browser and an explorer, so you expect them to mess around with opening ports for an entire week before they can play the game they bought ?
No other game has this problem, you install it, it puts a firewall restriction and fix, it works, but with AC, you need to be some kind of expert, which makes no sense, because be real, how many smart people are still on this planet ?

As AC_Mako said, they should have gotten rid of their "online coop service" a long long time ago.

I agree totally. I have never had to open ports, forward ports or anything technical with any previous AC games, or any other games for that matter, before. This problem isn't even consistent. I only get the strict NAT message if I go to the point on the map and interact directly with the co-op mission. If I stay in one place and select the co-op mission I don't get the strict NAT message. I actually have played many co-op missions. So I would have to ask whether this is truly a problem or not.

Aenigmatix
12-15-2014, 08:53 PM
I agree totally. I have never had to open ports, forward ports or anything technical with any previous AC games, or any other games for that matter, before. This problem isn't even consistent. I only get the strict NAT message if I go to the point on the map and interact directly with the co-op mission. If I stay in one place and select the co-op mission I don't get the strict NAT message. I actually have played many co-op missions. So I would have to ask whether this is truly a problem or not.

I agree, the problem may be negligible, and I wonder whether the NAT problems have any affect at all. But when I get the Strict NAT message, it says that my "ability to communicate with other players may be affected" (or something to that effect). I really want to use a microphone in-game, and though my mic works when I test it through Uplay, it doesn't work when I try to use it in co-op. I don't even get a mic icon next to my name in the upper-left corner, which I've seen with other players. If my NAT Type is preventing me from using my mic, (a) that's really, really stupid of Ubisoft, and (b) this is a problem that I would really like fixed, and I am not willing to jump through the hoops of learning how to port-forward or contacting my ISP customer support to figure out.

If that's really Ubisoft's response to these concerns, to contact your ISP and work through them, think about that for second: how many people here probably have Time Warner Cable in the US? I would venture to guess a lot. I don't have Time Warner because I switched to AT&T Uverse after many, many years of frustration and anger with Time Warner. If Ubisoft is seriously telling players to go through Time Warner's customer service process in order to fix the NAT issues, that is next-level stupidity. I feel bad for anyone who has Time Warner Cable and is having these NAT issues, because I guarantee you your customer service rep based in India is going to have just as much expertise on port-forwarding as you do.

Carch
12-15-2014, 10:13 PM
I have tried forwarding all the ports in the Ubisoft FAQ (https://support.ubi.com/en-GB/FAQ/9/4043/multiplayer-connection-issues-in-assassins-creed-unity/kA030000000eibzCAA), and the game still tells me I have Strict NAT. The only thing that works for me is setting a DMZ host, and I don't want to do that, because it would make my system less secure.

Either there are ports missing from the FAQ, or there is a bug in the game.


EDIT: After checking portforward.com, I noticed that the following ports are missing from the FAQ: 14000 and 14008. Forwarding those ports as described on portforward.com solved my "Strict NAT" problem.

One would think that Ubisoft themselves would know which ports are used by their game...

mikemirror88
05-23-2015, 02:17 AM
I have tried forwarding all the ports in the Ubisoft FAQ (https://support.ubi.com/en-GB/FAQ/9/4043/multiplayer-connection-issues-in-assassins-creed-unity/kA030000000eibzCAA), and the game still tells me I have Strict NAT. The only thing that works for me is setting a DMZ host, and I don't want to do that, because it would make my system less secure.

Either there are ports missing from the FAQ, or there is a bug in the game.


EDIT: After checking portforward.com, I noticed that the following ports are missing from the FAQ: 14000 and 14008. Forwarding those ports as described on portforward.com solved my "Strict NAT" problem.

One would think that Ubisoft themselves would know which ports are used by their game...

Hey

I tried that as well , i`ve opened all the ports from ubi faq and from portforward and I still get that message . I even checked them with portchecker from portforward and all are opened . Did u do anything else ? All ports are opened TCP&UDP 3074, 13000, 13005, 13200, 14000, 14008, 443, 80 . If you have any suggestions please let me know , thanks .

I`ve wasted a whole day trying to forward those ports without any outcome, it`s ridiculous ....

Sef1n
05-25-2015, 08:41 AM
strict NAT killed Unity for me. I was looking forward to play coop on daily bases, but strict NAT= long wait time and then laggy game.
I sent request to provider and they changed it (at lease they say they did) based on info I found in FAQ. Still it does not work. ACIII MP started to have open NAT though :-D

I really do not understand why Ubi keeps such method for online gaming since no other game ever requires gamer to do anything... :-(