PDA

View Full Version : gtx 970 poor performance



Singh1_1
11-29-2014, 09:29 AM
hey guys, i recetly replaced my gtx 560 ti with gtx 970 with 4 gb vram and was hoping that i would be able to max this game out and get around 50-60 or even 40-50 fps on highest settings, but that isnt the case, im getting like 30-40 fps, sometimes even lower like 28 fps depending if im in a cmbat situation, is this normal ? ive seen alot of threads with people having 970 and gettng around 50-70 fps, im playng this game on ultra high with msaa 2x.

rest of my config is :

i5 4670k stock clocks
8 gb corasair 1600 mhz
asus z87k latest bios vesion and on latest nvidia drivers

RVSage
11-29-2014, 09:43 AM
Which version of the card you have.. I get about 40-60 FPS with occasional dip below 40.. At paris on ultra with MFAAx2
https://www.youtube.com/watch?v=v9wQwshs92U

My card is evga gtx 970 SC acx 2.0

My system
i5-4960K
16gb 2133 mhz dd3 ram
256gb corsair SSD

RVSage
11-29-2014, 09:46 AM
Ubi will release a FPS patch soon expecting consistent 50-60FPS after that.. or hopefully higher

Singh1_1
11-29-2014, 09:50 AM
Which version of the card you have.. I get about 40-60 FPS with occasional dip below 40.. At paris on ultra with MFAAx2
https://www.youtube.com/watch?v=v9wQwshs92U

My card is evga gtx 970 SC acx 2.0

My system
i5-4960K
16gb 2133 mhz dd3 ram
256gb corsair SSD
i have the gigabyte windforce which has three fans, its factory overclocked, how do u get mfaax2, i ust see the option of turning it off or on in nv control panel, and btw i forgot to mention, i also have mfaa turned on with msaax2

so ure getting better performance than me but im still very much behind, im not sure what the problem is

RVSage
11-29-2014, 10:29 AM
Check for bloatware in your machine.. Make sure your anti-virus is in game mode or worst case turn it off when in game

AntiChrist7
11-29-2014, 12:41 PM
I replaced my 750 with the 970 as well. The game runs much better, but i have the occasional 5-10 seconds freeze (about every 10-15 minutes or so). I didnt put the settings on highest. Got 8GB ram and i4590 (3.30ghz)

Blackred689
11-29-2014, 02:31 PM
Try running FXAA or enable MFAA in the NVidia control panel

MSAA doesn't run very well in AC Unity and seems that x2 and x4 look worse than FXAA

AntiChrist7
11-29-2014, 03:10 PM
Try running FXAA or enable MFAA in the NVidia control panel

MSAA doesn't run very well in AC Unity and seems that x2 and x4 look worse than FXAA


Will try that tonight, but my Nvidia panel claims i cant even run AC:Unity.... Or that i have to downgrade Rome 2 quite a lot, which both isnt the case

Singh1_1
11-29-2014, 03:26 PM
Will try that tonight, but my Nvidia panel claims i cant even run AC:Unity.... Or that i have to downgrade Rome 2 quite a lot, which both isnt the case

yea ive already turned on mfaa, but ill have to run msaa on x2 or x4 for it work otherwise it wont work, im going to tryin running with fxaa and turning shadows to high and not the nvidia shadow, maybe its not that well optimised yet ... ill post back with my results

AmazingBeej
11-29-2014, 03:52 PM
I also bought Asus STRIX GTX970 DirectCU II OC 4GB and maxed out i get 35 40 fps, but the game runs smooth for me no freezing or glitching. So not sure what the problem is with other gcards.

NicoParasite
11-29-2014, 04:03 PM
Donīt worry m8,i have a EVGA GTX 970 4GB SC ACX 2.0 and im getting almost the same frames as you,35-55 fps with everything maxed out and ALSO with MFAA activated in the control panel,so this game is still poorly optimized but nevermind they will fix it... eventually.

AntiChrist7
11-29-2014, 05:11 PM
Turned AA to maximum setting, and it did seem to fix the minifreezes i had, played for an hour.

didnt monitor the fps (too much hassle with fraps and such), but it was stable and smooth

DarkSolitudeX
11-29-2014, 05:16 PM
Minus the freezes, my evga GTX 970 FTW (v344.75) can max out unity at 1920x1080 with around 50fps. I would suggest investigating task manager and services.

Singh1_1
11-29-2014, 06:18 PM
Minus the freezes, my evga GTX 970 FTW (v344.75) can max out unity at 1920x1080 with around 50fps. I would suggest investigating task manager and services.

well im glad im not the only one having really low frames and i just checked lowering environment quality and everything on very high from ultra high with fxaa gives me the same performance which is weird and makes me think there is something wrong with the game itself and not my hardware or anything which is pretty good imo ... and also about the freezes i notced i get thse freezes whenever a guard is chasing me and i leave that known position shadow behind, otherwise the game does feel smooth even if the game is running on 35-45 fps ..

Trih333
11-29-2014, 11:31 PM
Hi I also have a gtx 970 but I run the game at 50fps,
but to achieve that i have, in the options menu, put shadow to low (maybe it's my eyes but I genuinely don't see the difference)
anti aliasing to fxaa
annnnnd that's it
With just those options and everything else max (including vsync) i have a clear and consistent frame-rate

YazX_
11-30-2014, 11:59 AM
Hi Bullsheet, i have the exact same card and manufacturer, i was able to OC it 1525 Mhz/8 Ghz, the card is awesome, at these clocks i get 45 FPS on avg, max 55 and min 33. i play on 2560 x 1440p resolution and the game is maxed out with FXAA and shadows on high.

so since you are playing on 1920 x 1080, you should be easily getting 50+ FPS on that card, my assumption is you are having shadows on Ultra which enables Nvidia PCSS, note that from my FPS testing, this option kills performance and introduces stuttering and freezes, so my recommendation is turn shadows to High instead of Ultra, you will not notice any difference in visuals to be honest.

shadygiz
11-30-2014, 12:15 PM
hey guys, i recetly replaced my gtx 560 ti with gtx 970 with 4 gb vram and was hoping that i would be able to max this game out and get around 50-60 or even 40-50 fps on highest settings, but that isnt the case, im getting like 30-40 fps, sometimes even lower like 28 fps depending if im in a cmbat situation, is this normal ? ive seen alot of threads with people having 970 and gettng around 50-70 fps, im playng this game on ultra high with msaa 2x.

rest of my config is :

i5 4670k stock clocks
8 gb corasair 1600 mhz
asus z87k latest bios vesion and on latest nvidia drivers

I have pretty much the same rig as you and i am getting around 70fps

http://forums.ubi.com/showthread.php/950198-Gtx970-fps

you definitely need to tweak some settings, take v-sync off for a start, that will limit the input lag. I cant see you getting much screen tearing if you play on a 60hz monitor @ 1080p.

Also, turn shadow details down and turn bloom off

In the nvidia control panel, go to 3d settings, then click program settings tab. Now in the drop down box select Assassins Creed Unity (ACU.exe), if it isnt shown in drop down box, then click add and select it from the pop up menu.

Now change the following settings: -

Anisotropic filtering - change to 16x

Max pre-rendered frames - change to 1

Multi dispaly/mix GPU acceleration - change to single dispaly performance mode

Power management mode - change to prefer max performance

Vertical sync - change to off


now save and close nvidia control panel

AntiChrist7
11-30-2014, 12:46 PM
After some more playing, i didnt have any freezes, yet sometimes some crashes (but only in loading screens sometimes).

But then i played co-op a few missions. I could finish half of them. In the other two it minifroze at the end, in another i got kicked out due to a freeze.

Have my settings on high, but not max (Nvidia control panel advised max settings, but i dont wanna fry my card)

Singh1_1
11-30-2014, 06:49 PM
Hi Bullsheet, i have the exact same card and manufacturer, i was able to OC it 1525 Mhz/8 Ghz, the card is awesome, at these clocks i get 45 FPS on avg, max 55 and min 33. i play on 2560 x 1440p resolution and the game is maxed out with FXAA and shadows on high.

so since you are playing on 1920 x 1080, you should be easily getting 50+ FPS on that card, my assumption is you are having shadows on Ultra which enables Nvidia PCSS, note that from my FPS testing, this option kills performance and introduces stuttering and freezes, so my recommendation is turn shadows to High instead of Ultra, you will not notice any difference in visuals to be honest.

hey man, thanks for your reply, well i get around 38 fps on avg, can you tell me what program u use for overclocking ? i tried ocing my card up by +200mhz on core clock but then unity would freeze after loading.can you suggest me how to overclock this card as its a little confusing using msi afterburner.

Singh1_1
11-30-2014, 06:59 PM
so this is really weird, i get absolutely no gain in fps even if i turn off bloom and turn off shadows from pcss to high and turn down aa to fxaa, still get 38 fps on avg and micro freezes , the only place i do get better performance by turning down settings in in the pause menu, i dont know whats going on now, im playing dai as well and i get 60 fps everywhere in the game except hinterlands and shadow of mordor which is just as beautiful and get constant 60 fps.not sure whats going on with this game

Kamamura
11-30-2014, 08:13 PM
so this is really weird, i get absolutely no gain in fps even if i turn off bloom and turn off shadows from pcss to high and turn down aa to fxaa, still get 38 fps on avg and micro freezes , the only place i do get better performance by turning down settings in in the pause menu, i dont know whats going on now, im playing dai as well and i get 60 fps everywhere in the game except hinterlands and shadow of mordor which is just as beautiful and get constant 60 fps.not sure whats going on with this game

Don't forget that when using higher quality textures, you also need a fast I/O, SATA 3 SSD is best. Even if you have 8GB Ram like I do, the game won't allocate more than 2.5 GB and constantly streams textures from hard disk. Conventional hard disk is very slow compared to RAM, and therefore you get stutters and lower framerate.

The bottlenecks may be at several points. There is also a hypothesis that ACU makes so many DirectX draw calls per second that the API simply cannot process them, so there is a hard limit on how many FPS you may ever get.

Numbtoyou
11-30-2014, 09:57 PM
I was getting the stuttering as well on a gtx 980 and 5820k running at 4.3 ghz along with 16 GB of ram. Forcing windows to unpark cores solved that for me though. Now I get 60 fps locked and no stutter using fxaa ( which looks fine to me), txaa gives me drops to 50 with quick camera turns.

Lots of draw calls do tax the processor more ( which is why mantle shows improvements over dx11), and any parking done by windows exaggerates the problem. Worth a shot at least. Theres a free utility called 'park control' that makes the changes for you ( in the safe way, no editing the registry), and allows you to quickly turn parking back on for everyday use.

YazX_
11-30-2014, 10:47 PM
hey man, thanks for your reply, well i get around 38 fps on avg, can you tell me what program u use for overclocking ? i tried ocing my card up by +200mhz on core clock but then unity would freeze after loading.can you suggest me how to overclock this card as its a little confusing using msi afterburner.

Hey, i'm using MSI AfterBurner, IMO its the best and straight forward OC tool out there, nonetheless, 200 Mhz on core is like 1545 Mhz which is somehow too much without overvolting or setting power max limit, however the voltage has max limit locked in card bios, so if i want to go further i need to flash a custom bios but it doesnt worth it since 1525 Mhz/8 GHz is awesome, maybe after a while i will do so, but for now this is the safest way to OC. here is a screenshot to show you the correct settings:

http://s26.postimg.org/kqtvvj8eh/MSI_After_Burner.jpg

crystaltribe
11-30-2014, 11:25 PM
Hey, i'm using MSI AfterBurner, IMO its the best and straight forward OC tool out there, nonetheless, 200 Mhz on core is like 1545 Mhz which is somehow too much without overvolting or setting power max limit, however the voltage has max limit locked in card bios, so if i want to go further i need to flash a custom bios but it doesnt worth it since 1525 Mhz/8 GHz is awesome, maybe after a while i will do so, but for now this is the safest way to OC. here is a screenshot to show you the correct settings:

http://s26.postimg.org/kqtvvj8eh/MSI_After_Burner.jpg

DO NOT JUST APPLY THOSE SETTINGS TO VIDEO CARD.

Shame on you for telling someone to overclock their card with your settings. Cards are binned and OC mileage almost always varies. Usually you want to step it up gradually and test it.

YazX_
12-01-2014, 12:17 AM
DO NOT JUST APPLY THOSE SETTINGS TO VIDEO CARD.

Shame on you for telling someone to overclock their card with your settings. Cards are binned and OC mileage almost always varies. Usually you want to step it up gradually and test it.

First off, he asked for it and wanted to check my settings since he set his Core more than my settings actually, and i never said that he should apply same settings rather than correct settings which means the correct way to OC and the settings of the software itself , either ways, it will pretty much work since those settings are not pushing the card to the max.

second please watch your language.

third, no harm will be done since there is no over volting and either ways he will not be able to damage the card since voltage is locked in bios unless if he flashed custom bios and thats what i clearly said and explained, so get your facts right and read full posts and history before coming in like this and start attacking, next time i will consider it as personal attack and i will give you an infraction. if you have a different view on the subject, you could put it in different positive way rather than hopping in with negative attacking attitude without a slightest idea about the history of the conversation..

RVSage
12-01-2014, 12:55 AM
First off, he asked for it and wanted to check my settings since he set his Core more than my settings actually, and i never said that he should apply same settings rather than correct settings which means the correct way to OC and the settings of the software itself , either ways, it will pretty much work since those settings are not pushing the card to the max.

second please watch your language.

third, no harm will be done since there is no over volting and either ways he will not be able to damage the card since voltage is locked in bios unless if he flashed custom bios and thats what i clearly said and explained, so get your facts right and read full posts and history before coming in like this and start attacking, next time i will consider it as personal attack and i will give you an infraction. if you have a different view on the subject, you could put it in different positive way rather than hoping in with negative attacking attitude without a slightest idea about the history of the conversation..
Totally agree.. @crystaltribe stop over reacting..

Singh1_1
12-01-2014, 10:31 AM
Hey, i'm using MSI AfterBurner, IMO its the best and straight forward OC tool out there, nonetheless, 200 Mhz on core is like 1545 Mhz which is somehow too much without overvolting or setting power max limit, however the voltage has max limit locked in card bios, so if i want to go further i need to flash a custom bios but it doesnt worth it since 1525 Mhz/8 GHz is awesome, maybe after a while i will do so, but for now this is the safest way to OC. here is a screenshot to show you the correct settings:

http://s26.postimg.org/kqtvvj8eh/MSI_After_Burner.jpg

hey man thanks for the screenshots, ill try out these settings and i see your power limit is till the end, is it safe ? mine is only half through, im at work right now so i dont remember what the value was but i know it wasnt that high, and someone in the thread said about hdd being the culprit, u know i would buy an ssd but the thing is im from uae and ssds are highly overpriced here , like 400$ for just the 64 gb which is not really worth it, and the thing u said about dx11 does make sense and i also read that in an article somewhere, maybe thats y i dnt see any performance improvement even if i disable some of the settings down, i will try out these oc settings without overvolting or anything and hopefully i might see a small improvement.

YazX_
12-01-2014, 11:31 AM
hey man thanks for the screenshots, ill try out these settings and i see your power limit is till the end, is it safe ? mine is only half through, im at work right now so i dont remember what the value was but i know it wasnt that high, and someone in the thread said about hdd being the culprit, u know i would buy an ssd but the thing is im from uae and ssds are highly overpriced here , like 400$ for just the 64 gb which is not really worth it, and the thing u said about dx11 does make sense and i also read that in an article somewhere, maybe thats y i dnt see any performance improvement even if i disable some of the settings down, i will try out these oc settings without overvolting or anything and hopefully i might see a small improvement.

Regarding Power limit, the default should be 100%, in simple words power limit is how much power the card can draw in watts, this has nothing t do with voltage, so lets say the card is designed to draw 145W and max 170W, so on 100% it will draw 145W and on max power limit it will draw 170W, this will not increase/decrease the stock voltage, note that this card has 1x8pin and 1x6pin although the reference design has 2x6pin connectors, this is done to give more headroom for overclocking and supply more power, however, the max voltage is locked in BIOS which is 1.25v , so no matter what you raise the voltage, the card will throttle down to 1.25v which is the maximum allowed voltage.

as you can see from my settings, the card runs @ 1.225v which is still lower than the max voltage and was able to achieve stable OC on 1525/8Ghz, do note that each chip is different and you might not be able to reach those clock speeds with the same voltage, if thats the case, just lower the clock by 5-10 each time and test.

Regarding SSD, use ShopAndShip Aramex service and buy it from Amazon :)

AlienBurns
12-01-2014, 12:54 PM
Getting no change at all in frame rate whether its maxed out or with everything on lowest with my MSI 970.

On ground level it can go as low as 28fps and normally between 35-40. Every other game i have runs flawlessly so i have to lay the blame with AC:U and not my card. Also getting a lot more stuttering since last patch to the point its now unplayable, before that it was at least smooth even with the low fps and a few 5-10 second freezes.

MSI GTX 970
I5 3470
8GB RAM
Win 7 64bit

Singh1_1
12-01-2014, 01:44 PM
Regarding Power limit, the default should be 100%, in simple words power limit is how much power the card can draw in watts, this has nothing t do with voltage, so lets say the card is designed to draw 145W and max 170W, so on 100% it will draw 145W and on max power limit it will draw 170W, this will not increase/decrease the stock voltage, note that this card has 1x8pin and 1x6pin although the reference design has 2x6pin connectors, this is done to give more headroom for overclocking and supply more power, however, the max voltage is locked in BIOS which is 1.25v , so no matter what you raise the voltage, the card will throttle down to 1.25v which is the maximum allowed voltage.

as you can see from my settings, the card runs @ 1.225v which is still lower than the max voltage and was able to achieve stable OC on 1525/8Ghz, do note that each chip is different and you might not be able to reach those clock speeds with the same voltage, if thats the case, just lower the clock by 5-10 each time and test.

Regarding SSD, use ShopAndShip Aramex service and buy it from Amazon :)

hey man, i just tried your settings and i got a nice boost in performance from 38 to averaging around 43-45 fps and even going till 50 and 60 easily ... thanks man, but i hope ubi fixes these issues as 970 is a beast of a card already without ocing and shouldnt have these performance issues. add me in uplay if u want, my id is bullsheet11, we can coop sometime

cheers bro

YazX_
12-01-2014, 02:24 PM
hey man, i just tried your settings and i got a nice boost in performance from 38 to averaging around 43-45 fps and even going till 50 and 60 easily ... thanks man, but i hope ubi fixes these issues as 970 is a beast of a card already without ocing and shouldnt have these performance issues. add me in uplay if u want, my id is bullsheet11, we can coop sometime

cheers bro

you are most welcome, yes 970 OC like a beast and this should give you around 15%-20% performance boost, in ACU case around 5-10 FPS, do note that you need to monitor GPU temp when OCing, but since 900 are ridiculously cool, nothing to worry about but its a must do practice when OCing and also do some stress testing for artifacts , personally i use MSI Kombustor which is an excellent tool as well for that purpose.

Btw, if you applied same settings, you also have OCed your memory clock to 8Ghz which also gives you a great performance boost as well ;)

yah sure, sent FR :)

AntiChrist7
12-01-2014, 03:49 PM
Unfortunatly, contrary what I said before, I still have 5seconds minifreezes. Less frequent it seems (once every 20-30 minutes), so I could live with it, where it not it kicks me out of co-op games....

At the moment im verifying files, but that didnt help last time., so...

YazX_
12-01-2014, 06:19 PM
Unfortunatly, contrary what I said before, I still have 5seconds minifreezes. Less frequent it seems (once every 20-30 minutes), so I could live with it, where it not it kicks me out of co-op games....

At the moment im verifying files, but that didnt help last time., so...

if you got an SSD, install the game on it and test, i believe the freeze will be completely gone (Hopefully). to move the game just cut/paste the files into the new location and change installdir registry key value in HKEY_Local_machine\Software\Wow6432Node\Ubisoft\As sassin's Creed Unity and HKEY_Local_machine\Software\Wow6432Node\Ubisoft\La uncher\Installs\720

Thecolourfulowl
12-01-2014, 06:38 PM
Hi Guys,

I'm running on two 970's (i'll place my full specs below) and i don't receive any issues with the game with SLI or without. I pretty much get a constant 60-55 FPS everywhere, there is the odd dip but it never goes below 45 FPS. There's only one place in the entire game that causes me to drop below 55 FPS, which is in the co-op mission 'Moving Mirabeau' when you entire the down stairs section (with the wheels) where my FPS dropped down to 21 and below.

The only suggestion i have for people on the gtx 970's (and any card for that matter) is make sure, not only are your graphics drivers up-to-date but also make sure all of your drivers are. Including: chipset/motherboard; operating system (windows updates); Hard drive ( if your running on a HDD ); sound card and finally any wireless/wired networking cards you may have.


My specs:

CPU: IntelŪ Core™i7 Six Core Processor i7-5820K (3.3GHz) 15MB Cache

Memory (RAM): 16GB Crucial DDR4 2133MHz (2 x 8GB)

GPU 1: Nvidia GTX 970 4gb (standard edition - No OC)

GPU 2: Nvidia GTX 970 4gb (standard edition - No OC)

Hard Drive 1: 120GB KINGSTON V300 SSD, SATA 6 Gb (450MB/R, 450MB/W)

Hard Drive 2: 1TB 3.5" SATA-III 6GB/s HDD 7200RPM 32MB CACHE (game runs of this HDD)

Motherboard: ASUSŪ X99-S: ATX, HSW-E CPU, USB 3.0, SATA 6 GB/s

Operating System: Windows 8.1 64 Bit (latest version)

Screen: BENQ XL2720Z 27" W, 3D LED GAMING MONITOR (i don't use 3 :D)

Wireless/Wired Networking Card: DUAL-BAND WIRELESS 802.11N 450Mbps PCI-E CARD

Sound Card: ONBOARD 8 CHANNEL (7.1) HIGH DEF AUDIO (standard)


I hope you guys can find a solution for fixing the game, if the above doesn't help.

shadygiz
12-01-2014, 07:23 PM
hey man, i just tried your settings and i got a nice boost in performance from 38 to averaging around 43-45 fps and even going till 50 and 60 easily ... thanks man, but i hope ubi fixes these issues as 970 is a beast of a card already without ocing and shouldnt have these performance issues. add me in uplay if u want, my id is bullsheet11, we can coop sometime

cheers bro
if you have a MSI card, you can use the MSI Gaming App to quickly set "O/C mode", "gaming mode" , "silent mode" or "cooldown mode"

AntiChrist7
12-01-2014, 07:34 PM
if you got an SSD, install the game on it and test, i believe the freeze will be completely gone (Hopefully). to move the game just cut/paste the files into the new location and change installdir registry key value in HKEY_Local_machine\Software\Wow6432Node\Ubisoft\As sassin's Creed Unity and HKEY_Local_machine\Software\Wow6432Node\Ubisoft\La uncher\Installs\720

It is unfortunatly already installed on my SSD, where all my big games go.

jousef_900
11-19-2015, 08:18 AM
Ubi will release a FPS patch soon expecting consistent 50-60FPS after that.. or hopefully higher

I hope you're right, I own a twin twin frozr GTX 970 and I'm getting 44 FPS on the lowest possible settings with FXAA, please don't pull a Ubisoft on us!

Emry1
11-19-2015, 08:39 AM
I'm getting all kinds of rendering issues on my 970. Some things in the world are invisible and glitching out. My cards isn't overheating and I can play the Witcher 3 just fine.

YazX_
11-19-2015, 09:57 AM
I hope you're right, I own a twin twin frozr GTX 970 and I'm getting 44 FPS on the lowest possible settings with FXAA, please don't pull a Ubisoft on us!

This is an old thread for ACU not ACS, please follow up on new threads for ACS.


I'm getting all kinds of rendering issues on my 970. Some things in the world are invisible and glitching out. My cards isn't overheating and I can play the Witcher 3 just fine.

Here is the solution (read red text in first post) :

http://forums.ubi.com/showthread.php/1331022-First-glance-on-Syndicates-Perfomance-and-quality-on-PC-Poor-right-now


Thread Closed