PDA

View Full Version : Micro stutter / fps drop every few seconds?



Xepton
11-15-2014, 10:55 AM
I think I've been fairly lucky with this game, because for the most part it runs well. However, every five seconds the fps drops for a split second and the game stutters. I have updated to the latest driver, disabled as many background programs as I feel it safe to do so and tried adjusting the advanced graphics settings from low to a combination of ultra high and very high settings, but to no avail.

The game is playable, but it's starting to become very annoying having to watch the fps drop suddlenly, albeit briefly every five seconds. Has anyone else experienced this? Is there a work-around / fix? I'm using a GTX 680, 16gb Ram and an AMD 8350, so I at least meet the reqs.


Cheers.

Deepo-U
11-15-2014, 01:04 PM
I'm getting this. I'm running a Intel 5820K and a GTX 690. The game usually starts out smooth, but starts stuttering after a while. The stuttering happens even if I'm just standing still and watching civilans pass by in the streets. Are you running with textures on High? The thing we have in common is the same amount of VRAM (I assume you have the 2GB version), so I suspect it's related to that.

DjKamo
11-15-2014, 01:28 PM
Same here, got 660 GTX 2Gb VRAM

Xepton
11-15-2014, 01:38 PM
I'm getting this. I'm running a Intel 5820K and a GTX 690. The game usually starts out smooth, but starts stuttering after a while. The stuttering happens even if I'm just standing still and watching civilans pass by in the streets. Are you running with textures on High? The thing we have in common is the same amount of VRAM (I assume you have the 2GB version), so I suspect it's related to that.

Yep, I have the 2gb version. I have even tried reverting back to older drivers, but that doesn't seem to help. I have the factory overclocked 680 and was wondering if that had anything to do with things so I under-clocked it down to its standard settings. Still nothing. Yeah, it happens to me when stood still as well:(

silverfall1986
11-15-2014, 01:41 PM
If you guys want to know how to monitor what your GPU (graphics card) is actually doing while your playing the game in real time then check this thread out

http://forums.ubi.com/showthread.php/951137-Can-you-guys-tell-me-what-the-GPU-utilization-is-like

FPS drops or stuttering might not be your fault at all if the games engine isn't utilizing your gpu.

Xepton
11-15-2014, 02:07 PM
If you guys want to know how to monitor what your GPU (graphics card) is actually doing while your playing the game in real time then check this thread out

http://forums.ubi.com/showthread.php/951137-Can-you-guys-tell-me-what-the-GPU-utilization-is-like

FPS drops or stuttering might not be your fault at all if the games engine isn't utilizing your gpu.

Just tried it mate, 48-98% varying wildly. Never a solid figure. i had this with watch dogs, however that didn't result in stutter.

Dellers
11-15-2014, 02:35 PM
I'm getting this. I'm running a Intel 5820K and a GTX 690. The game usually starts out smooth, but starts stuttering after a while. The stuttering happens even if I'm just standing still and watching civilans pass by in the streets. Are you running with textures on High? The thing we have in common is the same amount of VRAM (I assume you have the 2GB version), so I suspect it's related to that.
Same issue here. Usually starts stuttering really bad after a while. Even the main menu is stuttering if I go there after the problems start. I usually have to close my web browser as well to avoid stuttering, even though I have 12GB RAM and the game uses less than 3.

x___Luffy___x
11-15-2014, 03:46 PM
i have the same problem and no matter what settings you use , the stuttering never stops.

gudlbua
11-15-2014, 04:26 PM
i have the same problem and no matter what settings you use , the stuttering never stops.

Same happens for me - it's even happening in quite unpopulated areas and with lowered graphics settings. Seems like some sort of preloading glitch!? Internect connection on or off does not make a difference.

GTX 770 (2GB) and I7-2600k with 12 GB of RAM.

Shaftex
11-15-2014, 04:56 PM
I have the same problem.

I can run the game with Textures on Low-High, if I go to Ultra, the frames drop tremendously.
If I can at least play this game with High Textures, I will be so happy. However this is not the case.
With Low Textures applied, the game is smooth like butter for a while, and then it starts to stutter/hiccup EXACTLY every 3 seconds (I counted).
It will NEVER stop until I restart my game.
With High Textures applied, the game is smooth as well, but starts to stutter/hiccup a little sooner than the previous setting.
Both Texture settings give me about 25-30 FPS on average (30-45 FPS in some locations of the game).
There is obviously poor optimization with this game. I tried to do a roll back on my NVidea Driver from 144.65 down to 144.48.
Nothing changed. I tried everything I can do with no luck.
THIS GAME NEEDS A STUTTER/FRAMERATE PATCH ASAP.

My system specs are:

EVGA GTX 760 SC 2Gb VRam
AMD A-10 5800k 3.8 Ghz APU
8G RAM

Calgerion
11-15-2014, 05:41 PM
no matter on GPU memory.

I have GTX 770OC with 3GB memory.... and I have micro suttering, but whats more, even time to time complete freeze for few seconds...

tried many configurations with no sucess so far...

I am wasting my money on time by testeing the corupted game..... great

soccer06
11-15-2014, 05:50 PM
Same here. I have FX 6100, GTX 770, and 4GB RAM.

gudlbua
11-15-2014, 06:38 PM
I tested a bit more and it sometimes happens that the view just spins around in an instant - I look at Arno from behind, run towards a wall, move my mouse a little bit, there is a small stutter and suddenly I am looking at Arno from above the wall. I don't move the mouse enough for it to spin like that.

Elcx
11-15-2014, 06:43 PM
Because it's a Next-Gen Game. And because Ubisoft are Morons like EA.

Freddy4k
11-15-2014, 08:05 PM
Simple solution that works for me is to disable uplays online feature before starting the game by clicking the uplay cog icon on the top right. Then selecting (Go offline). I used to get quite alot of stutter on my i7-3770k 780ti. But now its working fine with very little stutter at 1080p maxed out. Apart from AA which i use TXAA. The only problem is you wont be able to have any online features. At least for now this is a temporary solution. Try it out guys. It will probably help. ;)

TheSaftschubse
11-15-2014, 09:26 PM
Didn't help for me. Using GTX660 2GB. The Framerate itself is actually fine, but i get these hiccups which make it unplayable. Hope that they'll fix it soon.

Freddy4k
11-15-2014, 09:44 PM
Its unlikely you`ll be able to run it perfectly because you are below the minimum requirements. Maybe overclocking will help.

Oakre
11-15-2014, 09:47 PM
Main issue with me as well is the stuttering, I don't mind playing on lower settings, tho more graphic settings would be nice if I see only a few graphic options then it just screams lazy port, right now I play on a lower resolution that makes is playable and I can actual fight somewhat, heavy fighting and stuttering = might as well uninstall the game haha

general specs
AMD FX-6200 2.8
GTX 660
16 ram

Now i know that the 660 is under min but after watching a few videos of people with 660 (apparently) im putting my money on the amd/nvida combo not working haha, first game that I have had a problem with, I put black flag on earlier max (90% of stuff high the other 10% no problems what so ever :/

Xepton
11-15-2014, 10:07 PM
Its unlikely you`ll be able to run it perfectly because you are below the minimum requirements. Maybe overclocking will help.

I exceed the minimum reqs. Also, aside from the split second micro stutter every five seconds, my fps hovers around 40fps. I have adjusted the graphical settings accordingly, but nothing helps.

TheSaftschubse
11-15-2014, 10:09 PM
Its unlikely you`ll be able to run it perfectly because you are below the minimum requirements. Maybe overclocking will help.

This is definitely not a problem of the 660. I monitored the GPU Usage via MSI Afterburner, and it hovers around 85% (ridiculous!). When i get these hiccups, the usage goes down to 55% for a split of a second. These Framedrops are definitely due to poor optimization. Nvidia / Ubisoft HAVE to address that!

Midnights666
11-15-2014, 10:27 PM
I have sapphire 2gb 7850 oc, 8 gb ram, i5 2500k, windows 7 64 bit.


I know graphic card is below minimum, but i tried all combinations of settings.

In mostly ultra settings(except shadow and aa) and ithe game performs well, BUT i have the hiccuping/stuttering every 4-5 sec which ruins gameplay.


AND when i chang ALL my settings to LOWEST, i still have the same PERFORMANCE, SAME FPS, BUT i STILL have the hiccuping/stuttering.

I tried lots of things, but the result was always the same.

I m really frustrated and just waiting for next patch... And i have no idea if it will solve stuttering....

Eymerich
11-15-2014, 10:33 PM
If it could be of some relief to you, i have a 780Ti and get solid 60 FPS (after switching to FXAA which really helps performances), yet i get the microstuttering anyway.
I assume it's just a game engine issue.

timbit2005
11-15-2014, 10:41 PM
I use msi afterburner, the riva tuner display program that comes with it has a framerate limit option, I set it to 60 and it eliminates the micro stutter. May help

TheSaftschubse
11-15-2014, 10:56 PM
I have sapphire 2gb 7850 oc, 8 gb ram, i5 2500k, windows 7 64 bit.


I know graphic card is below minimum, but i tried all combinations of settings.

In mostly ultra settings(except shadow and aa) and ithe game performs well, BUT i have the hiccuping/stuttering every 4-5 sec which ruins gameplay.


AND when i chang ALL my settings to LOWEST, i still have the same PERFORMANCE, SAME FPS, BUT i STILL have the hiccuping/stuttering.

I tried lots of things, but the result was always the same.

I m really frustrated and just waiting for next patch... And i have no idea if it will solve stuttering....

Same to me. I'm affraid it will take some time til ubisoft has solved this, im gonna quit playing until then.

Freddy4k
11-15-2014, 11:06 PM
I just tried RivaTuner and put a 40fps limit on it. I now get zero stutter all maxed out. Its as smooth as butter. It`s a great utility. I would rather have lower FPS than it looking quite bad due to Aliasing.
I find TXAA looks better than 4xMSAA but not as good as 8xMSAA. But that option destroys most PC`s.

TheSaftschubse
11-15-2014, 11:12 PM
I just tried RivaTuner and put a 40fps limit on it. I now get zero stutter all maxed out. Its as smooth as butter. It`s a great utility. I would rather have lower FPS than it looking quite bad due to Aliasing.
I find TXAA looks better than 4xMSAA but not as good as 8xMSAA. But that option destroys most PC`s.

Hm, tried to lock at 25fps which i'm always able to achieve, but still stuttering.
Just purchased a GTX770 4GB for just 199 bucks, hope this will at least allow me to play at 30-40fps on high...

Midnights666
11-15-2014, 11:15 PM
I just tried RivaTuner and put a 40fps limit on it. I now get zero stutter all maxed out. Its as smooth as butter. It`s a great utility. I would rather have lower FPS than it looking quite bad due to Aliasing.
I find TXAA looks better than 4xMSAA but not as good as 8xMSAA. But that option destroys most PC`s.

i will try that and post

Freddy4k
11-15-2014, 11:17 PM
I forgot to add. This is also by using offline play.
Still get poor stutter though when connected online through uplay.

Midnights666
11-15-2014, 11:17 PM
I just tried RivaTuner and put a 40fps limit on it. I now get zero stutter all maxed out. Its as smooth as butter. It`s a great utility. I would rather have lower FPS than it looking quite bad due to Aliasing.
I find TXAA looks better than 4xMSAA but not as good as 8xMSAA. But that option destroys most PC`s.

damn i just dont know how to, it is a bit complicated program. can u explain step by step for it please?

Freddy4k
11-15-2014, 11:39 PM
After loading RivaTuner click on the plus icon. Got to wherever the ACU.exe is located then add it.
Now select the ACU.exe on the list. Now on the right hand side you should see a Framerate Limit Option.
Just change that to 30 or whatever framerate you wish.
Lastly click on the down arrow found at the top right of the window. Do not click the x as it will close rivatuner.
Lastly just load the game as usual.

Hope it helps you.

Algent_
11-16-2014, 12:25 AM
When the micro sutter happen for me, I can clearly see the FPS count go up in dxtory. It's like the game is waiting for a thread a bit too long and have to pause a couple frames until it's finished.

psychic717
11-16-2014, 02:16 AM
I don't have the game yet, but you should know that the game needs 4GB of VRAM for Ultra Textures.
The lack of VRAM will cause massive stuttering and fps drops.


Texture Quality adjusts the clarity and quality of textures game wide. Unity offers three options for textures: Low, High, and Ultra High. Low is recommended for graphics cards with 2GB of VRAM, High for cards with 3GB, and Ultra High for cards with 4GB.

Lil_Pubik
11-16-2014, 02:21 AM
Having a Draw distance setting will solve everything. since the PC will have to work less in rendering objects far away and set far away objects with low low res.

My Specs:
Win 7 Ultimate SP1,
Intel i5 750 @ 2.67Ghz OC to 3Ghz,
Ram: 4GB Dual-Channel DDR3 @ 534MHz,
NVIDIA EVGA GeForce GTX 970 4095MB,
ASUStek Motherboard LGA1156,
Monitor/TV DELL 2001FP (1600x1200@60Hz) Only use this one when playing ACU and disable the next two listed; Princeton VL1918 (1280x1024@75Hz); Sceptre 1920x1080i/p used for PC racing games with xbox controller and will try to use for ACU if shudders, stutters and fps still show up in the new patch,
Logitech G930 Headset,
R.A.T. 7 Albino,
Los Angeles Time Warner Cable 7MB/s Download and about 1MB/s upload.



default everything was maxed out.
Had to downgrade all my setting to this to get the best setting with little freezes. i would get a a singe freezes ever 15-30 minutes but it will then continue. :

I had to turn off stretch and Vsync
Resolution: 1600x1200
Fullscreen
Refresh Rates: 60Hz
Environment Quality: Very High
Texture Quality: Ultra
Shadows: Low <- I recommend you turn this down to low too. I've read a few reports that there are some problems with this in 1.1.0 patch and will lift frame rates a bit.
Ambient Occlusion: SSAO
AA: MSAA-4x
Bloom: ON

Kayewla
11-16-2014, 02:24 AM
Has anyone tried turning off V-sync?