PDA

View Full Version : [Nexus5] Cannot update to newest version (September 30th) - Device is not compatible



oilikepieo
10-05-2014, 05:35 AM
After getting the update request in game it takes me to the play store to update. I cannot download the update since it says my device is not compatible. I am now unable to play the game since the update notification will never close.

Could the nexus 5 be allowed in the valid devices for the new update?