View Full Version : Can't log in to multiplayer on AC4 for PC

08-31-2014, 02:49 PM
I cant seem to connect to ubisoft servers when I try to play ac4 for PC. I have read similar posts and tried the resolutions provided but nothing seems to work. I have reset my router and modem as well as made sure ports that ac4 multiplayer runs are open, I have even disabled my firewall to see if any change and still cant connect. My son has the same issues with his copy and we both own farcry 3 and splinter cell blacklist both games we have no issues connecting on and playing multiplayer. Why can we not play this game multiplayer?

08-31-2014, 06:26 PM
Hello Havokhuntr,

Have you tried going to your "settings" menu in the Uplay PC Client by clicking the gear / cog icon in the upper-right of the window; once there, click on the Network tab and then make sure that "Always start Uplay in Offline Mode" and "Allow Uplay to use a proxy connection to access the internet" are unchecked; save the settings, and then restart the client to see if the issue persists?

I apologize if you have already tried this solution. If you need more assistance, please contact us by email or by phone. You can do so by visiting this webpage: https://support.ubi.com and selecting "My Questions" to start the ticket. You can find our phone information here: https://support.ubi.com/en-us/faq.aspx?platformid=9&productid=3888&faqid=kA030000000ee8ACAQ.