PDA

View Full Version : Assassins Creed 2 Shadows flickering and bad performance.



blazzx_414
06-25-2014, 12:31 AM
I've first played this game years ago when I was new to gaming and it seemed fine...
Shadow flickering and other thing didn't bothered me so much.
So now I am playing this games now and shadow flickering is not fixed and its driving me crazy. It also runs locked at 60FPS with occasional drops to 55. Max GPU usage is 45% and CPU 50% so I have no idea what are those drops. And even when it runs smoothly at 60FPS there are millisecond stutters. Are there any fixes/patches/mods that fix this things?

Voyager456
06-25-2014, 03:50 PM
Yea i also started playing AC2 not long ago and i also have that milisecond stuters unfortunately i dont think there are any unofficial patches
only thing i can recomend is turning off multisampling if you have it on.

playlisting
06-25-2014, 04:03 PM
I've first played this game years ago when I was new to gaming and it seemed fine...
Shadow flickering and other thing didn't bothered me so much.
So now I am playing this games now and shadow flickering is not fixed and its driving me crazy. It also runs locked at 60FPS with occasional drops to 55. Max GPU usage is 45% and CPU 50% so I have no idea what are those drops. And even when it runs smoothly at 60FPS there are millisecond stutters. Are there any fixes/patches/mods that fix this things?


Yea i also started playing AC2 not long ago and i also have that milisecond stuters unfortunately i dont think there are any unofficial patches
only thing i can recomend is turning off multisampling if you have it on.

Do either of you have SLI? Also what are your system specs?

Voyager456
06-25-2014, 04:39 PM
I myself dont have sli my pc is i5 4670k 4.4 ghz,gtx 760 overcloacked,8 GB 1600 mhz ram for me the game is running 60 FPS 98% of the time exepct that weird 1 milisecond stuter its not realy that bad as lets say watch dogs LOL though i notice when i go outside of towns in the hills and when i look at the foliage at the edge of the maps my fps drops from 60 to 30 and my gpu usage spikes all the way to 99% only way to get rid of that is to completly turn off AA :( not realy sure whats up with that considering 98% of the time gpu usage is 50-60 % even with multisampling up to x8 oh well i can live with that.

blazzx_414
06-25-2014, 07:36 PM
I don't run SLI (Crossfire for me :D) also...
My specs are I5 760 overclocked to 3.8, AMD R9 280x and I have an SSD so texture loading lag isn't a problem.
I think the problem is long frame time of a single frame that sometimes occurs... After all this runs on Directx 9 so the game can't properly use quad core CPU...

blazzx_414
07-01-2014, 01:07 PM
I've just tried it on a PS3. It actually plays a bit batter in some way...
It runs at 30fps with occasional FPS drops, shadows still have terrible draw distances but what really destroys the experience is frame tearing...
It's really sad to see a such good game being ruined by a poor optimization. PC version is fine but shadows flickering is so annoying.

AherasSTRG
07-01-2014, 02:00 PM
I had the exact same problem with Assassin's Creed Brotherhood. Both games have got problems with Hyper-Threading in new Intel proccessors (I have an Intel i5 3570). Disabling Hyper-Threading solves the issue, bit I would strongly advice you against doing so. Better find your old desktop or laptop and load the game there.