PDA

View Full Version : AC4 Physx Fix



Dicehunter
06-10-2014, 04:20 AM
As those of us who play AC4 know, With Physx enabled the games performance tanks even when looking at a simple wall.

There is a fix, Alt+Tab out of the game and open up the task manager and right click on AC4 and click on "Set Affinity", Uncheck your very last core, Press ok and then go back in and re-enable it, Also make sure shadowplay is disabled.

And that's it, Simple yet effective.

I'm guessing this helps spread the work load out more or something along those lines but it really does work, I'm now running the game at max settings TXAA 4X 1080P and it remains most of the time at 61fps which is the hard cap.

By the way this little trick also works for previous Assassins Creed games, Tried it in AC3, Brotherhood and Revelations, Performance improved across all of them :)

Hope this helps someone :)