View Full Version : Watch Dogs Failing to Open (Xbox One) [solved]

05-24-2014, 11:46 AM
Just received Watch Dogs. I have installed the game with the 100 meg update however when I try to start the game I receive the following error after a minute or so:

for some reason WATCH_DOGS has taken too long to start. 0x8027025a

I have tried rebooting etc but to no avail.

On a side note I do also have issues logging in on Assassins Creed. uPlay logs in independanelty with no problems but Assassins Creed just times out after a couple of minutes (just in case this is related for any reason).

Any suggestions?

05-24-2014, 11:55 AM
I was unable to get into my apps and games also so couldn't uninstall.

As a last resort just powered down the xbox then it works.

05-25-2014, 04:46 PM

Sometimes the Xbox One - does behave oddly, after installing a game - such as closing the game at start up - and it's recommend if you have this type of error - to fully shutdown the console, wait a minute or so and turn it back on.

This solves most game boot issues.

I will lock the thread and mark as solved :)