PDA

View Full Version : [PC] May be a little early for this, but help with freezes? [Solved]



Miss_Rhiza
05-23-2014, 05:48 PM
So after installing the physical copy of the game, activating it on Uplay and downloading a patch, I started the game and it works fine, although only up to the menus. I played around with the settings to suit my hardware and preferences then tried to start a new game. The loading screen got to about two thirds done, then the logo stopped animating and the bar wouldn't move any more. Checking the Task Manager told me that the game had frozen with 25% CPU usage and about 1,870,000K memory usage.

I force closed the application, lowered the graphics settings and tried again with exactly the same result. I tried validating the installation files which went fine, then tried to run the game again with all graphics settings at minimum. The loading screen got to the same place, but this time started flashing a blue screen every couple of seconds. After minimizing and restoring, I could hear what I assume to be cutscene audio, but the whole screen was just black.

Further attempts just resulted in crashes to desktop at the same part of the loading screen.

PC Specs:
Windows 7 Ultimate 64bit
AMD Phenom II X4 955 Black Edition (3.2GHz, Quad Core)
4GB RAM
ATI Radeon HD 6870 (2GB VRAM)

Help?

GuZZ33
05-23-2014, 06:29 PM
downloading a patch.A patch already?. What are the patch notes?.

Miss_Rhiza
05-23-2014, 06:41 PM
A patch already?. What are the patch notes?.I have no idea, I just had to download an extra 42MB before Uplay would let me run it.

commonFury
05-23-2014, 08:42 PM
not much we can do ATM.

and yes you are 3 days early to the release ;)

HawxLike
05-24-2014, 01:43 PM
I've noticed quite a few issues with AMD cards. I think it's due to the lack of drivers, which won't be released until release day.

Shau0lin
05-24-2014, 03:21 PM
I'm having the exact same issue. I get to about 2/3 loading screen then either my PC reboots or I get an error.
I'm running AMD Radeon HD 6800 so maybe like has been said, have to wait for drivers on patch day?

Miss_Rhiza
05-24-2014, 05:33 PM
Just posting an update here:

I'm not sure exactly what I fixed, but I've got the game running now after a reboot and updating my ATI drivers to version 14.4 / latest version.

Might be worth a try if anyone else is experiencing the same / similar issues.

Shau0lin
05-25-2014, 11:05 AM
Ah, excellent, fixed my problem.
Anyone else having this issue try installing the AMD 14.4 update
http://support.amd.com/en-us/download/desktop?os=Windows%208%20-%2064#amd-catalyst-packages

Mr_Shade
05-25-2014, 04:23 PM
So, driver updates fixed the issue?

Good to know.

I will close this thread down, so that we can track other issues.