PDA

View Full Version : Game runs so slow sometimes!



PKPRODUKYS
05-13-2014, 06:59 PM
Hello I recently bought trials fusion for the pc as I loved the trials games on the xbox 360 and tho I have a good pc that can run games such as Titanfall and Elder scrolls online in 1080p while recording, I am struggling to run trials fusion smoothly as most of the time in 1080p as i get a lot of frame lag especially from the background stuff such as snow, explosions and it's quite annoying especially when you are trying to beat somebodys score.

Now I've tried all the setting to low and It still happens, even tried to put it in 720p and it seems alot better but i still get the odd frame lag.

My specs are,
Amd quadcore 3.8ghz
8gb ddr3 ram
WIndows 7 64bit Ultimate edition

and I am running with a Nvidia GTX 650 1gb ddr5

Here is my dxdiag info http://pastebin.com/H94kzhbN

Any ideas? Thanks for reading.

En0-
05-13-2014, 07:20 PM
Hello,

Which graphic settings are you using?

Cheers,

PKPRODUKYS
05-14-2014, 02:21 AM
I've my setting set to low and it still does it even with everything turned to minimal even tried turning AA off, but yeh ive tried all settings for the game even with everything set to medium / high,

Dullahanx
05-16-2014, 11:34 PM
On a gtx 480 I can run everything on high with max frames 100% of the time, so you should be ok. What kinds of things are you running in the background? I noticed while running certain programs while playing like encoding or compression software, my in game frames would drop, but otherwise it always runs smoothly. I'd try turning off all other programs and see if you notice a difference.

IImayneII
05-17-2014, 10:54 AM
You can try this


https://www.youtube.com/watch?v=syE55-jEzb8

mrjorts
05-17-2014, 08:56 PM
Yesterday I started getting really bad frame rates in places that used to run smoothly before and I eventually realized it was because of a flash video I had playing in my browser. The CPU wasn't being maxed out or anything, but switching the player to HTML5 video fixed my frame rate right up. Don't know if this will help, but might be useful for someone.

TeriXeri
05-18-2014, 03:01 PM
Playing youtube videos in the background caused slowdown for me indeed, I turned off hardware accelleration for my browser and it works just fine again.

PKPRODUKYS
05-18-2014, 11:24 PM
On a gtx 480 I can run everything on high with max frames 100% of the time, so you should be ok. What kinds of things are you running in the background? I noticed while running certain programs while playing like encoding or compression software, my in game frames would drop, but otherwise it always runs smoothly. I'd try turning off all other programs and see if you notice a difference.

Yeah like I said I can play Titanfall in high graphics and record at the same time with no frame drop what so ever, erm I always have the same open, Geforce Experience (as i use shadowplay to record) I also have AMD gaming evolved app. but these do not effect any other game I play, so apart from them I have steam open (which opens as i bought the steam game) and then the Uplay client ( which was required to download to play trials) and the uplay tells me stuff may go wrong ingame if its not running.

So yeah I also don't play games with stuff like Chrome open while gaming.


and to @bassline001 Thanks for the video Ill prob check it out though I don't like the idea of fiddling with my graphics drivers ( I probably would use that program if I had the same experience with every game I play on but probably not just for 1 game)

UseLessUK
05-29-2014, 03:46 PM
Greetings,

Try running just the game and see if things improve.... if not then it will certainly rule out the apps you are running as well as the game, and point to a problem elsewhere.