PDA

View Full Version : 'Tool Selection' issue



HazyDragon
03-31-2014, 07:19 PM
I love this game, have beaten it, and started over again to beat it again, but, there is a major issue that I can't seem to shake. So, I use a Logitech Marble mouse. It has 4 buttons, and no scroll wheel. I have a Microsoft 4000 keyboard, and it has a 'Zoom' wheel that I can use to zoom in and out, and on occasion, actually use to select tools. Generally, though, I just stick to the 1-7 keys.

Here's the issue; when I, say, use my spyglass to see what a ship is, if it's worth attacking or not, and I zoom in or out, or use the zoom wheel, or using the map zooming, I then let go of the ship's wheel to do any other actions, and all I hear and see is me constantly scrolling down on the 'tools' menu, and I cannot stop it, less a full game restart. Not bad, really, unless I need to select my sleeping darts, or my bezerk darts... or any other tool for that matter. Less the pistol! I can use that easy.

The only way I can stop this is if I shut the game down entirely, and re-start it, it'll resume like normal. Sadly, the 'Tools' is hard-bound to the mouse wheel... so, can't change that. And, that really sucks, but, I am used to some games discriminating, no big deal. Haha.

Personally, I just want to disable the use of mousewheel for tools, and use it only for zooming in/out alone, if there's some way to bind it that way via a registry fix, or maybe a settings file?

So, is there any workarounds? And, when I use the keyboard on other games, I don't get this at all. This is the only game it happens on.

Thanks for reading this.

Minor Update! Just for giggles, as it was trying to go down, I pushed my 'zoom' wheel up.... and it didn't do anything for a while, then it shot up. How odd... then, I tapped down a few times, and then up, and then finally it stopped trying to scroll, and let me just use one tool. Not sure if that helps, but, there it is.

YazX_
03-31-2014, 09:11 PM
all controls mapping and settings are stored in Documents\Assassin's Creed IV Black Flag\Assassin4.ini, im not sure if mouse wheel are there but you just need to find the mouse wheel up/mouse wheel down and change the value to "-1". (it might be hard coded)

search under [KeyboardMouse2 DefaultBindings], try to change anything with the word stick in it one by one and experiment the result until you find the correct one, if you messed up the file, just delete it, the game will create a new one once you launch it again with default settings.

if you tried them all and didnt find the mouse wheel, then unfortunately its hard coded.