PDA

View Full Version : Assassin's Creed 4 ( Fps drop in multiplayer)



Rachit.
01-12-2014, 07:31 AM
Assassin's creed 4 is good game but not good for AMD gpu's ...... i have radeon Hd 7770 pci and game running like crap in my gpu specially multiplayer ..... singleplayer running fine for me 30-40 fps but multiplayer is horrible .. I'am getting 20 fps in multiplyaer sometimes 12 fps too .... My gpu is good enough to handle the game but i don't know what is the problem. At some point in round i get 40-50 fps but only in some part and moreover AMD too doing nothing about the game . I suspect lot of people specially AMD holders have this problem. i google it a lot of time but can't find any solution and lost hope of getting fixed! i don't know why they can't fixed the game. if i can run singleplayer easily defiantly i can run multi at high settings. this same thing happen to ac3 too THE FAMOUS BOSTON LAG which was never fixed for amd :mad: ... The game has low fps and freeze issue still not fixed properly also no AMD drivers for ac4 this is what disappoint me most . Nvidia sponsor the game that doesn't mean only nvidia users can play game nicely and others are not :( ! Ubisoft and AMD must take a step to solve this problem otherwise one day will come when no AMD user gonna play assassin's creed !

D4rthK1LL3r
01-12-2014, 08:38 AM
4 patches rolled out and still nothing :confused:

Sdwakias
01-12-2014, 09:30 AM
I am also an AMD GPU user. I have a Radeon HD 4870, and I don't have much FPS drop in Multiplayer. Do you have the graphic options set at the lowest? You should also disable Post Effects and SSAO. I don't see how an older GPU like mines, with only 512MB of VRam can play the Multiplayer without FPS drop, sometimes I do have delay because of the internet, but no FPS drop at all, and yours with 1GB VRam and more powerful than mine is having problems. Are you sure you CPU is capable of running the game? And how about your internet connection? Maybe you are suffering from delay and lag, rather than FPS drop. Note that lowering the graphics at the minimum and disabling SSAO and Post Effects won't have a big impact on the overall graphics, so don't be afraid to lower them.

Rachit.
01-12-2014, 10:38 AM
My internet is good and about lowering graphics i tried at lowest settings still fps drop.. are we talking about ac4 so yeah .... i run ac3 multi at 1600x900 at full graphics and got 45-50 fps . I'am sunning singleplayer at 30-45 fps.. its not my card or pc fault mate its game i guess ... what's ur specs ? :p

angrygringo
01-13-2014, 08:48 PM
i think i hv problem even with my nvidia gpu gt 610 2 gb vram nd i get very little fps in both nd ur my pc overcome ur game's requirement i hv 8 gb ram , i3 3.30 ghz little my both mp nd sp give me less fps .
i get less fps still on making my game on low resoultion in single player nd still when i run my game on mp even with high setting den my single player i got more in fps in multiplayer , at least they should be equal.:mad:

Rachit.
01-14-2014, 07:03 AM
Exactly my point .... i tried to lower my graphics and resolution still i get very low fps .. well this is not good !

Black_Widow9
01-14-2014, 07:25 AM
Hello,
We haven't seen many complaints of this for AC4. Please contact Support with the details of your hardware and the specifics.
Ubisoft Support Website (http://support.ubi.com/)

Thanks

Rachit.
01-14-2014, 08:06 AM
Thank you .. i posted to support hope they solve our problem :(

If anyone experience this issue please go to support and tell them cuz they want many proofs ! they are not satisfy with my ques !

GR_Thanasis
05-11-2014, 05:00 PM
I have an R9 270x and i have fps drops on multiplayer a lot!

Suddenly the fps from 60 are going to 35-40 and the game is lagging.. I play on High Settings and even if i drop them to low i experience the same thing. 35-40 fps and lag. Moreover, I use triplebuffering via d3dOverrider.

My system specs :

i5 3350
R9 270x
4 GB RAM