PDA

View Full Version : AC Black Flag Freezing Glitch HELP PLEASE. :'(



Ragnarzk
01-06-2014, 10:27 PM
I have heard that this problem happens to several other people.
I have way above and beyond the system requirements for this game here they are:

Windows 7 64 bit
AMD Phenom II X4 965 Processor
8GB RAM
AMD Radeon HD 6800 Series.
------------------------------------------------------------

I'll be lucky if I get 30 minutes of gameplay without my game freezing on me.
sometimes it freezes completely. Other times it will freeze and have other animations still working.
example: When i'm on my ship everything will freeze except HALF the rain and waves.
And another one is the sound and music stop while everything else is still going and than
it freezes and than the sounds start again only to catch up to where
it froze and than start for a little than freeze again to the point where I have to restart the game.

This is getting annoying and preventing me from experiencing the game to the fullest without interruption :/
PLEASE. HELP.
If you have any questions please ask.
Thank You.

Carrot_mop
01-11-2014, 01:24 AM
I am also getting this fault.

I have rebuilt my computer, upgraded the sound card, motherboard, CPU and memory.

I have run physical level checks on my HDD and memory.

I have ensured the latest drivers are installed

I have installed the game from my disk and then after a rebuild from uplay (to make sure it is not the media)

I have removed the overclocking from my GPU

I have removed and re-installed the game so many times that I have lost count

I STILL cannot get off the first island after the intro.

The annoying thing is that it DID work for about a week. Between the first uplay update and the first BF update. Now it will only run for 5 mins a time max and I have lost my save-games.

I have logged a "Question" with Ubisoft (23/11/13), but the only reply I have had so far is "please clear down your temp files, remove background processes and re-install"

I have taken to updating the "Question" each time I try something new (patches, upgrades, diagnostics, etc)

Win 7 64bit Ultimate
Intel Core i7-4770K 3.50GHz
16Gb Ram
NVidia 680GTX

Macho
01-11-2014, 06:40 AM
I have heard that this problem happens to several other people.
I have way above and beyond the system requirements for this game here they are:

Windows 7 64 bit
AMD Phenom II X4 965 Processor
8GB RAM
AMD Radeon HD 6800 Series.
------------------------------------------------------------

I'll be lucky if I get 30 minutes of gameplay without my game freezing on me.
sometimes it freezes completely. Other times it will freeze and have other animations still working.
example: When i'm on my ship everything will freeze except HALF the rain and waves.
And another one is the sound and music stop while everything else is still going and than
it freezes and than the sounds start again only to catch up to where
it froze and than start for a little than freeze again to the point where I have to restart the game.

This is getting annoying and preventing me from experiencing the game to the fullest without interruption :/
PLEASE. HELP.
If you have any questions please ask.
Thank You.

Your setup is similar to mine.

Windows 7 64 bit
AMD Phenom II X6 1100T
8GB RAM
AMD Radeon HD 6870

I was having regular freezes while sailing. The freezes caused glitches in my system where I would need to restart. I had already updated Catalyst to the latest version 13.12. On a hunch, I checked my Bios and it was outdated. I updated the Bios and the freezes were fixed. No other settings were changed.

abn505
01-11-2014, 06:27 PM
I have heard that this problem happens to several other people.
I have way above and beyond the system requirements for this game here they are:

Windows 7 64 bit
AMD Phenom II X4 965 Processor
8GB RAM
AMD Radeon HD 6800 Series.
------------------------------------------------------------

I'll be lucky if I get 30 minutes of gameplay without my game freezing on me.
sometimes it freezes completely. Other times it will freeze and have other animations still working.
example: When i'm on my ship everything will freeze except HALF the rain and waves.
And another one is the sound and music stop while everything else is still going and than
it freezes and than the sounds start again only to catch up to where
it froze and than start for a little than freeze again to the point where I have to restart the game.

This is getting annoying and preventing me from experiencing the game to the fullest without interruption :/
PLEASE. HELP.
If you have any questions please ask.
Thank You.

I have had this issue for two months, tried everything Ubisoft recommended, still same thing. I tried this today, that has worked so far. I will see with more game time. I replaced the shortcuts the game installed on my desktop with the ones in the game folder. My file address is below. Create a desktop shortcut with the ones in the game file.


C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Assassin's Creed IV Black Flag

abn505
01-11-2014, 11:25 PM
That got me 3 hours before a crash.

Black_Widow9
01-12-2014, 04:54 AM
Hello and welcome to the Forums :D
Please contact Support with the details of your hardware and the specifics.
Ubisoft Support Website (http://support.ubi.com/)

Thanks

Carrot_mop
02-05-2014, 11:01 PM
Has anyone had a reply from Ubisoft about this yet?

My support ticket has been open since 23rd Nov last year and the only updates I have are a request to add the msinfo32 file and a generic email that talked me through basic housekeeping.

I notice (with extreme annoyance and more than a little cynicism) that more DLCs and additions re being released.

Carrot_mop
02-09-2014, 02:22 PM
After much trail and error, I decided to set all graphics options to the lowest I could. That helped to stabalise the game (still crashed, but usually only after an hour). I then turned on each of the graphics options one at a time. I found that I had to have the anti-aliasing turned off completely within the game.

I have a GX680 and I am running driver 332.21.

I know this will not work for everyone, but if it does help some people I will be happy.

Hoozeyerdaddie
02-10-2014, 02:06 AM
As of the latest update (5 GIG? Really?) my system has STARTED exhibiting these "freeze" symptoms.

1) Music is INTERMITTENT. It plays, stops playing, and plays again.
2) Graphics Freeze "halfway" - I.e. when on the deck of a captured ship, all the tunes freeze, but the rain keeps falling.
3) Load Times like you wouldn't believe - I mean it's like 3 to 4 MINUTES to load after a quick travel or re-entering the game. This used to be no more than 90 seconds, with 15 seconds being typical.
4) Cutscenes are now Glitchy as all hell. Animations get behind audio, or freeze entirely.

This is my 2nd time through the game. I've already played through ONCE, and had NONE of these problems - game played smooth as silk, scenes were snappy, cutscenes were fine.

What the HECK are you guys at UBISOFT doing? It's almost like someone released a DEBUG BUILD! (You know, runs so slow because it's not optimized....)

I'm going to have to re-think my opinion of this game if it doesn't get FIXED in the next update.....

UPDATED: Tried the "put everything in Graphics to LOWEST LEVEL and then back." So I put everything down to 1024X768 and all effects off....played a scene, and then back to DEFAULT, and everything seems to be pretty normal again. Will repost if there are more problems.....