PDA

View Full Version : How to enable AMD's crossfire in AC4: Black Flag



Blood_Baron
12-21-2013, 05:33 PM
Thought the lack of crossfire was disappointing especially since the game at highest settings takes 2 cards minimum
end goal is to play game at ~60fps trying to not dip lower than ~45fps all the while trying to still look pretty
found how to make it work giving me a more pleasant experience in AC4, didn't see any other posts for this so here we go

My system specs:
Windows 8.1 pro x64
Asus 1440p @60hz monitor
Intel i7-4930k OC to 4.5ghz
16gb ram 9-10-10 @2133mhz
Asus ROG rampage IV black edition motherboard
2x AMD Radeon HD 7970 in Crossfire OC at 1100 core clock and 1500 memory clock
120gb SSD

How to get Crossfire going:
1. install latest version of Drivers found Here (http://support.amd.com/en-us/download)
2. reboot
3. open up the AMD catalyst control panel
4. go to 3d application Settings
5.add a profile for AC4BFSP.exe or AC4BFMP.exe
6. leave everything as is except for amd CrossfireX Mode set that to Optimize 1x1
7. save

Crossfire should now be working in game
Results may vary
set in game settings to your preference

Here are mine @1440p 60hz
environment quality: very high
Texture Quality: high
Anti - aliasing quality: Msaa x4 (fps dips to 48 if you want closer to 60 then set to msaa x2 or eqaa x2)
Shadow quality:very high
Reflection quality:high
motion blur: on
ambient occlusion:Hbao+ (high)
God rays: on
volumetric fog: on
Vsync: on

Other tips to improve fps:
disable vsync helps but induces screen tearing
alternative is use vsync with triple buffering enabled with RadeonPro
Also can set Process as high priority in Task manager or force it with RadeonPro

Hopefully Amd will release a application profile for Black flag sooner rather than later although seeing as there is none for AC3 i doubt that will happen :(
PC MASTER RACE out ciao

Edit seem AFR friendly caused the uplay UI to conk out setting it to optimize 1x1 seems to fix it
edit post with this

satanrules666
04-14-2014, 04:12 AM
Thought the lack of crossfire was disappointing especially since the game at highest settings takes 2 cards minimum
end goal is to play game at ~60fps trying to not dip lower than ~45fps all the while trying to still look pretty
found how to make it work giving me a more pleasant experience in AC4, didn't see any other posts for this so here we go

My system specs:
Windows 8.1 pro x64
Asus 1440p @60hz monitor
Intel i7-4930k OC to 4.5ghz
16gb ram 9-10-10 @2133mhz
Asus ROG rampage IV black edition motherboard
2x AMD Radeon HD 7970 in Crossfire OC at 1100 core clock and 1500 memory clock
120gb SSD

How to get Crossfire going:
1. install latest version of Drivers found Here (http://support.amd.com/en-us/download)
2. reboot
3. open up the AMD catalyst control panel
4. go to 3d application Settings
5.add a profile for AC4BFSP.exe or AC4BFMP.exe
6. leave everything as is except for amd CrossfireX Mode set that to Optimize 1x1
7. save

Crossfire should now be working in game
Results may vary
set in game settings to your preference

Here are mine @1440p 60hz
environment quality: very high
Texture Quality: high
Anti - aliasing quality: Msaa x4 (fps dips to 48 if you want closer to 60 then set to msaa x2 or eqaa x2)
Shadow quality:very high
Reflection quality:high
motion blur: on
ambient occlusion:Hbao+ (high)
God rays: on
volumetric fog: on
Vsync: on

Other tips to improve fps:
disable vsync helps but induces screen tearing
alternative is use vsync with triple buffering enabled with RadeonPro
Also can set Process as high priority in Task manager or force it with RadeonPro

Hopefully Amd will release a application profile for Black flag sooner rather than later although seeing as there is none for AC3 i doubt that will happen :(
PC MASTER RACE out ciao

Edit seem AFR friendly caused the uplay UI to conk out setting it to optimize 1x1 seems to fix it
edit post with this

First off thanks for this am new to crossfire in fact i just got my second sapphire r9 280x today i am happy my coolermaster gx 750 is holding up.

I noticed weird things with assassins creed 4 in crossfire first id get piss poor performance if i did not have amd overdrive enabled on both cards.
Id get frame skipping and other terrible things and it would go from a slow 25 fps sometimes down to 18 really wish amd would just fix the problems as my mate with one nvidia card gets 60 fps even though hes a rich *** with a titan.

Hopefully this helps some people at the moment in built up areas i get 25 to 30 fps maxed out on all settings and when sailing get about 30 to 40 fps nothing great like 60 fps or over but i guess it will do.

I bet bottom dollar every other game will go a lot better.

I wish Ubisoft would look into it. If a game goes good with both nvidia and amd then you increase your market otherwise you will get more nvidia users buying the game than amd.