PDA

View Full Version : Is there a way to lock the frame rate to 30 (so it won't go up to 60) ? AC4



ExitT0ExisT
12-10-2013, 06:15 PM
As some of you may noticed, when you enable v-sync at AC4 the frame rate you get is either 30 or 60 and when you disable v-sync you get a lot of screen tearing.

My question is: Is there at least a way to lock the frame rate to 30 so it won't go up to 60 when i look up the sky or look down and drop back to 30 again?

PC: gtx 670, i5 2400 , 16gb ram

Side note: I honestly can't understand how a major company like ubisoft would f*ck up the PC version with a problem like this. To give example i developed a game on Unreal Engine 3 called Ocean City Racing and by default i made v-sync enabled and let's say the frame rate drops from 60 to 30 and the player doesn't notice this huge drop. The frame rate drop is only noticable if it goes down to 20 then the game would slow down.
But at AC4 you get 60 fps, and in an instant it can even drop to 20 with a GTX 670 no matter the gfx settings:mad:

drakkar321
12-10-2013, 06:36 PM
As some of you may noticed, when you enable v-sync at AC4 the frame rate you get is either 30 or 60 and when you disable v-sync you get a lot of screen tearing.

My question is: Is there at least a way to lock the frame rate to 30 so it won't go up to 60 when i look up the sky or look down and drop back to 30 again?

PC: gtx 670, i5 2400 , 16gb ram

Side note: I honestly can't understand how a major company like ubisoft would f*ck up the PC version with a problem like this. To give example i developed a game on Unreal Engine 3 called Ocean City Racing and by default i made v-sync enabled and let's say the frame rate drops from 60 to 30 and the player doesn't notice this huge drop. The frame rate drop is only noticable if it goes down to 20 then the game would slow down.
But at AC4 you get 60 fps, and in an instant it can even drop to 20 with a GTX 670 no matter the gfx settings:mad:

I would highly recommend that you disable v-sync in game and use adaptive v-sync in the Nvidia Control Panel. This will solve your problem without the need to lock the frame rate. You can follow the link at the bottom of my post for more information on it. However, to answer your question, yes, you can also enable half-rate v-sync in the Nvidia Control Panel, which should lock your frame rate at 30 fps.

Sandcracka
12-10-2013, 06:57 PM
I would highly recommend that you disable v-sync in game and use adaptive v-sync in the Nvidia Control Panel. This will solve your problem without the need to lock the frame rate. You can follow the link at the bottom of my post for more information on it. However, to answer your question, yes, you can also enable half-rate v-sync in the Nvidia Control Panel, which should lock your frame rate at 30 fps.

This. The in game vsync is borked just like AC3.

ExitT0ExisT
12-10-2013, 07:10 PM
I would highly recommend that you disable v-sync in game and use adaptive v-sync in the Nvidia Control Panel. This will solve your problem without the need to lock the frame rate. You can follow the link at the bottom of my post for more information on it. However, to answer your question, yes, you can also enable half-rate v-sync in the Nvidia Control Panel, which should lock your frame rate at 30 fps.
You mean like this?
http://i.imgur.com/FdugkiS.jpg
Tried turning vsync off in-game and making it 'on' at control panel a few hours ago. Will try this now

edit: Just tried making vysnc adaptive at control panel and 'off' at game. Maybe you don't notice it yourself but there is heavy screen-tearing but yeah i get 50 fps when vsync is turned off. If only there wont be any screen tearing..

BalefulMongoose
12-10-2013, 11:09 PM
The problem is the game has no in-built triple buffering.

If you download D3DOverrider and add the black flag executable to it you can play with v-sync on without a lock at 30 or 60 fps.

Frag_Maniac
12-11-2013, 03:54 AM
Settling for 30 FPS with that hardware spec would be ludicrous. Instead of capping it at 30, either employ adaptive VSync as mentioned, or force triple buffering via NCP or Direct3DOverrider. The reason the FPS dip to 30 is because the game lacks triple buffering.

ExitT0ExisT
12-11-2013, 12:06 PM
Settling for 30 FPS with that hardware spec would be ludicrous. Instead of capping it at 30, either employ adaptive VSync as mentioned, or force triple buffering via NCP or Direct3DOverrider. The reason the FPS dip to 30 is because the game lacks triple buffering.

Hi, i already tried both. At adaptive vsync i get screen tearing, at triple buffering there are still times the fps drops from 50 to 30 at a moment and then decides to stay there.

I hate 30 fps thats why i game at pc with a x360 gamepad on a hdtv but every year every assascreed game it's the same story.. Last years thing was when you go to boston the fps would drop to 30 but dropping the environment quality to 'normal' made he fps 60 at ac3, has no effect on ac4

strigoi1958
12-11-2013, 12:44 PM
have you tried changing your driver ? I found some drivers from Nvidia give me strange artifacts (in farcry 3 the blood became glittering) while others give me tearing or colour problems.... (they turned connor blue in AC3 and destroyed splinter cell blacklist so much I refuse to play it) at present I am running 331.82 but the only trouble free driver before that is 314.22 I would suggest you try swapping till you find a good one..... also if you use 320.18 you do it at your own risk

Secu12
12-11-2013, 12:49 PM
Use Direct3DOverrider method. As I read your comments you haven't tried this one yet.

z0m81e_de
12-11-2013, 01:03 PM
You mean like this?
http://i.imgur.com/FdugkiS.jpg
Tried turning vsync off in-game and making it 'on' at control panel a few hours ago. Will try this now

edit: Just tried making vysnc adaptive at control panel and 'off' at game. Maybe you don't notice it yourself but there is heavy screen-tearing but yeah i get 50 fps when vsync is turned off. If only there wont be any screen tearing..
there is another setting under the adaptive one, should be something like "half refresh rate" (halbe bildwiederolfrequenz in german). then the game is locked to 30 and all the tearing is gone,

drakkar321
12-11-2013, 02:59 PM
Hi, i already tried both. At adaptive vsync i get screen tearing, at triple buffering there are still times the fps drops from 50 to 30 at a moment and then decides to stay there.

I hate 30 fps thats why i game at pc with a x360 gamepad on a hdtv but every year every assascreed game it's the same story.. Last years thing was when you go to boston the fps would drop to 30 but dropping the environment quality to 'normal' made he fps 60 at ac3, has no effect on ac4

I use adaptive v-sync with all games and don't personally have any problems with tearing while using it. However, I have seen some people still complain of tearing issues when using it. I think it has a lot to do with the specific monitor being used. If you do still have problems with tearing, you can try using a third party program, as suggested, to enable triple buffering. Rumor has it that the Nvidia Control Panel triple buffering option will not work for DirectX games. I haven't personally done much research on the subject because adaptive works well for me, but if it is true, then you would need to use a third party program, like D3DOverrider, to enable it. Triple buffering should allow you to use normal v-sync without the huge drops in fps or stuttering (though some people complain of latency issues with triple buffering and I have read issues about windows 8 compatibility with RivaTuner tools such as D3DOverrider but I still think this may be your best option if you are not happy with adaptive v-sync). The other option is of course is using the half-rate v-sync that you first asked about, if you just want to lock it at 30 fps.