PDA

View Full Version : Lag / FPS Drops



SoG Guerrilla39
12-08-2013, 01:57 AM
Does the majority of players still have an issue with the lagging? Just bought this game off amazon, have Uplay installed, etc, and when I play it I get some choppy frame-rates on and off. it drops to like 20-30 fps it feels like, then stays up around 50; fluctuating quite a bit. (just speculation, but there is a huge noticeable drop)

3770k I7
GTX 660TI graphics (driver's fully updated)
8gb ddr3
1tb hdd

I know it's not my setup, because Battlefield 4, Bioshock infinite and Far Cry 3 all run silky smooth and look incredible.

Is there something I should disable? Or any updates I don't know about? Any help is appreciated. Thanks

SoG Guerrilla39
12-08-2013, 03:10 AM
I think you posted that in the wrong thread buddy lol

HypeR.tgL
12-08-2013, 03:15 AM
It's the ingame vsync, turn it off and you should be sweet.

Or you can press Ctrl + Alt + Del while the game is loaded(In game), or w/e you usually use to lock the screen and then proceed to click and open AC IV window up again, that should enable triple buffering which will variate the FPS instead of locking at 30 and 60.

SoG Guerrilla39
12-08-2013, 03:33 AM
It's the ingame vsync, turn it off and you should be sweet.

Or you can press Ctrl + Alt + Del while the game is loaded(In game), or w/e you usually use to lock the screen and then proceed to click and open AC IV window up again, that should enable triple buffering which will variate the FPS instead of locking at 30 and 60.

I tried both those things man and they didn't work. Now that I've played it a little more, It looks like i'm only getting 30 locked, with some fluctuations.

HypeR.tgL
12-08-2013, 03:45 AM
You probably have forced Vsync on your Nvidia control panel then.

SoG Guerrilla39
12-08-2013, 07:28 AM
You probably have forced Vsync on your Nvidia control panel then.

I checked it in the Nvidia Control Panel and turned it to "off". It's actually a little better, but now i'm getting that horizontal line blur when I move.
Just had the game crash on me too when I was at a fort.

I appreciate the help guys but I could really use a patch of some sort Ubisoft. I was hoping the fps issue was an easy fix but apparently not.

HypeR.tgL
12-08-2013, 08:44 AM
I'm only running a i5 3470 with a GTX 660 and I get 45 fps avg, there's no real problem here apart from understanding how to setup your settings ingame.


That horizontal line blue thing is called Screen Tearing, it's fixed by enabling vertical synchronization(vsync).

Simply turn it on ingame, then lock the screen and go back into the game, by doing this you enable triple buffering which fixes this fps issue that alot of people are having.

SoG Guerrilla39
12-08-2013, 11:08 PM
dang So why do I feel like i'm getting much less performance for the card I have.. maybe i'm comparing it to games that are way better optimized for PC? Bioshock infinite is a beast and it runs perfectly.

That brings me back to the original problem; with vsync on it's slower. And I tried the lock screen thing and it didn't do much of anything for me. Is this thing just me or is black flag not well done on this platform?

drakkar321
12-10-2013, 07:35 PM
dang So why do I feel like i'm getting much less performance for the card I have.. maybe i'm comparing it to games that are way better optimized for PC? Bioshock infinite is a beast and it runs perfectly.

That brings me back to the original problem; with vsync on it's slower. And I tried the lock screen thing and it didn't do much of anything for me. Is this thing just me or is black flag not well done on this platform?

Try using adaptive v-sync. You can get more information from the link at the bottom of my post, as well as a few other tips which might improve performance.