PDA

View Full Version : Very Low FPS in AC4 Multiplayer (Nvidia-Cards Solution)



Alcatraz1337
11-23-2013, 06:58 PM
I suppose many of us are experiencing a very poor performance in this game, especially those with graphics cards from the 5xx-Series or below.
What seems to improve the performance on my system quite a lot is the following:

- Turning off V-Sync ingame and turning on Adaptive V-Sync in the nvidia controlpanel
- Forcing off Anti-Aliasing in the nvidia controlpanel

First of all, the V-Sync ingame is a very bad implementation and therefore often limits players to 30 FPS, that's why I turned on Adaptive V-Sync in the nvidia controlpanel instead.

I'm not quite sure why forcing off Anti-Aliasing in the controlpanel makes such a difference, because there was no difference in graphics quality.
But fact is that I can manage a very smooth gameplay in the AC4 Multiplayer on highest settings with those adjustments.

I didn't test this out enough yet to tell for certain whether this is what fixed the FPS-Rate for me, but I thought it would be a good idea to share it with the community since there are many people who same as me, experience a very low FPS-Rate in this game.

My settings:
Resolution: 1920x1080, 60Hz
Vsync: Off
Environment Quality: High
Texture Quality: High
Shadow Quality: Very High
Reflection Quality: High
Character Quality: High
Post-Effects: On
SSAO: On
Volumetric Fog: On

My system:
GTX 570 1GB (Overclocked)
i5 2500k 4x 4.4GHz (Overclocked)
8GB DDR3 RAM
Windows 7 64-Bit

I hope this solution will work for some PC players who experience similar issues to mine.


Greetings!

psychic717
11-23-2013, 07:32 PM
You don't need to force AA off on Nvidia Control Panel. It is true that performance increases a lot with AA off, but you can do that inside graphics options.
They need to fix AA on the game, it seems broken.
Regarding V-Sync, you can use D3DOverrider and keep V-Sync on. With V-Sync from the game and Tripple Buffering from D3DOverrider, the game doesn't drop to 30 fps.

Alcatraz1337
11-23-2013, 10:18 PM
You cant turn it off in the game options because there isn't even an option available for Anti-Aliasing, also why using D3DOverrider if you can just use Nvidia's Adaptive V-Sync along with the Tripplebuffer from the controlpanel?

I also wanted to add to my previous post, that my system still doesnt manage a smooth gameplay as I thought at the beginning (only on a few maps it does), but it performs noticeable better.

Rachit.
11-25-2013, 04:55 PM
Can you please tell me what to do in AMD catalyst control centre ?

MnemonicSyntax
11-25-2013, 04:59 PM
You cant turn it off in the game options because there isn't even an option available for Anti-Aliasing, also why using D3DOverrider if you can just use Nvidia's Adaptive V-Sync along with the Tripplebuffer from the controlpanel?

I also wanted to add to my previous post, that my system still doesnt manage a smooth gameplay as I thought at the beginning (only on a few maps it does), but it performs noticeable better.

Because D3DOverrider handles it better.

Try it. Disable V-Sync in the game and the Nvidia Control Panel, set everything in the Nvidia Control Panel back to default and use D3DOverrider.

Alcatraz1337
11-25-2013, 08:09 PM
I just did and there was no difference, at least not in the multiplayer.
Really no idea what there is left to do, maybe I just have to deal with the fact that my GFX-Card is too old for this unoptimized game.

Edit: Considering that I didn't play the singleplayer yet and that there is no difference for me whether I play the multiplayer with D3D Overrider or not (same FPS-rate in both cases), it seems very likely to me that the multiplayer-part of this game already has tripple-buffering implemented, while the singleplayer-part has not.

Edit 2: Nevermind what I've said before, it seems that activating the tripple-buffer in D3D Overrider fixed my performance issues, thanks!