PDA

View Full Version : Improving Performance/Frame Rates in AC4:Black Flag with mid-high Nvidia cards



drakkar321
11-22-2013, 09:24 AM
I am currently running AC4 with most of the video settings maxed out. The game looks amazing and runs great. I have not had any frame rate issues at all. However, I have seen several posts of people complaining about poor frame rates and laggy game play, that have newer systems than my own, that should not have any trouble running AC4. I just thought I would start a thread to try to help people improve their performance and quality with AC4. This is intended for people that have mid-high end machines, that want both high quality and decent performance.

My specs-
OS: Windows 7 x86_64
CPU: Intel Core I7 2600K @3.4 GHz (4 GHz Turbo)
GPU: Nvidia Gefore GTX 570 (EVGA superclocked) Using Nvidia Driver R331 (331.65)
RAM: 16 GB

My AC4:Black Flag In-Game Settings-

Resolution: 1920x1080 @60Hz
Environment Quality: Very High
Texture Quality: High
Anti-Aliasing: MSAAx2
Shadow Quality: Very High
Reflection Quality: High
Motion Blur: Off
Ambient Occlusion: HBAO+(High)
God Rays: High (running it on Low now, I got tired of changing it with eagle vision and I have noticed a lot of foggy anomalies. I think it looks better on Low because of that. The difference was only about 5 FPS)
Volumetric Fog: On
V-Sync: Off

(I am not saying that all of the in-game settings I use will improve performance. I only provided my system specs and in-game settings for a comparison reference. In fact all of the in-game settings are at max, except for Anti-Aliasing and Motion Blur. I do not like the look of "soft" shadows or motion blur, though both can be GPU hogs. The AA is set at the lowest MSAA setting just to use "Enhance" in the Nvidia Control Panel. V-Sync should be off in-game, to use the Nvidia Control Panel "Adaptive v-sync" setting.)

There are several settings in the Nvidia Control Panel which I have not mentioned, that can effect both quality and performance, but there are a couple of important overrides for the Nvidia Control Panel, which do seem to have a large impact on performance in AC4.

Select "AC4BFSP.exe" (and AC4BFMP.exe if you use Multi-player) under "Manage 3D Settings" in the Nvidia Control Panel

Nvidia Control Panel Overides for ac4bfsp.exe (and ac4bfmp.exe)

Anti-aliasing - Mode: Enhance the application setting (you can also use "Override" if you prefer)
Anti-aliasing setting: (Whatever you want here. I use 4x personally, but anything from 2x to 8x is probably reasonable, depending on your video card.)
Vertical sync: Adaptive

For some reason I have noticed a lot of performance issues with the in-game MSAA in both AC3 and AC4. You can disable Anti-Aliasing altogether (yuck!) or run shader based AA like "FXAA" but for quality, MSAA looks a whole lot better (though I would also be using TXAA in a heartbeat if I had a newer card). Using the setting in the Nvidia Control Panel to "Enhance the application setting" seems to not only improve the performance by quite a bit, but I also think that the quality looks better with it as well. You can also use "Override" if you prefer.

I highly recommend using "Adaptive V-Sync" in your Nvidia "Global settings", and never have to worry about v-sync, in any game, ever again. It really is that simple. I have seen numerous posts about performance problems related to v-sync in AC4, when all of those issues can be resolved by using "Adaptive v-sync". Since Nvidia released the feature, I have used it in every game I have played and have never looked back, or had any problems with it, or v-sync, since. However, you can also use it on a per game basis if you want, for whatever reason. Either way, it is an important setting for AC4.

There are also a couple of tips that I can give, which can have a dramatic impact on performance.

1. One of the most commonly overlooked issues, make sure your physical video card is clean and your cooling is functioning properly. It may seem obvious to many, but a lot of people do overlook this. Obviously your video card heats up while in use. When the thermal limit for the GPU is reached, the driver throttles down the GPU to prevent overheating. If you have poor airflow in your case or have a video card full of dust or with a clogged exhaust vent, this can be an issue. Newer games tend to run fairly hot anyway, so this is something you don't want to overlook.

2. Update your video drivers. You should be running fairly new drivers for AC4. Running AC4 with old drivers will likely have a huge impact on performance. I would recommend updating to the Nvidia R331 drivers (or newer). At the least though, you should probably make sure you are at least running something newer than driver version 320, if you have some specific reason you do not want to install the latest drivers.

3. It's probably also a good idea to defrag your hard drive after you have AC4 installed. It is a fairly large game and uses a lot of dynamic and seamless loading. A badly fragmented hard drive will probably have a lot more laggy or jerky game play. I can't say for certain how much impact this would actually have on the game, but it's a good idea in general to keep your drive defragmented anyway.

Hopefully this will improve someone's gaming experience or at least prevent some of the more common problems for someone. Good luck on the high seas.

EDIT: I had been using Nvidia Driver 331.65. I updated to 331.82 and did some brief testing and actually noticed a small drop in frame rate (5-10 FPS). I have seen some similar feedback from others as well. Driver 332.21 seems to perform fairly well, without significant issue.

EDIT: I have noticed that this thread has been averaging over 1000 views a day since I made the post. I know the information is probably not relevant to everyone who views it but feel free to post feedback, if you found the thread helpful or not. If it has been helping people, I will continue to update it as changes develop, such as driver updates from Nvidia or game patches or other relevant information etc.

abohamed2013
11-22-2013, 09:51 AM
AMD guys ... any ideas ?! :D ... come on UBISOFT this is not fair ... we just want the same FPS on both Nvidia just like AMD .. not necessarily the TXAA thing or PhysX or something but at least the same FPS ... for example :
http://www.hwcompare.com/12053/geforce-gtx-570-vs-radeon-hd-7850/
so these very close cards should have a very close FPS in all games ... and not because Ubisoft work with Nvidia for making AC4 means that the game must run bad for AMD users and run great for Nvidia users !!! bcause that is unfair and mean .. and btw AMD did not do this with ITS games for example : FarCry 3 run great on both Nvidia and AMD cards and crysis 3 as well .. i just hope you get the point ubisoft and help AMD guys on their new driver or gave them the game codes or something

Solid-Snake-Eyes
11-22-2013, 10:15 AM
I have a brand new GTX 770 and have been able to max the settings except for AA and keep an acceptable framerate once I enable triple buffering with D3DOverrider. I put AA to 2xMSAA and get 40-60 fps, if I do 4x it gets as low as 30 so I stick to 2x. I've been able to run TXAA low but it's too damn blurry. I expected better performance than this, but I'll live with it. I find that when a storm starts up it really hurts my frame rate.

The only thing I changed in my drivers was to force 16x anisotropic filtering cause sometimes it produces better quality than the game's filtering.

Secu12
11-22-2013, 11:26 AM
Hello OP and tkank you for your initiative!
I have an intel i5 4440 processor, a GTX 760, 8 GB DDR3 and Windows 7 x64.
I use these graphical settings:

Resolution: 1920x1080
Environment Quality: High
Texture Quality: High
Anti-Aliasing: MSAAx2
Shadow Quality: High
Reflection Quality: High
Motion Blur: On
Ambient Occlusion: HBAO+(Low)
God Rays: Low
Volumetric Fog: On
V-Sync: Off

I get +45 fps but by changing some settings to High (AO and God rays) the framerate doesn't drop more than 5 fps. Which is odd.
I tried TXAAx2 and there are some semnificative framerate drops but no noticeable graphical improvements.
I still didn't find a good combination for 60 fps and high settings.
What is the difference between FXAA, CSAA, MSAA and TXAA and what the order should be?
Do you get 60 fps all the time or what framerate do you get?

sudhirsmani
11-22-2013, 03:08 PM
Thanks for the Antialiasing tip. I was already using Adaptive Vsync with Triple Buffering enabled in the nVidia panel, but the Added Enhance AA settings has improvd everything i think. Smoother gameplay on MSAA 2x in game with these overrides, and everything else set to the highest possible sets.

o_sania
11-22-2013, 03:54 PM
I dont like "Adaptive V-Sync" because it tear frame so i use solution to fix vsync:

THe cause:
So the cause of the fps drop is vsync (if your fps between 30-60) it will reduce it to 30 fps.
Solution
Force triple buffering!!!! To do it use programm D3DOVERRIDER add AS4BFSP.exe and force triple buffering On - You will saw your FPS wont reduce to 30 again)

RayRPG
11-22-2013, 04:45 PM
I have the exact same system Drakkar. Congrats to Ubi for a fantastic PC release. Absolutely amazing quality on my 2 year old system. Who needs a PS4 eh?

Boemundus
11-22-2013, 04:48 PM
Hello, I improved the performance a lot by disabling V-sync in game , running D3Doverrider, enabling triple buffering and forcing v-sync as well in that program.

Also be sure to disable HBAO+ (or setting it to low), if you're running on 1080p consider also lowering AA to minumum (FXAA should do or MSAAx2 should do, you won't see any difference even with AA turned off on 1080p), disable or lower god rays and you should be fine. Everything else can be set to max setting.

I got geforce GTX 760 , AMD phenomn II X4 965. My FPS go from 35-45 in every situation.

I'm a bit CPU bottlenecked, and the game is CPU demanding... So I think my tweaks could do fine for most of the people here.

Sushiglutton
11-22-2013, 04:50 PM
I used Nvidia's new "Geforce Experience" application. Basically it checks your hardware and then suggest optimal settings for various games based on statistics they have collected. For me it worked great and I recomend it to my fellow noobs who don't like to fiddle with these things :)! Obviously only work for Nvidia cards.

MnemonicSyntax
11-22-2013, 04:55 PM
I used Nvidia's new "Geforce Experience" application. Basically it checks your hardware and then suggest optimal settings for various games based on statistics they have collected. For me it worked great and I recomend it to my fellow noobs who don't like to fiddle with these things :)! Obviously only work for Nvidia cards.

I used this too, at first, but I was able to max everything (except Godrays keeps going back to "low", no biggie) and still have no lag whatsoever.

760 GTX, i7 4770K, 8 GB RAM

drakkar321
11-23-2013, 03:22 AM
I have a brand new GTX 770 and have been able to max the settings except for AA and keep an acceptable framerate once I enable triple buffering with D3DOverrider. I put AA to 2xMSAA and get 40-60 fps, if I do 4x it gets as low as 30 so I stick to 2x. I've been able to run TXAA low but it's too damn blurry. I expected better performance than this, but I'll live with it. I find that when a storm starts up it really hurts my frame rate.

The only thing I changed in my drivers was to force 16x anisotropic filtering cause sometimes it produces better quality than the game's filtering.

As I advised in the original post, if you set the in-game anti-aliasing to MSAAx2, then use the enhance setting in the Nvidia Control Panel, you should get better quality and performance anti-aliasing. You also do not need to use triple buffering with adaptive vsync, which you can also set in the Nvidia Control Panel.

drakkar321
11-23-2013, 03:33 AM
Hello OP and tkank you for your initiative!
I have an intel i5 4440 processor, a GTX 760, 8 GB DDR3 and Windows 7 x64.
I use these graphical settings:

Resolution: 1920x1080
Environment Quality: High
Texture Quality: High
Anti-Aliasing: MSAAx2
Shadow Quality: High
Reflection Quality: High
Motion Blur: On
Ambient Occlusion: HBAO+(Low)
God Rays: Low
Volumetric Fog: On
V-Sync: Off

I get +45 fps but by changing some settings to High (AO and God rays) the framerate doesn't drop more than 5 fps. Which is odd.
I tried TXAAx2 and there are some semnificative framerate drops but no noticeable graphical improvements.
I still didn't find a good combination for 60 fps and high settings.
What is the difference between FXAA, CSAA, MSAA and TXAA and what the order should be?
Do you get 60 fps all the time or what framerate do you get?

I am not personally concerned with getting a solid 60 fps all the time. I just give it the eye test. As long as the game play is smooth and fluid then I am happy. I would rather have the highest quality possible, as long as the game play is smooth.

FXAA is a fast, shader based AA method. CSAA and MSAA are traditional AA methods. They are higher quality than FXAA but are a lot more taxing on the GPU. FXAA and MSAA/CSAA can be used at the same time as well. I am not crazy about FXAA because lower quality FXAA can add a foggy look, though the FXAA in AC4 is decent. TXAA is temporal anti-aliasing. It reduces the flickering that you see during movement. If you want more detailed information about AA, you can read a little bit about it here-

http://en.wikipedia.org/wiki/Antialiasing

drakkar321
11-23-2013, 03:39 AM
I dont like "Adaptive V-Sync" because it tear frame so i use solution to fix vsync:

THe cause:
So the cause of the fps drop is vsync (if your fps between 30-60) it will reduce it to 30 fps.
Solution
Force triple buffering!!!! To do it use programm D3DOVERRIDER add AS4BFSP.exe and force triple buffering On - You will saw your FPS wont reduce to 30 again)

There is absolutely no tearing with adaptive v-sync, that is the whole point of using it lol. You also do not need to use triple buffering with it. Adaptive v-sync is basically just a driver controlled automatic v-sync. If the game reaches 60 fps, the driver turns on v-sync automatically. If you drop down below 60 fps, then the driver automatically disables v-sync. So you have absolutely no screen tearing and because v-sync is turned off when you drop below 60 fps, there is no need for triple buffering.

VivaLaSpook
11-23-2013, 04:33 AM
There is absolutely no tearing with adaptive v-sync, that is the whole point of using it lol..

I tried adaptive V-Sync as well and still got tearing. First I tried it just for the ac4bfsp.exe and then tried it under global settings and still got tearing. D3Doverrider is the only thing working for me so far.

drakkar321
11-23-2013, 04:59 AM
I tried adaptive V-Sync as well and still got tearing. First I tried it just for the ac4bfsp.exe and then tried it under global settings and still got tearing. D3Doverrider is the only thing working for me so far.

That is very odd. Sounds like something is not correct. Tearing only occurs when your video card frame rate exceeds the refresh rate of the monitor. Adaptive v-sync also prevents the video card from exceeding 60 fps. You can test to see if adaptive v-sync is functioning properly by turning it on and checking your frame rate, or benchmarking, with an application that you know will normally exceed 60 fps. If it is working correctly, it should not exceed 60 fps, therefore there should also not be any tearing.

However, if D3Doverrider is working for you and you are happy with the results, then go with what works for you.

Loucmachine.Joe
11-23-2013, 07:05 AM
Thank you Drakkar for this thread :o
Thank you Ubisoft for the awesome PC release :cool:

warp2125
11-23-2013, 07:57 AM
OK, so I downloaded D3DOverrider and can report a very good improvement in frame rates and game smoothness.

luciusnetheril
11-23-2013, 02:20 PM
Here's a silly question-how do I set God Rays to High? I have FTW 670 in 2-way SLI with everything at max, except for God Rays, which keeps defaulting to low every time I set it to high :(

psychic717
11-23-2013, 04:17 PM
Here's a silly question-how do I set God Rays to High? I have FTW 670 in 2-way SLI with everything at max, except for God Rays, which keeps defaulting to low every time I set it to high :(

http://forums.ubi.com/showthread.php/810767-*BUG-REPORT*-Eagle-Vision-Turns-God-Rays-to-Low

luciusnetheril
11-23-2013, 06:41 PM
It's not just that. I was setting them to high, and then I'd check the settings right away and those would be back to low, this happened without of me even using Eagle Vision at the very start of the game, like before I've even tried to run it for the first time.

I did solved it by going to my documents, editing the setting and setting the file to read-only.

Doesn't seem to help against Eagle Vision bug, though.

sasha0912
11-24-2013, 10:02 AM
Please help me i have big problem running AC4, i have:

Win 7 Home premium
6 GB RAM
Intel Core i5
NVIDIA GT 520 mx
i have last Directx etc...

i update driver to last Nvidia GeForce 331.82 WHQL

But when i try to launch file AC4BFSP.exe file i have blank screen otherwise if i try to launch same file using graphic card integrated in my pc game run but in poor quality obviously.

Seems as my NVIDIA graphic card cannot run this game i tried a lot of time... please somebody could help me? may be i must set something for play game with my graphic card and not using integrated card that often block game and is very slow

thx

drakkar321
11-24-2013, 04:20 PM
Please help me i have big problem running AC4, i have:

Win 7 Home premium
6 GB RAM
Intel Core i5
NVIDIA GT 520 mx
i have last Directx etc...

i update driver to last Nvidia GeForce 331.82 WHQL

But when i try to launch file AC4BFSP.exe file i have blank screen otherwise if i try to launch same file using graphic card integrated in my pc game run but in poor quality obviously.

Seems as my NVIDIA graphic card cannot run this game i tried a lot of time... please somebody could help me? may be i must set something for play game with my graphic card and not using integrated card that often block game and is very slow

thx

You really should start a different thread/topic for this, you will be far more likely to get help. You can also contact Ubisoft Support. However, I would be surprised if your video card is supported though. You really should consider updating your card to a higher quality card if you want to be able to use it for games, especially newer games.

drakkar321
11-25-2013, 10:21 PM
Thank you Drakkar for this thread :o
Thank you Ubisoft for the awesome PC release :cool:

You are very welcome and I hope that you found the information useful. I also think the PC release is quite good. There are some minor issues that are quite easy to work around. If I am able to help even a few people work around those issues, then I would be very happy. Other than the minor issues mentioned by my first post, the game does seem pretty well polished. I have had very few problems with bugs.

kidalot
11-27-2013, 06:16 AM
I don't get it, I'm using optimal settings according to nvidia control panel but I still get drop from 59/60 to 45 fps which is noticeable and puts me off.

Gtx titan and amd fx 8350 and my CPU is reaching max of 40% , I noticed the only way I can get a constant 60 frames is setting environment textures to vey low or low

drakkar321
11-27-2013, 08:35 AM
I don't get it, I'm using optimal settings according to nvidia control panel but I still get drop from 59/60 to 45 fps which is noticeable and puts me off.

Gtx titan and amd fx 8350 and my CPU is reaching max of 40% , I noticed the only way I can get a constant 60 frames is setting environment textures to vey low or low

Have you read the first post in this thread and followed the suggestions there? Specifically, have you:

Disabled V-Sync in-game and set "Adaptive V-Sync" in the Nvidia Control Panel?
If you use Multi-Sample Anti-Aliasing, Have you set AA to "MSAAx2" in-game and set "Enhance application setting" in the Nvidia Control Panel? Then set your desired AA level in the Nvidia Control Panel?
What driver version are you using? I should have specified in the first post that I was using Nvidia driver version 331.65. I have done some very brief testing with driver 331.82, but I actually noticed a 5-10 FPS drop in performance, so I rolled back to driver version 331.65. I have seen some similar feedback from others as well. Unless you are using SLI, then I would recommend trying driver version 331.65.

kidalot
11-27-2013, 03:25 PM
Have you read the first post in this thread and followed the suggestions there? Specifically, have you:

Disabled V-Sync in-game and set "Adaptive V-Sync" in the Nvidia Control Panel?
If you use Multi-Sample Anti-Aliasing, Have you set AA to "MSAAx2" in-game and set "Enhance application setting" in the Nvidia Control Panel? Then set your desired AA level in the Nvidia Control Panel?
What driver version are you using? I should have specified in the first post that I was using Nvidia driver version 331.65. I have done some very brief testing with driver 331.82, but I actually noticed a 5-10 FPS drop in performance, so I rolled back to driver version 331.65. I have seen some similar feedback from others as well. Unless you are using SLI, then I would recommend trying driver version 331.65.

yes I have tried your suggestions, although like some enabling adaptive v-sync resulted in screen tears so I opted to use d3 override. I have just tried rolling back to 331.65 driver but I get the same results in the same place.
I went back to cape bonavista and in a a lot of places my fps drop from 59/60 to around 45 fps even if standing still. This of course is with environment quality set to normal and above (no difference in fps if normal or very high) nvidia suggests very high. So I turned everything to low or off and tried env quality on all setting, and the fps would still go to 45. When turning everything else on apart from AA and env quality and get 50-60fps.
I noticed my gpu was running very hot at 80 c but I've compensated for that now got it down to 65 c but it hasn't made a difference in performance

So are you able to run this game at 60 fps on a single 570 gtx superclocked card?

drakkar321
11-28-2013, 04:19 AM
yes I have tried your suggestions, although like some enabling adaptive v-sync resulted in screen tears so I opted to use d3 override. I have just tried rolling back to 331.65 driver but I get the same results in the same place.
I went back to cape bonavista and in a a lot of places my fps drop from 59/60 to around 45 fps even if standing still. This of course is with environment quality set to normal and above (no difference in fps if normal or very high) nvidia suggests very high. So I turned everything to low or off and tried env quality on all setting, and the fps would still go to 45. When turning everything else on apart from AA and env quality and get 50-60fps.
I noticed my gpu was running very hot at 80 c but I've compensated for that now got it down to 65 c but it hasn't made a difference in performance

So are you able to run this game at 60 fps on a single 570 gtx superclocked card?

No, I am not getting 60 fps...well, except in the menus lol. My biggest concern is quality and having relatively smooth game play. Honestly, I do not personally notice much difference between 45 fps and 60 fps myself. As long as my frame rates don't drop below 30 fps then I am usually happy. A first person shooter is a little different, but with AC4, it doesn't bother me. I did actually check my frame rates when I did the testing on the two different drivers. On average, it is running around 30-45 fps, depending on the location, though closer to 50 fps in the Abstergo Offices. In heavy vegetation, it is around 30 fps. I have to believe though, that if any single GPU can run the game at 60 fps, it should be a GTX Titan.

I would highly recommend that you use adaptive v-sync for testing or disable v-sync altogether, just to make sure that this is not a v-sync issue. If you would like more information about this (and my concerns), you can get more information here:

http://www.geforce.com/hardware/technology/adaptive-vsync/technology

Can you also list your in-game video settings or take a screenshot of your in-game video settings?

80c sounds really hot, but that is actually within normal operating parameters. The maximum thermal limit, before the driver steps in to down throttle, varies from GPU chip to GPU chip, however for most Nvidia GPUs it is usually around the range of 95c-100c. That's great though that you were able to lower it down to 65c.

Loucmachine.Joe
11-28-2013, 08:10 AM
@Drakker321 Haha I just wanted to thank you for reading my ''sort of'' article, I feel you 100% on what you answered on the other thread. It didnt sound like a rant too much ;)

@kidalot, I use a GTX 780 witch is pretty similar. Our GPU is made to be used @80 c . If your titan act like my 780, the default fan settings will let you go up to high 70s (Celsius) then your fan speed will start go up to maintain 80c.
BUT, I found that @80c, the fan will have a limit too (to not be too noisy) and then, to keep 80c, your gpu clocks will throttle. (its really not as bad as the new radeons from what I heard tho)

So i suggest if you are using evga precision or msi afterburner to put a costum fan mapping that will be a bit more aggressive to be sure it will stay to max clock.
Our cooler is one of the (if not the) best reference cooler of all time and can take more fan speed without being too noisy. If you dont overvolt you should be able to keep it @ 75c max. without earing it much if its in a case. (mine is at ear level and I dont find it noisy... but im deaf xD)

And also, the less heat the more longevity for your hardware, no matter how hot it is ''supposed'' to run at. :)

The thing is that i have no idea of how an AMD cpu perform in this game.... i dont have one to test near :(

kidalot
11-28-2013, 09:03 PM
So I went to a location where the fps suffers, this was in Havana

Settings
http://i44.tinypic.com/dq0rc0.jpg
Result
http://i39.tinypic.com/2agmj4.jpg
On the lowest res
http://i41.tinypic.com/4ucnjc.jpg

Ouch that's not good performance.


These are with V Sync off and nvidia control panel set to default

Loucmachine.Joe
11-28-2013, 10:47 PM
Ouch that's not good performance.


These are with V Sync off and nvidia control panel set to default
Wow... I agree... your gpu dosnt get used and your CPU wouldnt get very high even on 4 cores...

Srsly I would like to have an fx 8350 to test, they really seems to suffer in this game :/

kidalot
11-29-2013, 02:48 AM
Wow... I agree... your gpu dosnt get used and your CPU wouldnt get very high even on 4 cores...

Srsly I would like to have an fx 8350 to test, they really seems to suffer in this game :/

So have others had this issue with fx 8350? I'm getting similar issues with the witcher 2, a chapter of the game I'm only getting 47fps max on the lowest setting nod low resolution.

Seems to be my rig.

Loucmachine.Joe
11-29-2013, 04:35 AM
I ve seen many people complaining with FX 8350... But I dont have one to test and see :(

drakkar321
11-29-2013, 06:02 AM
So have others had this issue with fx 8350? I'm getting similar issues with the witcher 2, a chapter of the game I'm only getting 47fps max on the lowest setting nod low resolution.

Seems to be my rig.

I agree it seems to be something specific to your rig, but the question is why and what? Honestly it looks like possibly a driver issue off hand, but there are a lot of possibilities to the why and what. You can either rule out possibilities one at a time or perhaps contact support, either Ubisoft support or your video card manufacturer or both. Do you get the same results when you increase the settings? You mentioned in an earlier post that you were getting 60 fps with dips down to 45 fps. Is that on all settings and what does your GPU usage look like on other settings? Does your card perform as it should in other games, specifically, a newer game with complexity and are you getting your expected frame rates in that situation?

Nvidia released a new beta driver yesterday. I don't generally use beta drivers myself or recommend them to others because they have enough regression issues in the normal release drivers as it is, but you might give them a try and see what results you get. It is driver version beta 331.93.

EDIT: Looks like the only updates in this driver are a bug fix for GTX 460/560 users and an updated AC4 SLI profile. Looks like Nvidia is working on an AC4 performance driver in the near future though. So I would probably hold off on the beta driver for now but hopefully you won't have to wait too long.

I am assuming that your card is performing as expected in most other games (except witcher 2) but I wanted to be sure. I am also assuming that you have an adequate power supply and both the 8-pin and 6-pin plugs are securely fastened to the card? Sorry, if this stuff seems obvious to you, but I really don't know your technical level. You might also try changing the power mode of the card from adaptive to max performance in the Nvidia Control Panel for ac4bfsp.exe to make sure the card isn't going into a lower power state. I have never personally seen that actually happen but your card is a monster and AC4 hasn't been out very long.

Loucmachine2 is right, the GTX 780 and GTX Titan are similar. I saw a video posted in another thread with Loucmachine2's 780 and the FPS were pretty rock solid at 60 FPS, so I know now it is certainly possible with the card you have. Perhaps Loucmachine2 or anyone else with a GTX Titan (or 780) can provide some suggestions I am overlooking. You might also try posting in the Nvidia forums as well, to reach out to more Titan owners to see if they are experiencing similar issues. Hopefully you will be able to get to the bottom of this, I am very curious about the cause, so please do make sure you post your solution here if you do find it.

Loucmachine.Joe
11-29-2013, 06:40 AM
Looking at the pictures he showed... assuming everything is up to date, from my point of view I cant really come to another conclusion that there is a bottleneck, Hardware or software, in regards to the AMD CPU... many other people with this cpu seems to have the same cpu bottleneck... on a cpu that is supposed to be pretty powerful...

I can invent a theory like : I know FX 8350 get less performances in single thread calculation compared i5 4670k for example, but better in multi threaded calculation. And the game does not ''not support hyperthread'' but does ''not support 8 cores'' ... so in all and all you get alot less performances from your cpu and get bottlenecked? but what happens in consoles then ??
I was not wanting to flame for no HT support because its more a ''feature'', but if this is true, its still a software bottleneck to not be able to use more than 4-5 physical cores..:confused:

But again, i m just throwing **** in the air.. I have no idea because i dont have an FX cpu to make proper tests ..


The only thing i am sure is that if I put everything off, i would NEVER see under 60fps... ever, ever, ever... (except on the rare case where my cpu bottleneck)

Alshan007
11-29-2013, 11:52 AM
Well My Game Lags Too.....Anyone Of U Have An Idea To Fix This : (Even Though I Have A Little Gud PC)

System Specifications :
Processor : Intel Core i7 @ 3.40Ghz
RAM : 8GB DDR3
Windows : Windows 7 Ultimate 64Bit Service Pack 1
HDD : 1TB
Motherboard : H61M-S2P
Graphics Card : Nvidia GT 610 2GB DDR3 (Pixel Shader 5.0)
Total Graphics : 4096 MB (Including Nvidia+Integrated)
Graphics Driver : 331.93 Beta
Screen Resolution : 1366x768

Well I Juz Wanted To Run The Game At Low Settings (Like This)
Screen Resolution : 1280x720
Environment Quality: Off
Texture Quality: Off
Anti-Aliasing: Off
Shadow Quality: Off
Reflection Quality: Off
Motion Blur: Off
Ambient Occlusion: Off
God Rays: Off
Volumetric Fog: Off
V-Sync: Off

Even Though I Run At This Settings...Its Still Lagging...
Any Idea How To Fix This?
Anywayz...Thanks In Advance !!! :)

Loucmachine.Joe
11-29-2013, 01:28 PM
Well My Game Lags Too.....Anyone Of U Have An Idea To Fix This : (Even Though I Have A Little Gud PC)

System Specifications :
Processor : Intel Core i7 @ 3.40Ghz
RAM : 8GB DDR3
Windows : Windows 7 Ultimate 64Bit Service Pack 1
HDD : 1TB
Motherboard : H61M-S2P
Graphics Card : Nvidia GT 610 2GB DDR3 (Pixel Shader 5.0)
Total Graphics : 4096 MB (Including Nvidia+Integrated)
Graphics Driver : 331.93 Beta
Screen Resolution : 1366x768

Well I Juz Wanted To Run The Game At Low Settings (Like This)
Screen Resolution : 1280x720
Environment Quality: Off
Texture Quality: Off
Anti-Aliasing: Off
Shadow Quality: Off
Reflection Quality: Off
Motion Blur: Off
Ambient Occlusion: Off
God Rays: Off
Volumetric Fog: Off
V-Sync: Off

Even Though I Run At This Settings...Its Still Lagging...
Any Idea How To Fix This?
Anywayz...Thanks In Advance !!! :)
Nvidia GT 610 2GB DDR3 is ridiculously low end.
Its not close to minimum requirement ... and even people with higher than recommended find this game to be heavy.

kidalot
11-29-2013, 05:38 PM
I agree it seems to be something specific to your rig, but the question is why and what? Honestly it looks like possibly a driver issue off hand, but there are a lot of possibilities to the why and what. You can either rule out possibilities one at a time or perhaps contact support, either Ubisoft support or your video card manufacturer or both. Do you get the same results when you increase the settings? You mentioned in an earlier post that you were getting 60 fps with dips down to 45 fps. Is that on all settings and what does your GPU usage look like on other settings? Does your card perform as it should in other games, specifically, a newer game with complexity and are you getting your expected frame rates in that situation?

Nvidia released a new beta driver yesterday. I don't generally use beta drivers myself or recommend them to others because they have enough regression issues in the normal release drivers as it is, but you might give them a try and see what results you get. It is driver version beta 331.93.

EDIT: Looks like the only updates in this driver are a bug fix for GTX 460/560 users and an updated AC4 SLI profile. Looks like Nvidia is working on an AC4 performance driver in the near future though. So I would probably hold off on the beta driver for now but hopefully you won't have to wait too long.

I am assuming that your card is performing as expected in most other games (except witcher 2) but I wanted to be sure. I am also assuming that you have an adequate power supply and both the 8-pin and 6-pin plugs are securely fastened to the card? Sorry, if this stuff seems obvious to you, but I really don't know your technical level. You might also try changing the power mode of the card from adaptive to max performance in the Nvidia Control Panel for ac4bfsp.exe to make sure the card isn't going into a lower power state. I have never personally seen that actually happen but your card is a monster and AC4 hasn't been out very long.

Loucmachine2 is right, the GTX 780 and GTX Titan are similar. I saw a video posted in another thread with Loucmachine2's 780 and the FPS were pretty rock solid at 60 FPS, so I know now it is certainly possible with the card you have. Perhaps Loucmachine2 or anyone else with a GTX Titan (or 780) can provide some suggestions I am overlooking. You might also try posting in the Nvidia forums as well, to reach out to more Titan owners to see if they are experiencing similar issues. Hopefully you will be able to get to the bottom of this, I am very curious about the cause, so please do make sure you post your solution here if you do find it.

My brother built this rig, my tech knowledge is very low.
Somone said my CPU is not fast enough for the Titan so I manage to over clock the fx 8350 a little to 4.2ghz, not sure how to get more without having stability issues, my benchmark scores increased slightly after this but the performance was the same.
My first test was the small island by Havana (where you start), the frames would drop to 45fps in areas when env quality was on normal + dropping it to low or very low it would stay closer to 60fps but in Havana no matter what setting I turn off there are spots where the fps will drop in its 40s, At sea I will get a constant 60fps even at the highest settings. I

I guess it would make more sense it 1 of the clocks were running very high, but the none of the cpu cores go above 80% (one of them do reach around 75%) and with the lowest settings the gpu is barely used (Not going over 50%)

Same with the Witcher 2, although that game faired worse, the fps will not over 47 even at the lowest settings. Same thing about the cpu cores, none going over 80%.

I am at a loss.

UmaisNisar
11-29-2013, 07:33 PM
My PC Specs are :

4 GB RAM DDR2
2.5 GHz Processor Dual core
1 GB 3d Card Ati Radeon 4870 HD

So, Can i run this game? And on what fps.

I was able to run every AC game on 40 fps except AC3 which was poorly optimized for PC and was getting 20 fps in it.

drakkar321
11-30-2013, 12:19 AM
My brother built this rig, my tech knowledge is very low.
Somone said my CPU is not fast enough for the Titan so I manage to over clock the fx 8350 a little to 4.2ghz, not sure how to get more without having stability issues, my benchmark scores increased slightly after this but the performance was the same.
My first test was the small island by Havana (where you start), the frames would drop to 45fps in areas when env quality was on normal + dropping it to low or very low it would stay closer to 60fps but in Havana no matter what setting I turn off there are spots where the fps will drop in its 40s, At sea I will get a constant 60fps even at the highest settings. I

I guess it would make more sense it 1 of the clocks were running very high, but the none of the cpu cores go above 80% (one of them do reach around 75%) and with the lowest settings the gpu is barely used (Not going over 50%)

Same with the Witcher 2, although that game faired worse, the fps will not over 47 even at the lowest settings. Same thing about the cpu cores, none going over 80%.

I am at a loss.

It is true that AMD processors do not generally perform as well as their Intel counterparts, but I really don't think the power of the CPU is the issue. It should still be powerful enough to run the Titan. If it is related to specifically having an AMD CPU, I would again think that it is related to drivers. You can check to make sure that you have the latest chipset drivers for your motherboard. I would check your motherboard manufacturer's website first. If you don't find them there then you can probably get them from AMD's website, though it would be better to get them from your motherboard manufacturer's website if you can. You should also be able to check for any bios updates on your motherboard manufacture's website, but I would recommend that you get assistance from your bother, if possible, to update the system bios though, if needed. It is a lot easier to update the system bios now days, but it is still a critical operation which you would not want to have go wrong. Again, this stuff is just to rule things out. I don't specifically think any of these things are the cause, though if they were, they could cause the issues you are experiencing.

What about other games besides AC4 and The Witcher 2? Better yet, you should try running a benchmark. You can use any recent one you want, but I would recommend either 3dmark or Unigine Heaven or both. The Unigine Heaven benchmark is a lot more flexible for the free version, so I do actually prefer it over 3dmark if you don't want to get the paid version, although 3dmark does allow you to compare your results online with similar systems to your own.

Here is a link for Unigine Heaven Try running it on DX11, at your native resolution, and see how your card performs.-
http://unigine.com/products/heaven/download/

Here is 3dmark11-
http://www.futuremark.com/support/downloads


Again, I would also contact support for your video card manufacturer. The GTX Titan is a top end model, so you will likely get 1st class support for it.

drakkar321
11-30-2013, 12:32 AM
Well My Game Lags Too.....Anyone Of U Have An Idea To Fix This : (Even Though I Have A Little Gud PC)

System Specifications :
Processor : Intel Core i7 @ 3.40Ghz
RAM : 8GB DDR3
Windows : Windows 7 Ultimate 64Bit Service Pack 1
HDD : 1TB
Motherboard : H61M-S2P
Graphics Card : Nvidia GT 610 2GB DDR3 (Pixel Shader 5.0)
Total Graphics : 4096 MB (Including Nvidia+Integrated)
Graphics Driver : 331.93 Beta
Screen Resolution : 1366x768

Well I Juz Wanted To Run The Game At Low Settings (Like This)
Screen Resolution : 1280x720
Environment Quality: Off
Texture Quality: Off
Anti-Aliasing: Off
Shadow Quality: Off
Reflection Quality: Off
Motion Blur: Off
Ambient Occlusion: Off
God Rays: Off
Volumetric Fog: Off
V-Sync: Off

Even Though I Run At This Settings...Its Still Lagging...
Any Idea How To Fix This?
Anywayz...Thanks In Advance !!! :)

I would highly recommend updating your video card. Make sure that you get a GTX model if you intend to use it for gaming. Make sure that the last 2 digits of the model number end with a 60 or higher. For example a Nvidia GTX 760 or higher. Though if you are on a tight budget, you might be able to get a 600 series card for a lower price if anyone still has them in stock, but those are from last year and a 700 series would obviously be better. With today being "Black Friday" though you can probably find some really good deals at the moment. I know this is probably not the advice you were wanting to hear, but it is the best advice I can give you. Good Luck

drakkar321
11-30-2013, 12:41 AM
My PC Specs are :

4 GB RAM DDR2
2.5 GHz Processor Dual core
1 GB 3d Card Ati Radeon 4870 HD

So, Can i run this game? And on what fps.

I was able to run every AC game on 40 fps except AC3 which was poorly optimized for PC and was getting 20 fps in it.

AC4 also uses the Anvil Next engine, but has more graphics effects than AC3 did. Your CPU is below the minimum requirements and your video card is the absolute minimum. I suspect that if you tried to run the game, you would experience poor frame rates and stuttering. Here are the minimum requirements for the game, from the Ubisoft website-

In order to run Assassin's Creed 4: Black Flag properly, your PC MUST meet or exceed these minimum requirements:

Minimum System Requirements

Supported OS: Windows Vista SP2 or Windows 7 SP1 or Windows 8 (both 32/64bit versions)
Processor: Intel Core2Quad Q8400 @ 2.6 GHz or AMD Athlon II X4 620 @ 2.6 GHz
Memory: 2 GB (4 GB recommended)
Graphics: Nvidia Geforce GTX 260 or AMD Radeon HD 4870 (512MB VRAM with shader Model 4.0 or higher), DirectX 11
Hard Drive: 30 GB available space
Sound Card: DirectX Compatible Sound Card with latest drivers
Additional Notes: Windows-Compatible keyboard and mouse required, optional controller (Xbox 360 Controller for Windows recommended)
Multiplayer: 256 Kbps or faster broadband connection

Supported video cards at the time of release:
nVidia GeForce GTX260 or better, GT400, GT500, GT600, GT700 series
AMD Radeon HD4870 or better, HD5000, HD6000, HD7000 series

Note: Latest GeForce drivers tested: 320.49 for all series Latest Radeon drivers tested: 13.1 for Radeon HD4000, 13.4 for Radeon HD5000 and above
Optional: nVidia TXAA functionality (part of nVIdia features package) is only available on 6xx series

Laptop versions of these cards may work but are NOT officially supported. These chipsets are the only ones that will run this game.

drakkar321
11-30-2013, 03:57 PM
Looking at the pictures he showed... assuming everything is up to date, from my point of view I cant really come to another conclusion that there is a bottleneck, Hardware or software, in regards to the AMD CPU... many other people with this cpu seems to have the same cpu bottleneck... on a cpu that is supposed to be pretty powerful...

I can invent a theory like : I know FX 8350 get less performances in single thread calculation compared i5 4670k for example, but better in multi threaded calculation. And the game does not ''not support hyperthread'' but does ''not support 8 cores'' ... so in all and all you get alot less performances from your cpu and get bottlenecked? but what happens in consoles then ??
I was not wanting to flame for no HT support because its more a ''feature'', but if this is true, its still a software bottleneck to not be able to use more than 4-5 physical cores..:confused:

But again, i m just throwing **** in the air.. I have no idea because i dont have an FX cpu to make proper tests ..


The only thing i am sure is that if I put everything off, i would NEVER see under 60fps... ever, ever, ever... (except on the rare case where my cpu bottleneck)

BTw, a little off topic, but one of the reasons I haven't updated my video card yet, is that I am holding out, waiting for the Nvidia GTX 800 series (Maxwell) card to come out. I am not sure if you have heard anything about them yet, but they will actually have a 64-bit ARM CPU built on the card, to reduce the reliance on the main CPU. It might not turn out to be as big as I think, but I really do think it will be pretty revolutionary. One thing is for sure, there will be no more CPU bottlenecks any more. Check this out, if you haven't already seen info on it.-

http://en.wikipedia.org/wiki/GeForce_800_Series

drakkar321
12-01-2013, 11:14 PM
@kidalot Any luck trying either of the benchmarks?

louthelou
12-02-2013, 05:58 AM
There is absolutely no tearing with adaptive v-sync, that is the whole point of using it lol. You also do not need to use triple buffering with it. Adaptive v-sync is basically just a driver controlled automatic v-sync. If the game reaches 60 fps, the driver turns on v-sync automatically. If you drop down below 60 fps, then the driver automatically disables v-sync. So you have absolutely no screen tearing and because v-sync is turned off when you drop below 60 fps, there is no need for triple buffering.
While this may be true in principle/theory, it's not the reality. I tried switching to using only the "adaptive v-sync" when they first came out with it, and I found my games exhibited tearing while using it (so I stopped using it). The same goes for this. I came to this thread looking for a way to even out my framerate (getting some FPS drops), so I disabled v-sync in-game, then enabled Adaptive through the NVidia control panel - and I get tearing.

Truth be told, the little tearing I get is better than the FPS drops I was getting, but the fact remains that the tearing happens with adaptive v-sync enabled. In fact, this is evidenced in part of the description for Vertical Sync within NVIDIA Control Panel (though they need to fix the grammar):

"Variable refresh is an advanced version of VSync Adaptive which has low latency does not have any of the frame tearing that is associated with 'adaptive vsync mode'." Again, I know the sentence doesn't quite make sense as it's written, but that's how it's written in there.

For reference:
i5 3570k
GeForce 660 Ti
8GB

kidalot
12-02-2013, 08:47 AM
@kidalot Any luck trying either of the benchmarks?

I ran ungine valley benchmark, got score of 3366, not really looked into the meaning of this yet. Min fps were 18, max above 80 on high settings.

3d mark free version, on firestorm

before overclocking my cpu
graphics 10998, Physics 7665

After overclocking to 4.2 ghz
Graphics 11005, Physics 8107

I tried to compare scores with others but couldn't find anyone with exactly the same set up, in a lot of cases the gpu memory clocks were different to mine.
mine is 1652, ones at the higher end had their CPU over locked much more and their gpu memory clock was around 3,000? Not that I understand that or what the difference should be.

drakkar321
12-03-2013, 10:57 AM
While this may be true in principle/theory, it's not the reality. I tried switching to using only the "adaptive v-sync" when they first came out with it, and I found my games exhibited tearing while using it (so I stopped using it). The same goes for this. I came to this thread looking for a way to even out my framerate (getting some FPS drops), so I disabled v-sync in-game, then enabled Adaptive through the NVidia control panel - and I get tearing.

Truth be told, the little tearing I get is better than the FPS drops I was getting, but the fact remains that the tearing happens with adaptive v-sync enabled. In fact, this is evidenced in part of the description for Vertical Sync within NVIDIA Control Panel (though they need to fix the grammar):

"Variable refresh is an advanced version of VSync Adaptive which has low latency does not have any of the frame tearing that is associated with 'adaptive vsync mode'." Again, I know the sentence doesn't quite make sense as it's written, but that's how it's written in there.

For reference:
i5 3570k
GeForce 660 Ti
8GB

I apologize. I should know better than to make a statement of absolutes. If there is one thing I have learned in my experience over the years, is that there are very few absolutes in computing. It would have been more accurate to say that Nvidia claims there is no screen tearing, I personally have absolutely no tearing, and most people do not have any tearing with adaptive v-sync.

I have done a lot more research on this subject. It does seem like there are a lot of people that are confused about what tearing actually is, but there also seems to be a few people that do actually experience genuine tearing even with adaptive v-sync, though it usually seems to be a reduced amount of tearing from using no v-sync at all. I believe it is most likely related to the particular monitor that is being used though I can't be certain. For example some monitors which claim to be 60 Hz are in fact actually 59 Hz, which could still produce minor tearing if the driver doesn't enable v-sync until hitting 60 fps. That's of course only one example situation and it is likely there are others. I have also seen my frame rate hit 61 or 62 fps very briefly when using adaptive v-sync, that might also cause some minor tearing too. The fact seems to remain that, most people don't experience tearing but there are a small number of people that still do.

There are actually a few options for AC4 though. You could disable v-sync altogether (though obviously probably not a very good option if you are bothered by tearing), use adaptive v-sync, or use D3DOverider to force triple buffering and use standard v-sync. I would not recommend to the masses to use D3DOverrider because that is opening a can of worms to a host of other problems. I do still believe that adaptive v-sync is the best option for most Nvidia users.

drakkar321
12-03-2013, 12:03 PM
I ran ungine valley benchmark, got score of 3366, not really looked into the meaning of this yet. Min fps were 18, max above 80 on high settings.

3d mark free version, on firestorm

before overclocking my cpu
graphics 10998, Physics 7665

After overclocking to 4.2 ghz
Graphics 11005, Physics 8107

I tried to compare scores with others but couldn't find anyone with exactly the same set up, in a lot of cases the gpu memory clocks were different to mine.
mine is 1652, ones at the higher end had their CPU over locked much more and their gpu memory clock was around 3,000? Not that I understand that or what the difference should be.

Sorry, I should have been more specific. Using 3dmark, I thought it would give you a good comparison of what other similar systems were getting but the Unigine Heaven benchmark has a lot of flexibility. I was most interested in if you were getting a sustained frame rate of or over 60 fps to try and determine of your issues are specifically related to AC4 and Witcher 2 only, or if it is a system wide problem. Since you are not getting a solid 60 fps even on the lowest settings, first I would suggest trying to run the Heaven benchmark with the following settings:

Preset: Custom
API: DirectX 11
Quality: Low
Tessellation: Disabled
Stereo3D and Multi-monitor: Disabled
Anti-Aliasing: Off
Check the Full Screen box
Resolution: Your native resolution (1920x1080?)

Even my GTX 570 is able to maintain a rock solid 60 fps with adaptive v-sync on. With v-sync disabled the frame rate is 90-150 fps, It doesn't really drop lower than 90 fps. A GTX Titan should have no problems keeping 60+ fps even on higher settings and should not even break a sweat doing 60 fps with these settings.

I wouldn't be too concerned about the other systems on 3dmark, there are obviously a lot of overclockers there trying to get the highest score possible. It would be nice if you could find a similar system to your own but your scores do not look that far off of the reference Titan system that futuremark has listed. The main thing was to make sure that there wasn't anything abnormal and it doesn't look like there is.

PremiumGhoul
12-03-2013, 02:40 PM
The thread title is a bit misleading, it should really be "Hey, turn off vsync if you want improved performance!" All adaptive vsync does is turn on vsync when the frame rate hits 60, and turns it off when the frame rate falls below that number. When vsync is off you WILL get tearing! Sorry to be so blunt but that is a fact that will remain true until G-Sync comes along (hopefully). What people should really do is use either D3DOverrider or RadeonPro to force triple buffered vsync in this game. Triple buffering will stop vsync from locking the frame rate to 30 or below when it drops from 60.

Since this game isn't very well optimised I'm betting most people aren't hitting 60 very often, so in my opinion the triple buffering would be better.

Or you could do what I do and just lock the game to 30fps and then forget about frame rate all together.

drakkar321
12-03-2013, 07:28 PM
The thread title is a bit misleading, it should really be "Hey, turn off vsync if you want improved performance!" All adaptive vsync does is turn on vsync when the frame rate hits 60, and turns it off when the frame rate falls below that number. When vsync is off you WILL get tearing! Sorry to be so blunt but that is a fact that will remain true until G-Sync comes along (hopefully). What people should really do is use either D3DOverrider or RadeonPro to force triple buffered vsync in this game. Triple buffering will stop vsync from locking the frame rate to 30 or below when it drops from 60.

Since this game isn't very well optimised I'm betting most people aren't hitting 60 very often, so in my opinion the triple buffering would be better.

Or you could do what I do and just lock the game to 30fps and then forget about frame rate all together.

If all you read in the original post was to turn off v-sync, then you did not read it very carefully, though I still do not understand why you would feel mislead. Also, the only thing I said about turning v-sync off was in the in-game settings, though you won't necessarily get tearing just because it is off. Tearing only occurs when the frame rate exceeds the refresh rate of the monitor. D3DOverrider has been mentioned in previous posts by others and myself. I certainly don't consider it the best option for a number of reasons, but it is an option none the less. RadeonPro is intended for Radeon cards, so I really have no idea why you would even suggest that in a thread about Nvidia cards. Either way, triple buffering is unnecessary with adaptive v-sync anyway. The game not being "optimized" is a myth, perpetuated by a single clueless article on a website which I shall not name. Most people that have the hardware to do it, don't have any problems achieving 60 fps, which is why they are concerned about v-sync in the first place.

The real question though, if you are going to lock your frame rate to 30 fps, then why do you even care about v-sync???

PremiumGhoul
12-03-2013, 08:39 PM
If all you read in the original post was to turn off v-sync, then you did not read it very carefully, though I still do not understand why you would feel mislead. Also, the only thing I said about turning v-sync off was in the in-game settings, though you won't necessarily get tearing just because it is off. Tearing only occurs when the frame rate exceeds the refresh rate of the monitor. D3DOverrider has been mentioned in previous posts by others and myself. I certainly don't consider it the best option for a number of reasons, but it is an option none the less. RadeonPro is intended for Radeon cards, so I really have no idea why you would even suggest that in a thread about Nvidia cards. Either way, triple buffering is unnecessary with adaptive v-sync anyway. The game not being "optimized" is a myth, perpetuated by a single clueless article on a website which I shall not name. Most people that have the hardware to do it, don't have any problems achieving 60 fps, which is why they are concerned about v-sync in the first place.

The real question though, if you are going to lock your frame rate to 30 fps, then why do you even care about v-sync???

the misleading part is that the thread title reads like there will be some miraculous fix contained within, but what it really boils down to is just "turn vsync off." Despite what you think, Adaptive vsync will not get rid of screen tearing at frame rates below your refresh rate and because this game runs poorly for some people I don't view it as an ideal solution. Triple buffering would work much better and keep the game tear-free.

RadeonPro may have "radeon" in its title but that doesn't mean it's incompatible with Nvidia cards. A lot of the features (triple buffering, frame rate capping, FXAA/SMAA injection, SweerFX) just use directX hooks and work perfectly on my 670.

Now, as for the "real question," try capping your own frame rate in any game to 30 and then don't use vsync. If you want to avoid tearing you use vsync, it's as simple as that.

drakkar321
12-03-2013, 09:53 PM
Sorry, but you can't blame me for stuff I never said. I can't help your incorrect assumptions. As I stated before, I never said to turn v-sync off, except in the in-game settings. You are right that adaptive v-sync not getting rid of screen tearing at frame rates below the monitor refresh, because there is no tearing to get rid of. You don't really seem to understand tearing, v-sync, adaptive v-sync or triple buffering. I would suggest that you read up on it a bit. This would be a good place to start:

http://www.geforce.com/hardware/technology/adaptive-vsync/technology

Of course you will probably just say Nvidia doesn't know what they are talking about either.

I wasn't assuming that RadeonPro is for Radeon cards because of the name. I would assume that it isn't really intended for Nvidia cards because it says right on the download page, under system requirements that a Radeon HD 2000 card or newer is required. This is copy and pasted from their own download page:

Minimum requirements:

Microsoft Windows Vista SP2
Microsoft .NET Framework 2.0
Microsoft DirectX Runtime June 2010 or newer
ATI Radeon HD 2000 series graphics card or newer

- See more at: http://www.radeonpro.info/download/

Anyway, since you already know everything anyway and you clearly don't want help, I will waste no more time with you. There are plenty of other people in other threads who would love to debate with you, I am just not one of them.

Alshan007
12-03-2013, 10:43 PM
@drakkar321
@loucmachine2

Thx For Replying Guyz ...I was away for 2 dayz...ehh according to minimum requirements Nvidia GT610 Is above minimum requirements...well Nvidia is way too expensive here in Saudi Arabia :( .....I had planned to buy GTX 600 Series but its above 800SR...so i finally bought Nvidia GT 610 according to my budget.....Well Bf4,Cod Ghosts,nfs rivals and all wrked fine without evn a single lag...but donno what bout AC4.....B4 i had Nvidia Geforce 9500GT (its very old one) and i played Assassin Creed 3 in that without lag and many other games.

But...the thing is that nw AC4 is wrking without lag :) i used D3Doverrider and Nvidia Cntrol panel and forced triple buffering and Vsync ON and i selected maximum performance only for AC4...also i made many changes in Nvidia Control panel only For Assassin Creed 4 till ubisoft release a patch or update and also i launch the game using Game Booster 3...
According to me...I wanted to play games in such a way that the game fits the monitor screen (Which means Not below 1280*720 resolution) and not on ultra...only on medium...And AC4 is wrking in this way...And im happy now :D

Once Again...Thx For ur Help And Tips Guyz and nt only u guyz evn others too..... :)
Stay Safe!!! :D

drakkar321
12-03-2013, 11:16 PM
@drakkar321
@loucmachine2

Thx For Replying Guyz ...I was away for 2 dayz...ehh according to minimum requirements Nvidia GT610 Is above minimum requirements...well Nvidia is way too expensive here in Saudi Arabia :( .....I had planned to buy GTX 600 Series but its above 800SR...so i finally bought Nvidia GT 610 according to my budget.....Well Bf4,Cod Ghosts,nfs rivals and all wrked fine without evn a single lag...but donno what bout AC4.....B4 i had Nvidia Geforce 9500GT (its very old one) and i played Assassin Creed 3 in that without lag and many other games.

But...the thing is that nw AC4 is wrking without lag :) i used D3Doverrider and Nvidia Cntrol panel and forced triple buffering and Vsync ON and i selected maximum performance only for AC4...also i made many changes in Nvidia Control panel only For Assassin Creed 4 till ubisoft release a patch or update and also i launch the game using Game Booster 3...
According to me...I wanted to play games in such a way that the game fits the monitor screen (Which means Not below 1280*720 resolution) and not on ultra...only on medium...And AC4 is wrking in this way...And im happy now :D

Once Again...Thx For ur Help And Tips Guyz and nt only u guyz evn others too..... :)
Stay Safe!!! :D

No problem, I am always happy to help. I am very glad to hear that you got AC4 working well.

PremiumGhoul
12-04-2013, 08:23 AM
I will also stop trying to debate with you because it's obvious we will never see eye to eye on this issue.


Adaptive vsync and triple buffered vsync will both solve the frame rate locking issue that people have been having. They just each handle it a bit differently so use either one and you'll probably be happy. If you can handle large amounts of screen tearing then you can also just turn off all vsync and play the game that way.

AJRimmsey
12-05-2013, 03:44 AM
1: thanks for the thread,i always find these threads the ones that do the most for gaming.

2: this isnt a debate..you tell us what you find works,we try it,if it works its great,if it doesnt you still helped

my settings turn out to be identical to yours before i read this,but txaa was something i had doubts about so again thanks for that snippet.

gigabyte gtx 760
ssd drives
fx8350
sabretooth 990fx rev 2.0
16 gb 1600
win 7 ult

kidalot
12-05-2013, 08:30 AM
Sorry, I should have been more specific. Using 3dmark, I thought it would give you a good comparison of what other similar systems were getting but the Unigine Heaven benchmark has a lot of flexibility. I was most interested in if you were getting a sustained frame rate of or over 60 fps to try and determine of your issues are specifically related to AC4 and Witcher 2 only, or if it is a system wide problem. Since you are not getting a solid 60 fps even on the lowest settings, first I would suggest trying to run the Heaven benchmark with the following settings:

Preset: Custom
API: DirectX 11
Quality: Low
Tessellation: Disabled
Stereo3D and Multi-monitor: Disabled
Anti-Aliasing: Off
Check the Full Screen box
Resolution: Your native resolution (1920x1080?)

Even my GTX 570 is able to maintain a rock solid 60 fps with adaptive v-sync on. With v-sync disabled the frame rate is 90-150 fps, It doesn't really drop lower than 90 fps. A GTX Titan should have no problems keeping 60+ fps even on higher settings and should not even break a sweat doing 60 fps with these settings.

I wouldn't be too concerned about the other systems on 3dmark, there are obviously a lot of overclockers there trying to get the highest score possible. It would be nice if you could find a similar system to your own but your scores do not look that far off of the reference Titan system that futuremark has listed. The main thing was to make sure that there wasn't anything abnormal and it doesn't look like there is.

I ran the valley benchmark on the settings as suggested, 1920 x 1080p is my native res. I'm not too sure how to take the results, min fps was 23 and max was 72 with adaptive v sync on in nvidia control panel, the times it dipped under 60 was when it was loading the next section (screen goes black) though I did notice it going down to 50s in the rainy area? Its almost as the card can't handle certain environments. Or again could this be a CPU issue?

drakkar321
12-06-2013, 11:31 AM
I will also stop trying to debate with you because it's obvious we will never see eye to eye on this issue.


Adaptive vsync and triple buffered vsync will both solve the frame rate locking issue that people have been having. They just each handle it a bit differently so use either one and you'll probably be happy. If you can handle large amounts of screen tearing then you can also just turn off all vsync and play the game that way.

Perhaps we haven't seen eye to eye completely, but I wouldn't go as far to say that we will never see eye to eye. I agree with this post 100%. Both methods have pros and cons, but they are both viable solutions.

I also wanted to thank you for the positive tone and helpful nature of your post. One thing that I have noticed, is that there seems to be a lot of griefers on these forums. I am truly only here to help people. I think AC4 is a fantastic game and I would like to see everyone be able to enjoy it. Your other posts seemed very negative and I got the impression that you were only trying to grief. If I misjudged you, then please accept my sincerest apologies, I truly am sorry for that.

drakkar321
12-06-2013, 02:01 PM
I ran the valley benchmark on the settings as suggested, 1920 x 1080p is my native res. I'm not too sure how to take the results, min fps was 23 and max was 72 with adaptive v sync on in nvidia control panel, the times it dipped under 60 was when it was loading the next section (screen goes black) though I did notice it going down to 50s in the rainy area? Its almost as the card can't handle certain environments. Or again could this be a CPU issue?

The Valley benchmark seems to be aimed more at stress testing. The results you mention seem to be normal. Watching the FPS counter in the upper right corner though, your FPS should be mostly stable at 60 FPS. The exception of course is right after the black transition screens. Think of it as your video card taking off from the starting line lol. A couple of the rainy scenes do cause dips on my card as well. As I said though, the Valley test is intended more for heavy loading and stress testing. Though I do like the scenery a lot more with it lol. The Heaven benchmark, your FPS counter should appear to be stable at 60 FPS with those settings and I don't believe that Heaven has any scenes that should drag the card down. Also keep in mind, that when you actually run the benchmark test, the min and max fps will most likely register if you have even 1 sec (most likely less) of 23 fps or 72 fps, so I would be more concerned with the stability of the FPS meter (mostly staying at 60 fps) and whether the scenes look normal and fluid. From what you have said though, it doesn't sound like it's abnormal.

How has AC4 been running for you since the latest patch? Have there been any improvements for you or is it still running the same for you? The patch notes said they fixed some graphical issues, though they did not specify what. I do know the fixed the eagle eye/god ray bug, but I'm not real sure what else has been changed.

Mr_Shade
12-06-2013, 02:05 PM
Indeed - most benchmarking software, such as the Valley or 3d mark, are stress tests, so not always a good gauge of performance in other titles - however if you have much lower than other people with the same hardware, it can highlight potential bottlenecks or issues.

the Witcher 2 normally runs fairly stable on most hardware, so the fact some have issues with that too, could mean an underlying issue,

drakkar321
12-08-2013, 12:33 PM
1: thanks for the thread,i always find these threads the ones that do the most for gaming.

2: this isnt a debate..you tell us what you find works,we try it,if it works its great,if it doesnt you still helped

my settings turn out to be identical to yours before i read this,but txaa was something i had doubts about so again thanks for that snippet.

gigabyte gtx 760
ssd drives
fx8350
sabretooth 990fx rev 2.0
16 gb 1600
win 7 ult

No problem and thank you for the feedback.

kidalot
12-08-2013, 07:47 PM
The Valley benchmark seems to be aimed more at stress testing. The results you mention seem to be normal. Watching the FPS counter in the upper right corner though, your FPS should be mostly stable at 60 FPS. The exception of course is right after the black transition screens. Think of it as your video card taking off from the starting line lol. A couple of the rainy scenes do cause dips on my card as well. As I said though, the Valley test is intended more for heavy loading and stress testing. Though I do like the scenery a lot more with it lol. The Heaven benchmark, your FPS counter should appear to be stable at 60 FPS with those settings and I don't believe that Heaven has any scenes that should drag the card down. Also keep in mind, that when you actually run the benchmark test, the min and max fps will most likely register if you have even 1 sec (most likely less) of 23 fps or 72 fps, so I would be more concerned with the stability of the FPS meter (mostly staying at 60 fps) and whether the scenes look normal and fluid. From what you have said though, it doesn't sound like it's abnormal.

How has AC4 been running for you since the latest patch? Have there been any improvements for you or is it still running the same for you? The patch notes said they fixed some graphical issues, though they did not specify what. I do know the fixed the eagle eye/god ray bug, but I'm not real sure what else has been changed.

I ran the heaven benchmark on the settings you siuggested. Result min frames 8.7 and max 67.7, average 59.0 on adaptive v sysync for the most part it ran at contact 60fps, the only dips once again was between sections (some not all)

i was excited to hear about the ac4 patch but sadly this didn't effect the performance on the game. Crowded areas with the lowest settings will still dip in the 40s on the lowest possible settings. It's getting me down especially reading some users claiming to be running the witcher 2 a 60fps on ultra settings (with out über sampling) on a gtx660 sc or other single cards.

machjava
12-08-2013, 11:57 PM
I'm running 2 GTX 670 4gb SC's in SLI, an i5 3570k @4.2ghz, and 16gb RAM @ 1600mhz.

Latest 331.93 Beta drivers, everything pushed as far as it can go in the settings, with adaptive vsync (which I love, by the way) and I still dip below 60 while running through the first city.

Seems pretty un-optimized to me. And don't forget about when it starts raining, I just turn off the game, it's that unplayable.

drakkar321
12-10-2013, 04:27 AM
I ran the heaven benchmark on the settings you siuggested. Result min frames 8.7 and max 67.7, average 59.0 on adaptive v sysync for the most part it ran at contact 60fps, the only dips once again was between sections (some not all)

i was excited to hear about the ac4 patch but sadly this didn't effect the performance on the game. Crowded areas with the lowest settings will still dip in the 40s on the lowest possible settings. It's getting me down especially reading some users claiming to be running the witcher 2 a 60fps on ultra settings (with out über sampling) on a gtx660 sc or other single cards.

Have you checked to make sure that your system bios and AMD chipset drivers are all up to date? There seems to be a bottleneck somewhere on your system, but I am having a tough time being able to point to the exact cause. Then again, I am working blindfolded with both hands tied behind my back as well lol.

You might also check your system bios settings and be sure your settings are correct, where it pertains to your video card especially. For example be sure you don't have video bios caching on or VGA palette snooping or vram caching. There should be guides available which should give you more detailed information on your particular bios, but the settings I mentioned can have a negative impact on performance as well.

I know you have had some concerns about your CPU not being powerful enough, but I do think it should be powerful enough to handle a single Titan. It might be a different issue if you were running 3 way SLI, but a single card shouldn't be too much. However, the data transfers back and forth over the system bus, therefore it is a really good idea to make sure that you are running the latest AMD chipset drivers. You should be able to get them from your motherboard website or even directly from AMD if you wanted to, though I would recommend getting them from your motherboard manufacturers site to be sure that you download the correct version for your system.

I still also highly recommend that you contact support from your video card manufacturer. The GTX Titan is a high end model, so they should give you top notch support. They would also probably be aware if others, with a similar setup to your own, have also had similar issues.

drakkar321
12-10-2013, 04:41 AM
I'm running 2 GTX 670 4gb SC's in SLI, an i5 3570k @4.2ghz, and 16gb RAM @ 1600mhz.

Latest 331.93 Beta drivers, everything pushed as far as it can go in the settings, with adaptive vsync (which I love, by the way) and I still dip below 60 while running through the first city.

Seems pretty un-optimized to me. And don't forget about when it starts raining, I just turn off the game, it's that unplayable.

I am guessing that since you are using adaptive v-sync, that you do have v-sync disabled in game right? Also, did you follow the suggestions in post #1 about anti-aliasing? Specifically, make sure that if you are using MSAA (or TXAA) that you only set it to MSAA x2 in game, and then enhance the application settings in the Nvidia control panel. Anything higher than MSAA x2 in game seems to really hurt performance. The MSAA in game is very taxing on the system for some reason. The anti-aliasing through the Nvidia driver is more efficient and less demanding to run.

machjava
12-10-2013, 07:30 PM
I am guessing that since you are using adaptive v-sync, that you do have v-sync disabled in game right? Also, did you follow the suggestions in post #1 about anti-aliasing? Specifically, make sure that if you are using MSAA (or TXAA) that you only set it to MSAA x2 in game, and then enhance the application settings in the Nvidia control panel. Anything higher than MSAA x2 in game seems to really hurt performance. The MSAA in game is very taxing on the system for some reason. The anti-aliasing through the Nvidia driver is more efficient and less demanding to run.

Yes, adaptive on, off in-game. I've been using SMAA, even without any anti-aliasing, still getting sub-par performance on my system. And this is all after a recent clean install and wipe of my computer to move to Windows 8.1. So there should be little to no conflicts driver/software side causing this. Maybe I'm expecting too much, with BF4 pushed to max on every setting, and getting well above 100+ FPS (most of the time, 64 player kills any CPU), I'd expect more in this game. I don't mean that as far as a direct comparison, two different engines/games, but more as a side by side with what I'm playing right now.

Oh well :(

ProtestMayFire
12-10-2013, 09:19 PM
If you Ctrl-Alt-Del during the game, open the task manager, click on the processes tab, and end the Uplay launcher(Uplay.exe) It frees up a substantial amount of processing power. I noticed that this allows me to use a much higher AA and turn the shadows and god rays up to very high and high! Give it a shot!

Nofearxxx25
12-11-2013, 07:04 AM
hey i guys i need help here cause when i update the patch both my single player and multiplayer goes to blackscreen but before installing the patch the game worked fine
my pc specs
i5 processor 3330 3.0ghz
8gb ram coasir vengance
gpu- nvidia geforce gtx 650
windows 7 64bit

please help me

drakkar321
12-11-2013, 03:51 PM
Yes, adaptive on, off in-game. I've been using SMAA, even without any anti-aliasing, still getting sub-par performance on my system. And this is all after a recent clean install and wipe of my computer to move to Windows 8.1. So there should be little to no conflicts driver/software side causing this. Maybe I'm expecting too much, with BF4 pushed to max on every setting, and getting well above 100+ FPS (most of the time, 64 player kills any CPU), I'd expect more in this game. I don't mean that as far as a direct comparison, two different engines/games, but more as a side by side with what I'm playing right now.

Oh well :(

I don't really think your expectations are too high. I would suggest that you try adjusting the graphic settings one at a time and testing to see if you are able to improve your performance. It may just be an issue of finding a balance between quality and performance that you are happy with.

It also may be a matter of waiting for Nvidia to fine tune the SLI profile or driver. I know that the past couple of drivers they have made changes to the SLI profile for AC4, which tells me that they are probably still fine tuning it. They have also still not yet released any driver performance enhancements for AC4 either, even though the description of driver 331.82 sounds like they may have, they have not. I believe that they are working on it, or at least planning to release at performance enhancement driver at some point in the near future.

drakkar321
12-11-2013, 03:55 PM
hey i guys i need help here cause when i update the patch both my single player and multiplayer goes to blackscreen but before installing the patch the game worked fine
my pc specs
i5 processor 3330 3.0ghz
8gb ram coasir vengance
gpu- nvidia geforce gtx 650
windows 7 64bit

please help me

You really should open a new thread for this issue, since it is unrelated to the topic in this thread. However, I would suggest that you verify the installation with UPlay. If that doesn't work, I did actually read an interesting thread from someone else that had a very similar issue, that you might want to take a look at,

http://forums.ubi.com/showthread.php/815483-One-possible-AC4-Black-Screen-fix

If you are still having problems, you can start a new thread topic, or find another thread about this issue, or you can contact Ubisoft Support and file a support ticket.

DoraXploresMe
12-11-2013, 05:20 PM
PC SPECS:

GPU: GeForce GTX650 2GB DDR5
CPU: Intel(R) Core (TM) I5-3450 cpu @ 3.10GHz
Memory: 6GB

Nvidia vers: 331.93


Hello guys.. I believe my problem seems to be different. My game runs fine without AA and AO... BUT!!! Environment settings from normal to super high drops to 17fps if i'm in the jungle (close to many trees and plants).

Anybody else with the same problem??? If i set the environment to low, all the plants r gone and i have rly good fps... but playing it with low environment kinda sucks.. i wanted to set it to normal :(

As for the MP.. i can play it all max'd, 60 fps o___o (SP, Y U DO DIS TO ME!!)

drakkar321
12-11-2013, 07:04 PM
PC SPECS:

GPU: GeForce GTX650 2GB DDR5
CPU: Intel(R) Core (TM) I5-3450 cpu @ 3.10GHz
Memory: 6GB

Nvidia vers: 331.93


Hello guys.. I believe my problem seems to be different. My game runs fine without AA and AO... BUT!!! Environment settings from normal to super high drops to 17fps if i'm in the jungle (close to many trees and plants).

Anybody else with the same problem??? If i set the environment to low, all the plants r gone and i have rly good fps... but playing it with low environment kinda sucks.. i wanted to set it to normal :(

As for the MP.. i can play it all max'd, 60 fps o___o (SP, Y U DO DIS TO ME!!)

I would guess that it is probably your GPU. Nvidia video cards intended for serious gaming are the GTX cards that end with a 60 and up, for example a GTX 660 or GTX 760. I am sure that you can play the game, but you should not be surprised if you have trouble on higher settings. I would highly recommend that you upgrade your video card if you want to run games at a higher quality, especially newer games. The vegetation in AC4 for example is very GPU heavy.

Now, with that being said, it may still be possible to improve your performance by lower several other settings, and still be able to run the environment at normal. I can't make any promises of course, but you could try a few things. Try lowering shadow quality, specifically make sure that you are not using soft shadows. Try disabling motion blur. Basically, try lowering any of your settings and see what effect it has on performance.

I was curious how the GT 650 compared to the GTX 260, because the 260 is listed as minimum specs for AC4. So I actually found a GPU comparison of the two. I think it is probably more complicated than this page shows, but it should give you an idea about how the two cards would compare and the difference it makes in the last 2 digits of the model number. The GTX 260 was actually refined shortly after it was first released and the GTX 650 also has 3 different models. I gave a link comparing both originals and both of the upgraded models. (You didn't mention if you had the TI model or not, but I am guessing that you do)

http://www.hwcompare.com/13547/geforce-gtx-260-vs-geforce-gtx-650/

http://www.hwcompare.com/13876/geforce-gtx-260-core-216-vs-geforce-gtx-650-ti-2gb/

kidalot
12-13-2013, 06:44 PM
I would guess that it is probably your GPU. Nvidia video cards intended for serious gaming are the GTX cards that end with a 60 and up, for example a GTX 660 or GTX 760. I am sure that you can play the game, but you should not be surprised if you have trouble on higher settings. I would highly recommend that you upgrade your video card if you want to run games at a higher quality, especially newer games. The vegetation in AC4 for example is very GPU heavy.


Now, with that being said, it may still be possible to improve your performance by lower several other settings, and still be able to run the environment at normal. I can't make any promises of course, but you could try a few things. Try lowering shadow quality, specifically make sure that you are not using soft shadows. Try disabling motion blur. Basically, try lowering any of your settings and see what effect it has on performance.


I was curious how the GT 650 compared to the GTX 260, because the 260 is listed as minimum specs for AC4. So I actually found a GPU comparison of the two. I think it is probably more complicated than this page shows, but it should give you an idea about how the two cards would compare and the difference it makes in the last 2 digits of the model number. The GTX 260 was actually refined shortly after it was first released and the GTX 650 also has 3 different models. I gave a link comparing both originals and both of the upgraded models. (You didn't mention if you had the TI model or not, but I am guessing that you do)


http://www.hwcompare.com/13547/geforce-gtx-260-vs-geforce-gtx-650/


http://www.hwcompare.com/13876/geforce-gtx-260-core-216-vs-geforce-gtx-650-ti-2gb/




This kind of happens to me on my titan card, same sort of effect with fps dropping in jungle areas with environment quality set to normal or higher, it drops from 60 to the 40s. Although I have issues in populated areas too even on the lowest settings.


I have sent a e-mail to zotac my graphics vendor, gave them the details of my issue. Sent a txt file showing gpu stats whilst running the game and sent my results from heaven benchmark (this is what they requested) and no one has got back to me in a week.


I've had a look at bios update, thereI are two available not sure if either look like they could help. My bios version is 1.60 http://www.asrock.com/mb/download.asp?o=BIOS&Model=970%20Extreme3 I'm still looking my bios settings to see if there is anything there I can do. Not sure where I can look for amd chipset for my CPU?

Wrath2Zero
12-13-2013, 11:09 PM
Getting 30-40fps(higher at sea) with the following:

Resolution: 1920x1080
Anti-Aliasing Quality: SMAA
Environment Quality: Low
Texture Quality: High
Shadow Quality: Very High
Reflection Quality Normal
Ambient Occlusion: HBAO+(Low)
God Rays: Low
Volumetric Fog: On
V-Sync: Off



GTX 560Ti 2GB, Intel Q8400@3.2GHz, 6GB RAM, V-Sync on in NCP with D3doverrider(Triple Buffer), frame-rate locked at 58fps with MSI Afterbuner for better mouse input responsiveness. Although having environment setting at low removes the advanced foliage, you can make up for it by enabling other higher setting and the game still looks very nice and has superb fidelity. The rain hurts the FPS really bad though, losing 10fps when it rains alone.

drakkar321
12-17-2013, 08:42 PM
This kind of happens to me on my titan card, same sort of effect with fps dropping in jungle areas with environment quality set to normal or higher, it drops from 60 to the 40s. Although I have issues in populated areas too even on the lowest settings.


I have sent a e-mail to zotac my graphics vendor, gave them the details of my issue. Sent a txt file showing gpu stats whilst running the game and sent my results from heaven benchmark (this is what they requested) and no one has got back to me in a week.


I've had a look at bios update, thereI are two available not sure if either look like they could help. My bios version is 1.60 http://www.asrock.com/mb/download.asp?o=BIOS&Model=970%20Extreme3 I'm still looking my bios settings to see if there is anything there I can do. Not sure where I can look for amd chipset for my CPU?

If you have still not heard back from Zotac, you should just contact them again. You could probably call them as well, especially if they gave you a ticket number.

If it were my system, I would personally update the bios to version 1.80. If you have a USB stick, then the best method to update it would be the "instant" method directly in the bios. Make sure that you read the full instructions on that page that you linked. There is a shortcut for directions for each method on there and it is very important that you read the directions very carefully. There are other updates on that same site as well, depending on what OS you are running. The chipset driver specifically is the AMD all in 1 driver, though it would probably be a good idea to update all of the software on there that have newer versions. Just be sure to read the update instructions carefully. You might want to look around for a guide for your particular bios that gives good explanations of the settings, before you actually update. Most of the time, after a bios update, the settings are retained, but they can all be reset to the defaults. Sometimes the default settings are good but other times I have to wonder what bios makers are thinking with some of the settings they choose as defaults. It really just depends on your particular system, so it really helps to have an understanding of the settings. Though if you don't understand a particular setting, it's of course better to leave it at default until you can find more information about it.

Beargen21
01-03-2014, 07:33 PM
Hello. I am having problems playing this game. I get a maximum of like 13 FPS anywhere in the game. I would LOVE to actually play this game. Would someone please try and help me out a little bit?

PC Specs are as follows:
GPU: GeForce GTX 670
CPU: AMD FX(tm)-8350 Eight-Core Processor
Memory: 16.00 GB RAM (15.90 usable)
Driver version: 331.93
OS: Windows 8.1x64

I have tried playing on even the LOWEST settings and my fps does not change. Any help would be much appreciated.

drakkar321
01-04-2014, 06:23 AM
Hello. I am having problems playing this game. I get a maximum of like 13 FPS anywhere in the game. I would LOVE to actually play this game. Would someone please try and help me out a little bit?

PC Specs are as follows:
GPU: GeForce GTX 670
CPU: AMD FX(tm)-8350 Eight-Core Processor
Memory: 16.00 GB RAM (15.90 usable)
Driver version: 331.93
OS: Windows 8.1x64

I have tried playing on even the LOWEST settings and my fps does not change. Any help would be much appreciated.

I will certainly try to help you out. I obviously can't make you any promises, but I will do my best to help you get going. Have you read post #1 and tried following all of the applicable suggestions there already? Also, the Nvidia driver 331.93 is a beta driver. While I have not heard about any specific problems with that driver version and AC4, it might still be a good idea to try a release driver, like 331.65 or 331.82 just to be sure it isn't a problem with the beta driver.

I don't know if you have read any of the previous posts from kidalot, but I can't help but notice that you seem to have the same CPU model. I hope it is just a coincidence.

LightStrider01
01-16-2014, 01:13 AM
So ya i have a gtx 780 ti sc edtion, and i just got this game, i am trying to play it beautifully. i also have a nice 120hz monitor. it definatly made things work better with v-sync off in the game and adaptive set in the nvidia control panel. Now i am playing with settings, i find that
Resolution: 1920x1080 @60Hz
Environment Quality: Very High
Texture Quality: High
Anti-Aliasing: Txaa x2
Shadow Quality: Normal (Because shadows are tricky, i might try soft shadows high if anyone can reccomend)
Reflection Quality: Normal, why would i care about reflections?
Motion Blur: Off, of course its silly
Ambient Occlusion: HBAO+(Low), Again im not a guy for shadowing and stuff...i dunno
God Rays: Low
Volumetric Fog: On
V-Sync: Off
Advanced phyx- Off....if i turn them on i instantly lose 10 frames...ish...depending on the scene. some i can play 60 but i want the game to run at a constant 60...any tips guys? with advice on what the difference in visuals is?

Calrid
01-16-2014, 03:40 AM
Well I said this on another thread and I don't think anyone believed me, I have everything maxed out on GT560ti card, although the i means it is overclocked so although only a 1 meg card it apparently runs much faster and competes with some of the heavier cards of its time.

I have no idea how to check my frame rate or anything but it never slows down no matter what the action, smoke, lots of jungle whatever.

Additional specs:

OS Name Microsoft Windows 7 Home Premium

System Type x64-based PC
Processor Intel(R) Core(TM) i7-2700K CPU @ 3.50GHz, 3801 Mhz, 4 Core(s), 8 Logical Processor(s)

Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 16.0 GB
Available Physical Memory 11.9 GB

I think many people might be playing on lap tops, which means your configuration will not match any desk top even if it is some amazing spec. Don't play high end games on a lap top if you can afford a desktop of decent spec use that. Laptops are shat for high end games, always have been always will be.

That said if you are on a desktop, with comparable configuration and a better graphics card than mine (which let's face it isn't hard) who knows. All I know is it's "maxed" as much as it can be, it never lags no matter what. I don't know how to check my frame rate, but it isn't slowing down so why should I care. :)

drakkar321
01-16-2014, 05:45 AM
So ya i have a gtx 780 ti sc edtion, and i just got this game, i am trying to play it beautifully. i also have a nice 120hz monitor. it definatly made things work better with v-sync off in the game and adaptive set in the nvidia control panel. Now i am playing with settings, i find that
Resolution: 1920x1080 @60Hz
Environment Quality: Very High
Texture Quality: High
Anti-Aliasing: Txaa x2
Shadow Quality: Normal (Because shadows are tricky, i might try soft shadows high if anyone can reccomend)
Reflection Quality: Normal, why would i care about reflections?
Motion Blur: Off, of course its silly
Ambient Occlusion: HBAO+(Low), Again im not a guy for shadowing and stuff...i dunno
God Rays: Low
Volumetric Fog: On
V-Sync: Off
Advanced phyx- Off....if i turn them on i instantly lose 10 frames...ish...depending on the scene. some i can play 60 but i want the game to run at a constant 60...any tips guys? with advice on what the difference in visuals is?

I would recommend that you do not use any in-game AA setting higher than MSAAx2. You should be able to enable TXAA in the Nvidia Control Panel using "Enhance Application Setting" . I also wouldn't bother with soft shadows unless you prefer the way that they look. Personally I do not like them, they look less realistic. Go outside on a sunny day and look at shadows, they are usually well defined. The only time shadows look blurry is when they are cast from really high up. More importantly, you are adding extra blur passes to the already GPU heavy shadowing. You shouldn't have much trouble running them on high or very high though if you wanted to.

The PhysX effects only create thicker darker smoke. Which again, I think looks a lot less realistic. I have owned and fired a real black powder pistol. With PhysX disabled, the smoke looks quite real. But with PhysX on, it makes so much smoke that it is just silly, and it is hard to even see what is going on in the game. It also turns the smoke a darker gray color, which also looks less realistic. Anyway, it really comes down to preference, but PhysX only affects the smoke effects, like firearms, cannons, chimney smoke and smoke grenades.

All of your other settings should be fine for running at 60 fps. In fact with a GTX 780 Ti you should be able to get 60 fps even with Shadows and Reflections at very high and Ambient Occlusion at HBAO+ high. What kind of frame rates are you currently getting?

Calrid
01-16-2014, 11:27 AM
More importantly have you stood on the deck of 54 gun Brigantine and fired a broadside under heavy fire yourself, because I can tell you the smoke from just one cannon is quite extensive, 27 in battle conditions and several mortars, would I think produce that much smoke if not more, unfortunately though I don't have an 18th century Brig bristling with cannon. ;)

You probably have a point about firearms though, unless it's a brigade I can't see there being as much smoke as that, although frankly its as you say cosmetic and really doesn't affect gameplay, you should if you are any good be able to ignore smoke whilst using mortars and even to some extent cannons, using the force to locate the ship. ;)

ROFLBOT
01-20-2014, 10:10 AM
I used Nvidia's new "Geforce Experience" application. Basically it checks your hardware and then suggest optimal settings for various games based on statistics they have collected. For me it worked great and I recomend it to my fellow noobs who don't like to fiddle with these things :)! Obviously only work for Nvidia cards.
Holy balls, I completely forgot about that! I also used the recommended settings from the NVIDIA's guide for their GTX video cards. I'm so going to try that out when I'm back home. The performance for this game is really quite low, even though I'm running it on an NVIDIA video card. Clearly Ubisoft has -no- love for PC gamers even though PC gaming is the future and it is the present. I'm also using the currently newest drivers, I sure hope I can improve the performance, because I'm not happy at all.
Here are my PC specs, any recommendations would be great and yes I do fear there is a case of bottleneck here, but I can't seem to OC my processor any more higher.

Gigabyte GA-MA790XT-UD4P
AMD Phenom II x4 965 Black Edition 3.4GHz w/ Cooler Master V8
AMD Entertainment Edition 8GB DDR3
MSI GTX 760 2GB Twin Frozr 4 Lite Edition
Windows 7 Ultimate 64bit SP1
Thermaltake V3 Black Edition w/ 2 Cooler Master BC 120MM Blue LED fans, in-take and exhaust.

playlisting
02-01-2014, 02:48 PM
Thanks for the tips!

Wrath2Zero
02-01-2014, 07:13 PM
Use MSAA, it keeps your GPU initialisation above 80%, with SMAA is stays around 60%-70%, which is bad.

drakkar321
02-03-2014, 12:48 PM
Holy balls, I completely forgot about that! I also used the recommended settings from the NVIDIA's guide for their GTX video cards. I'm so going to try that out when I'm back home. The performance for this game is really quite low, even though I'm running it on an NVIDIA video card. Clearly Ubisoft has -no- love for PC gamers even though PC gaming is the future and it is the present. I'm also using the currently newest drivers, I sure hope I can improve the performance, because I'm not happy at all.
Here are my PC specs, any recommendations would be great and yes I do fear there is a case of bottleneck here, but I can't seem to OC my processor any more higher.

Gigabyte GA-MA790XT-UD4P
AMD Phenom II x4 965 Black Edition 3.4GHz w/ Cooler Master V8
AMD Entertainment Edition 8GB DDR3
MSI GTX 760 2GB Twin Frozr 4 Lite Edition
Windows 7 Ultimate 64bit SP1
Thermaltake V3 Black Edition w/ 2 Cooler Master BC 120MM Blue LED fans, in-take and exhaust.

You can use Geforce Experience, however it is focused more on performance than quality and I don't personally care for the choices Nvidia made for the profiles for AC4. They do have the slider now at least, which helps a bit, but the profiles for AC4 could still use a bit more work. It is an option though, especially if you do not feel comfortable with changing the video settings yourself and you are happy with the results.

drakkar321
02-03-2014, 12:58 PM
Use MSAA, it keeps your GPU initialisation above 80%, with SMAA is stays around 60%-70%, which is bad.

There is nothing bad about it. MSAA is a traditional AA method and is much higher quality but it is also much more GPU intensive than SMAA. SMAA is a post process, shader based AA method, similar to FXAA.

Wrath2Zero
02-04-2014, 01:38 AM
There is nothing bad about it. MSAA is a traditional AA method and is much higher quality but it is also much more GPU intensive than SMAA. SMAA is a post process, shader based AA method, similar to FXAA.

I know that but I didn't say SMAA is bad, if you read correctly I said the GPU initialisation is bad, using a higher AA settings makes the GPU initialise more making a more stable frame-rate and makes up a bit for the bad CPU threading performance. You can do with with SGSSAA.

drakkar321
02-04-2014, 08:57 AM
I know that but I didn't say SMAA is bad, if you read correctly I said the GPU initialisation is bad, using a higher AA settings makes the GPU initialise more making a more stable frame-rate and makes up a bit for the bad CPU threading performance. You can do with with SGSSAA.

I actually did read it correctly and I didn't say you said anything at all. I said. "There is nothing bad about it". I was only explaining why you should be seeing a higher GPU usage with MSAA than with SMAA. As far as the rest goes, it is complete nonsense.

abyssofdreams
02-04-2014, 01:02 PM
Hello everbody.

I would like to post my findings with regard to screen tearing and v-sync.
I've spent some time testing with various settings I found across the net including the ones I found in this thread.
It was my experience that even though various methods help reduce screen tearing, none eliminate it completely.
The only setting that removes screen tearing for me entirely is enabling v-sync in-game. Sure, the fps locks at 30 once it drops from 60 to 59 but there you go.

I tried RadeonPro, D3DOverrider and Nvidia Control Panel with various settings (yes, also tried out adaptive v-sync), all helped reduce the tearing, sure enough... but it's still there for me and very noticable, especially when panning quickly on islands or approading huge buildings.

I'll probably upload some screenshots and/or a video comparison later.

I'm running a factory overclocked ASUS GTX 770 plus AMD Phenom 1090T as my CPU.

ETA:
********************************

Okay, after some more research I found a solution to eliminate screen tearing completely.
Overclock your monitor! I didn't even know that is possible.
I overclocked my 60Hz only slightly to 65Hz to go just above the ACBF cap @63fps.
And voila, screen tearing is gone! Am still running D3DOverrider but will test if it works without. As it seems the remaining tearing only happened when it went above 60frames, so there you go.

Anyone with a strong enough machine and a 60Hz monitor should try this.

Here's a video on how to do it safely:
http://www.youtube.com/watch?v=8sXeSwe1_dU

Hope it helps anyone.

********************************

Wrath2Zero
02-04-2014, 06:02 PM
I actually did read it correctly and I didn't say you said anything at all. I said. "There is nothing bad about it". I was only explaining why you should be seeing a higher GPU usage with MSAA than with SMAA. As far as the rest goes, it is complete nonsense.

I can backup what I said and so can someone else on the NVIDIA forums.


I can confirm this. This did the trick for Revelations for me. That game ran mostly in 35-45 with everything maxed out in 1080p on my rig. I applied 4xSGSAA and the game started running at 45-60 because the GPU started doing more work.

Wrath2Zero
02-04-2014, 06:07 PM
Hello everbody.

I would like to post my findings with regard to screen tearing and v-sync.
I've spent some time testing with various settings I found across the net including the ones I found in this thread.
It was my experience that even though various methods help reduce screen tearing, none eliminate it completely.
The only setting that removes screen tearing for me entirely is enabling v-sync in-game. Sure, the fps locks at 30 once it drops from 60 to 59 but there you go.

I tried RadeonPro, D3DOverrider and Nvidia Control Panel with various settings (yes, also tried out adaptive v-sync), all helped reduce the tearing, sure enough... but it's still there for me and very noticable, especially when panning quickly on islands or approading huge buildings.

I'll probably upload some screenshots and/or a video comparison later.

I'm running a factory overclocked ASUS GTX 770 plus AMD Phenom 1090T as my CPU.

ETA:
********************************

Okay, after some more research I found a solution to eliminate screen tearing completely.
Overclock your monitor! I didn't even know that is possible.
I overclocked my 60Hz only slightly to 65Hz to go just above the ACBF cap @63fps.
And voila, screen tearing is gone! Am still running D3DOverrider but will test if it works without. As it seems the remaining tearing only happened when it went above 60frames, so there you go.

Anyone with a strong enough machine and a 60Hz monitor should try this.

Here's a video on how to do it safely:
http://www.youtube.com/watch?v=8sXeSwe1_dU

Hope it helps anyone.

********************************


As I've said, the game has triple buffer using the Windows key, L key trick so you can have V-Sync on and get no tearing without the frame-rate drops known with V-Sync.

piez0r
02-07-2014, 04:33 PM
I've got to thank you for pointing out the nvidia AA profiler enhancement and the adaptive vsync. I'll admit I've not really played with the nvidia profiler at all.

I was just relying on in game settings. with vsync enabled, locked at 30fps. took vsync off and it only took me to 45-50 fps and lots of screen tearing.

With the nvidia AA enhancement with adaptive vsync i'm at a constant 60fps and minimal tearing. it's made this a much smoother experience. so thanks very much for the info.

Wrath2Zero
02-08-2014, 12:52 AM
Adaptive V-sync is useless if you don't get 60fps or over, it tears the screen and turns v-sync off under 60fps. V-Sync + triple buffer is the best option if you want no tearing but there is input lag. You can also offset the input lag by locking your frame-rate manually to 2fps under your monitor refresh rate.

Gold31415
02-13-2014, 03:24 AM
Any tips on improving fps when Physx is set to High? (Off, low, normal, high are the settings, but for me the effects arent really visible or different in the first 3 options).

Wrath2Zero
02-14-2014, 04:29 AM
Other than updated to 1.06 no. High PhysX option adds physX realtime particles to camp fires, chimney smoke and it's demanding for a reason rather than the smoking being a 2D shaders effect, also the smoke particles cast shadows.

Just so you know, it's not just demanding for PhysX, Crysis 2 has shadows on particles and really hurts performance on ultra, volumetric fog shadows in Crysis 3 but AC4 has more on the screen because they're constant.

Gold31415
02-15-2014, 04:10 PM
Other than updated to 1.06 no. High PhysX option adds physX realtime particles to camp fires, chimney smoke and it's demanding for a reason rather than the smoking being a 2D shaders effect, also the smoke particles cast shadows.

Just so you know, it's not just demanding for PhysX, Crysis 2 has shadows on particles and really hurts performance on ultra, volumetric fog shadows in Crysis 3 but AC4 has more on the screen because they're constant.



If all high does is add physx to campfires and chimneys I can do without it.

I thought the physx effects in gunfire, cannonfire and water etc were better on high than on they are on normal aswell.

U sure?

Wrath2Zero
02-16-2014, 04:19 AM
If all high does is add physx to campfires and chimneys I can do without it.

I thought the physx effects in gunfire, cannonfire and water etc were better on high than on they are on normal aswell.

U sure?

Yep I'm sure, it's pretty much why NVIDIA recommend a top end SLI system for high because of all the PhysX smoke in big towns and camp fires.


As of the latest game update, the PhysX detail levels are as follows:

Low: Enables PhysX weapon effects and smoke bomb effects. PhysX particles interact solely with characters.
Medium: In addition to character interaction, PhysX particles now interact with objects and the environment.
High: As above, but with the addition of camp fire smoke, chimney smoke, and other environmental PhysX effects.For High,

We recommend a multi-GPU SLI system if you’re also using the game’s other high-end graphics

Gold31415
02-16-2014, 06:45 PM
Yep I'm sure, it's pretty much why NVIDIA recommend a top end SLI system for high because of all the PhysX smoke in big towns and camp fires.

Thanks.. As of 1.06 theres now also a normal option between low and high, and it doesn't run too bad on a 680.

vinayaltair
04-22-2014, 06:43 AM
hey guys i wanna know how to increases fps on my ac4 i have 15 fps on low settings and 25 in med but it still remains the same in high .....any solutions and does razor game booster increase fps ....................thnx in advance .......ohh i wanna play dis game:(



and i heard that opening task manager and closing ur unwanted processes will increase ur fps really high and try using this program throttlestop it increased mine a bit ( long before) and try disabling ur anti virus ...it will detect ur .dll file ......

Locopells
04-22-2014, 09:37 AM
You can use Geforce Experience, however it is focused more on performance than quality and I don't personally care for the choices Nvidia made for the profiles for AC4. They do have the slider now at least, which helps a bit, but the profiles for AC4 could still use a bit more work. It is an option though, especially if you do not feel comfortable with changing the video settings yourself and you are happy with the results.

It's generally OK, as long as you ignore their resolution recommendation.

UupMeDown
04-28-2014, 11:35 PM
If you own assassins creed 3 and you just go to your documents and find Assassin3.ini and change it to Assassin4.ini then use assassins creed config for assassin 4... you'll notice a slight performance.

User>Documents>Assassin's Creed III>Assassin3.ini Rename to Assassin4.ini

then go to Documents>Assassin's Creed 4> then replace it with the assassin3.ini

Also they'll change all the controls to AC3's controls

DeviL-In714
06-23-2014, 08:08 PM
Alrighty then...I just picked up the entire AC series (minus Liberation) on the Steam Summer Sale, been testing them all over the last few days. they all ran smooth as silk up until Black Flag. I've spent all morning trying to figure this out, read through this entire forum, several other sites, etc. I finally got the game to run smooth, but I had to turn everything to either Low settings, or turn it completely off. I had to use D3DOverrider, and turn of my EVGA Precession monitoring on my Logitech G15 keyboard, which kinda rubs me wrong. I find this very odd, as i can run AC3 just fine on Normal settings, and Watch_Dogs on High (without any mods)

Specs:
Win 7 64 bit
CPU: AMD II X6 1050T
GPU: GTX 760
8 gigs DDR3

The game still looks amazing (especially compared to my PS3 version), but I'd think I've got more than enough power to run this above Low settings without the game stuttering. Am I missing something?