PDA

View Full Version : Unplayable. Even when I meet the recommended specs.



DJ17thMay
11-20-2013, 10:39 PM
Everything is set to lowest possible option in the graphic options menu.
And it's unplayable because I have less than 19 frame rates. :confused:

My PC has:

Intel Core i7 CPU @ 2.30GHz
16GB RAM
NVIDIA GeForce GTX 670 3GIG

:mad: So now I just wasted a lot of money to play a game for 15 minutes after spending 4 hours downloading the game as I bought the digital version.

Please do not set recommended specs when it actually means nothing.

Astr4len
11-20-2013, 10:47 PM
Try the 331.82 drivers and make sure you choose "custom install" and tick "clean install". Also make sure you untick 3DVision if you are not using it.

PiotrZajac
11-20-2013, 10:51 PM
Something's wrong with your pc
I have i5 @ 3.3 ghz, 8GB RAM, GTX 770 and it runs perfectly fine with everything set to max.

DJ17thMay
11-20-2013, 11:17 PM
I did update the drivers not so long ago but I can see there are some new drivers, 331.82!
I'lll try to do a clean install and report back if that solved the issue or not. :confused: :(

DJ17thMay
11-20-2013, 11:29 PM
Problem solved! :cool: Thanks.

Astr4len
11-20-2013, 11:40 PM
Yay nice :)

pladpenguin00
11-22-2013, 04:42 AM
i have a
gtx780
16gb ram
i7 3930k
win8.1

got new drivers
run settings on lowest even though i can play batman, bf4 and ghost all on max with no problem
ive uninstalled and reinstalled
tried just about what seems like everything.
whats going on

Loucmachine.Joe
11-22-2013, 04:44 AM
i have a
gtx780
16gb ram
i7 3930k
win8.1

got new drivers
run settings on lowest even though i can play batman, bf4 and ghost all on max with no problem
ive uninstalled and reinstalled
tried just about what seems like everything.
whats going on
Disable V sync

pladpenguin00
11-22-2013, 06:26 AM
Disable V sync

tried that. didnt help