PDA

View Full Version : Black Flag Won't Download



Aquai
11-20-2013, 12:30 PM
Hi all,

I'm having a strange issue. I got my nVidia promotion copy of Black Flag - Deluxe Edition email yesterday and added the game to my uPlay library - this bit went fine.

However whenever I am trying to download the game I am getting the following error:

"Failed to start download

uPlay is unable to start your download. Check that you have an active internet connection and sufficient space on your hard drive"

I have both of these and have also been able to download other games in my uPlay library without issue.

And suggestions? Thanks

darkvsgrim
11-20-2013, 01:42 PM
I had the same problem. It seems that even if uplay has the folders for installers and game set to another partition, it still wants space on the partition it is installed ( in my case my SSD windows drive that had 21GB free space).

While still disappointing, I was, ok I will download a copy from torrents... nope, no joy. The game will install but upon running the launcher will refuse to detect your game asking you to download it from Ubisoft.

As a last resort I have uninstalled Uplay from my C drive and moved it to another partition that had more than enough space (because it seems that PC users are second grade users and have to debug on their own... or skip all this hassle and just pirate the game to skip the DRM that seems to be there only to kill users with the license not the crackers). Nevertheless this method worked.

As a side note, why would you force your PC users download to the drive they have installed Uplay on? Why would I want Uplay to write over 21GB of data to my SSD drive (yes nobody forces me to install it there, but setting those 2 folders to another drive would make someone think your software is pretty SSD friendly)? Yes, 21GB is not much for an SSD to write once, but look at this issue in the long run.

Aquai
11-20-2013, 01:55 PM
Thanks for your reply. I've checked and the SSD where uPlay is installed still have over 40Gb free so don't think is causing the error but will give it a go.

ripemanew1
11-21-2013, 01:08 AM
Same problem here. Any solutions?

ripemanew1
11-21-2013, 02:24 AM
The solution for me was as follows.
Close everything
Uninstall Uplay
Run CCleaner
Shut Down PC (Dont just restart)
Start up and reinstall Uplay into a new folder on your main drive.
Restart PC
Unplug router and wait 2 minutes.
Retry download.

Im on win 7 64 bit premium and tried other reinstalls/work arounds to no avail b4 this.

hardysim
11-21-2013, 06:46 AM
start uplay once as administrator - worked for me

Aquai
11-21-2013, 11:07 PM
I've tried a reinstall and running as administrator, still no luck...

Great job uPlay...

L0rdZwu
11-22-2013, 04:37 PM
starting as administrator did the trick for me - thanks

krinnert
03-04-2014, 09:03 PM
Hi all,

I'm having a strange issue. I got my nVidia promotion copy of Black Flag - Deluxe Edition email yesterday and added the game to my uPlay library - this bit went fine.

However whenever I am trying to download the game I am getting the following error:

"Failed to start download

uPlay is unable to start your download. Check that you have an active internet connection and sufficient space on your hard drive"

I have both of these and have also been able to download other games in my uPlay library without issue.

And suggestions? Thanks

I had exactly the same issue and tried (almost) all the other random suggestions to no avail (running as admin etc.). None of it helped.

What finally did the trick was going to the UPlay settings menu and limit the bandwidth in the 'Downloads' tab to 1MB/s (which is a bit lower than my outside bandwidth).

I also made sure that I have only one UPlay/Ubisoft Game Launcher version installed and that it's installed on the same drive where I want to install the game (i.e. enough disk space on the same drive). Creating a folder named "games'' in the Ubisoft Game Launcher folder before trying to download a game seems to be a good idea as well --- can't say whether it's necessary but UPlay was happy while it ask questions otherwise.

This was quantum debugging -- change at least two things or it won't work. But I'm positive changing the bandwidth limit from "None" to something finite did the job.

Wilcobanjo
08-19-2016, 07:10 PM
I had same issue, running Uplay as administrator worked for me. Thanks!

Ubi-Banshee
08-23-2016, 08:56 PM
I had same issue, running Uplay as administrator worked for me. Thanks!

Thanks for sharing your solution!