PDA

View Full Version : PS4 - Getting asked to activate UPlay passport everytime game starts.



THizzle7XU
11-20-2013, 03:29 AM
I entered the UPlay code on the first day I got the PS4. But nearly everytime I start AC4, it asks me to activate the Passport. I don't have to keep putting the code in, but it says the Passport is activated everytime I select activate and continues to the main menu. If I say Buy a Passport, I just get the same message and continues to the main menu. If I say I don't have a Passport, I get no message and the game continues to the main menu (and I can still play MP, probably because the Passports were done away with).

Is there anyway to get rid of the Passport detection process (aka a patch) or is there a workaround to get rid of the activation process everytime I start the game. Once in a while the passport will be successfully detected and it won't ask me.

Edit: I'm not the only one:

http://www.gamefaqs.com/boards/706181-assassins-creed-iv-black-flag/67844831

THizzle7XU
11-20-2013, 03:49 AM
OK, I think I fixed it. I noticed on the main menu pressing square either takes you to the news stories, or a "Product Details" store menu (which the button action keeps alternating...WTF?). When I saw the store menu, I chose Redeem Code and entered the passport code again (last time I did it in the PSN Store when I finally got connected Friday night), and the code brought up the passport download again like I never redeemed the code. I downloaded the passport again, and now it always detects the passport correctly.

When I tried to enter the code a third time, it correctly told me I already redeemed the code and could re-download the passport. Maybe the download never took when the PSN was overloaded on Friday even though everything looked like it went through.

Black Edge13
11-20-2013, 04:22 AM
OK, I think I fixed it. I noticed on the main menu pressing square either takes you to the news stories, or a "Product Details" store menu (which the button action keeps alternating...WTF?). When I saw the store menu, I chose Redeem Code and entered the passport code again (last time I did it in the PSN Store when I finally got connected Friday night), and the code brought up the passport download again like I never redeemed the code. I downloaded the passport again, and now it always detects the passport correctly.

When I tried to enter the code a third time, it correctly told me I already redeemed the code and could re-download the passport. Maybe the download never took when the PSN was overloaded on Friday even though everything looked like it went through.

I'm having the same error and made a thread on this exact topic earlier today but it got buried. Thanks for the tip/fix, i'll give it a try after I'm done eating. <3

phoenix-force411
11-20-2013, 04:26 AM
I thought they made Uplay passports free now, since people were having so much conflicts.

THizzle7XU
11-20-2013, 06:35 AM
I thought they made Uplay passports free now, since people were having so much conflicts.

They are free, but they only made them free like a few days before the game came out, so the game is still programmed to activate the passport.

garyhove666
12-02-2013, 06:41 PM
They are free but I have installed a passport twice now and still it keeps telling to install one, I wouldn't bother but I want to use the companion app which needs the passport !!!

lootsquadrune
12-27-2013, 11:45 PM
yes i have the same problem. nothing that i do works

AlextheGreat611
01-01-2014, 04:04 AM
Hey... I've tried everything and I can't get it to work. Maybe you can help? I've tried to put the code in every which way I can... either from the store or when it first asks you do play with a u-play passport, all the way to pressing square and going to product details and redeeming the code. No matter what I do to enter it, it will not redeem the code. I've entered it probably 15 times now... any ideas?

dlebra
01-03-2014, 03:17 AM
doesn't work for me either. I've done everything and this is insanely frustrating. 69$ with tax for a game that doesnt fully work..

techfreak151989
01-04-2014, 02:44 PM
I had the same issue about a week ago. At the time the DLC I had wouldn't even work. So I went to Settings > PSN > Restore Licenses. After doing that I was able to re download the UPlay passport and was able to get passed the passport activation screen.

Shahkulu101
01-04-2014, 02:52 PM
Keeps happening to me - apparently you can't use the uplay passport code when upgrading to next-gen - so I need to buy a new one. it's weird, it accepts the code but then goes back to the same screen and asks me to enter it again.

kookieman6
01-04-2014, 03:37 PM
Okay. I had the same problem. My fix was to sign in PSN with a guest acc and load the game to the main menu. Then Sigh in with your PSN and relaunch the game. It works like normal now. And I have no clue how it worked. But it did.