PDA

View Full Version : [PC] FC3BD Achievements not unlocking on Uplay



Jmech1986
05-24-2013, 09:21 AM
Several of the collectible achievements for Blood Dragon haven't unlocked for me on Uplay. I've looked around and have seen a few people with this same problem, but no update on whether or not it has been addressed yet. If anyone has dealt with this problem and found a solution, or if you've spoken with the Ubi tech about this, please share some info on what's going on. Thanks.

flamey90
05-25-2013, 09:38 PM
Are you playing BD in offline mode?

If so, put UPlay in online mode, play game even just for a couple of minutes then quit back to desktop (don't know if you have to manually save).

Uplay will say the usual of played for x amount of minutes but of it does the same as mine, the achievements should unlock at that point also.

Jmech1986
05-27-2013, 10:23 PM
Was definetly in online mode, but tried using both modes once i noticed there was a problem. Still no achievements. At this point i think i'm at the mercy Ubi support.

olderthanheck
05-28-2013, 12:44 AM
It's also doing it to me . Friday I had only one garrison left , saved & exited game . Came back later in evening & I lost all garrisons but 3 , upgrades & collectibles gone too ! My uplay also now says failed to synchronize . I hate to start up my surround setup & have it revert back too...

EvilPixieGrrr
05-28-2013, 08:32 PM
Have you contacted Support (http://www.ubi.com/us/support/) about this? If not, you should so they can help you fix this issue. :) Thanks!

Jmech1986
05-29-2013, 12:27 AM
Indeed i have, would you like to see the exchange i'm having with them thus far?

Jmech48895/24/2013 8:14:07 AM
Several of the achievements for Far Cry 3 Blood Dragon haven't unlocked even though they're clearly completed. I've looked around a bit and have seen that this is an occasional issue with other Uplay users, however i haven't seen anyone say that issue is resolved. Is there a way to fix this problem without having to play the entire game over again? If not, can you explain what happens that causes this problem so that if i do decide to try again i wont make the same glitch occur twice?

Andrea5/24/2013 6:55:56 PM
Most Uplay actions unlock once your save games have synched in Uplay. I'm looking at your account and everything appears to be unlocked and it looks like you recently used the points from them for Blood Dragon rewards. Please let me know if you have any questions.

Jmech48895/27/2013 9:25:12 PM
I think you may be looking at the four Actions, which worked perfectly fine. I'm talking about the nineteen Achievements, of which four have not unlocked when they should have. Specifically the achievements What are You Reading For?, The Greatest Format of all Time, Tooled Up, and The Drug of the Nation did not work on my account. Sorry I did not specify earlier.

Andrea5/28/2013 3:32:31 PM
I think you may be refering to the Steam actions? Unfortunately we do not have any access to those. Steam uses its own system. To get those achievements you will need to contact Steam directly.

Jmech48895/28/2013 11:17:19 PM
I am not referring to Steam actions, there is no such thing. I am referring to the Achievements that are unlocked and then displayed on the Uplay client. Actions and Achievements are similar, but they have seperate tabs for each game on Uplay. As a reference, here is a link to a post made in the Ubisoft Blood Dragon forums with a picture of exactly what i am talking about. The person who posted this picture is experiencing the exact same bug as me: http://forums.ubi.com/showthread.php/770786-Far-Cray-3-Blood-Dragon-Achievements-not-working-Forums I hope this clarifies the issue so that we can be on the same page and begin working on a solution.

This poor woman apparently has no clue what an achievement is... Anyway i promise to post the final word on what's going on with this glitch since no one else seems to have found a fix yet.

Jmech1986
06-02-2013, 01:26 AM
Final message:

Andrea5/29/2013 2:43:49 PM
Thank you for reporting this issue. We have forwarded this issue to the dev teams and the problem is currently under investigation. If any changes are made to this issue, details will be posted directly to the support section of our website as well as the official message boards at http://forums.ubi.com. Please keep an eye on these two locations for all updated information as it becomes available.

If were lucky maybe one day this will be fixed...

Jmech1986
07-29-2013, 01:25 AM
It's been about two months now and there's still no word on this. I've checked with the Ubi client several times but no update has fixed this problem. If they fixed it but were not able to activate achievements retroactively I would have no way of knowing this and would also have to 100% the entire game again anyhow.
It's bad enough Ubi is following EAs footsteps and forcing pc gamers to separate achievements from Steam, but now the achievements don't even work... After years of pc gaming I can tell you who takes their gamers seriously: Bethesda, Valve, and Blizzard for sure. Up until now I've never had an issue with a Ubisoft game, but this is becoming disappointing...

LStormbringer11
11-17-2013, 12:17 PM
Just bought this game off a steam sale and i have the same problem

Derp, Tooled up, and The only true stopper remain locked

The only true stopper i could see being as there are no ways to track which enemies youve headshotted, but the other 2 are essentially story related

I just submitted my question to support so ill see what happens

Jorj_x
01-03-2014, 04:26 AM
I had this same issue, I was able to resolve it with a couple of steps outlined below.

1. Assign my PC a permanent ip address on the local network created by my ADSL router by entering the MAC address of my PC's network card, in this case I assigned it 192.168.0.2 so it would always get that ip and no other pc on the network would be assigned that ip even if my PC was off.

2. In my router's settings I assigned the ip I had assigned my PC to be a DMZ zone. This means that my router just passes information through from the internet to my PC with the bare minimum of filtering and therefore no hardware based firewall filtering. I've seen a few different brands of routers that have this feature though it may not always be called DMZ.

3. This is a problem with ports being blocked by Windows firewall but not saying so -so you can allow an exception. The way I got around the issue was to install the very good free firewall Private Firewall 7.0 and then went through manually creating firewall exceptions in that for all the uplay exe's in the uplay folder and then all the blood dragon exe's I could find in the blood dragon folder.

4. After that it worked, sadly I was almost finished the game but I still got my achievements when my PC finally communicated properly with their servers.

I'm sorry if my explanation is too technical for some readers but a little bit of googling the stuff you don't get might make it easier. Sadly from doing help desk for many years I know that the last thing someone providing tech support for a game is going to want is to have to try and work out the settings to do this on how ever many different routers there are on the market and management normally bans it as well.

WARNING: adding your PC to a DMZ (stands for De-Militarised Zone) as outlined above basically sets your computer up to be directly connected to the internet so make sure your copy of windows is up to date and/or install a good free firewall before trying it.

T0scanelli
01-06-2014, 05:44 PM
That was the hint I was looking for. Thank you Jorj_x! I was also confronted with the missing Uplay rewards. Now as I set an exception rule for Windows Firewall the rewards were unlocked. What a shame for Ubisoft support, that they can't bring their own **** together. And btw, I purchased the Steam version.

Jorj_x
01-14-2014, 12:50 AM
I'm glad to hear that my post helped you!
I probably described a much more complicated fix than is necessary - I was just having trouble finding a way to create a new exception (when it isn't a prompt from
Windows) in Windows Firewall so switched to one that works a little better and has an easy system for creating new exceptions (Private Firewall 7.0).
If you connect to the internet with a wired or wireless router you may still need to check that the router isn't imposing it's own firewall rules as they normally do and they can interfere and cause these kinds of problems.

lrdxgm
01-16-2014, 12:17 AM
I have the same issue. I unlocked, bought, killed, etc. everything, but I have got only 11/19 achievements..

Trying Jorj's trick, DMZ and disabling firewall (I live dangerously ;) ), but I didn't get any of them registered..

Tried to contact support, but I just get a "We are encountering a technical issue with the page you are trying to view." message after creating the ticket, and of course the question is not in the "My Question History"... Seriously? :mad:

Jorj_x
01-21-2014, 05:21 AM
As I remember it I played for a bit as well - it might be that it caches the completion info until it can upload to the server but only tries to do the upload when you hit a checkpoint in the main story or complete another achievement. I wouldn't recommend running without a firewall for long :p It turns out it's easy to create exceptions for windows firewall - the link is in the left bar when you open firewall info in control panel.

kotekzot
11-05-2015, 06:34 AM
I had a problem with Uplay actions not registering for this game, and after finding this thread i managed to get them to unlock by adding inbound and outbound exceptions for the game's executable to the Windows firewall. Simply starting the game after adding the exceptions (not before) was enough.

Deuterium-H2
09-26-2016, 11:35 AM
Hey guys,

it's been over a year since the last post, but let me quickly describe, how to fix most of every uPlay-bug:
Just start up your Windows on Safe Mode with network support (start up your computer and spam F8 before windows shows up), then start up uPlay and do, whatever you want. In this case, just launch FC3 Blood Dragon. It will not start up (no graphic support), but your achievements will unlock, if you theoretically finished them ingame. Also, this helps bypassing lots of download-problems uPlay faces especially with Rainbow Six Siege.

It's the most easy way to get the sh*t out of your system (also works perfectly well with Steam, Origin etc., nevertheless uPlay is the king of bugs).

I hope, I could help you :)

Deli_Dios
10-20-2016, 09:57 AM
Hm. A week ago i complete gamestory and get achievment.
Today i start save previous last mission and take all tv, vhs, text-files, kill all creatures and get all bases... but get only 1 achievment for 30lvl.
Restart game and buy last update for pistol. and get achievment.
The question it - can i get acvhievment for tv and other stuff or i must start a new game now?

VICTORTREVOR
06-08-2018, 09:11 AM
I thought the problem was on my side at first , but the achievements for AC Origins and Far Cry 5 sync just fine , but older games like AC Revelations for example don't , I jumped from the Galatta tower 5 times to Golden Horn still no achievement . I thought maybe I didn't do it right so I went for something simpler , Desmond's story missions completed em but still no achievements . I know my complaint will get a soothing response from Ubi and assurance that it will be solved .

But They have to focus on upcoming games and games that are currently most played to keep their company afloat . I say this to others to stop trying to fix this , it's not our fault .

lior.assor
10-14-2018, 08:43 PM
Support will not help you. It's a coding problem across DIFFERENT GAMES that should be resolved by the development team but don't expect them to do so. This has been going on for a LONG TIME. They ASSUME that the achievements will always be synchronized but the problem is that not always that happens, if instance, if the game crashes.They should have a way to sync everything, not just achievements from your last game session.