PDA

View Full Version : Direct X problem with Blood Dragon



lowmankind
05-13-2013, 06:53 AM
I'm having a weird problem, in which Blood Dragon seems to think that my machine can only run DX9. It's clear in the options menu, because if I try to change it to DX11 (or even 10), I simply do not have that option. This is sucky for any number of reasons, such as the fact that it won't allow me to use SSAO or antialiasing. Also, the auto-detect for Optimal Settings has defaulted to Low for absolutely everything.

I haven't really played the game yet, I tried the first minute of the game to see how it would run, and it's not that great. The frame rate seems to suffer, using specs that a machine from 6 years ago should have no problem with.

For reference, FC3 plays on the same machine using DX11, Optimal Settings default to Very High or High (fairly smooth, only occasional dip in frame rate at 720p).

Now, I'm sure there's some form of 'retro' irony in only being able to play on 2007's technology, but still, I want to play at the spec my machine should be at!

Mr_Shade
05-13-2013, 02:23 PM
I'm having a weird problem, in which Blood Dragon seems to think that my machine can only run DX9. It's clear in the options menu, because if I try to change it to DX11 (or even 10), I simply do not have that option. This is sucky for any number of reasons, such as the fact that it won't allow me to use SSAO or antialiasing. Also, the auto-detect for Optimal Settings has defaulted to Low for absolutely everything.

I haven't really played the game yet, I tried the first minute of the game to see how it would run, and it's not that great. The frame rate seems to suffer, using specs that a machine from 6 years ago should have no problem with.

For reference, FC3 plays on the same machine using DX11, Optimal Settings default to Very High or High (fairly smooth, only occasional dip in frame rate at 720p).

Now, I'm sure there's some form of 'retro' irony in only being able to play on 2007's technology, but still, I want to play at the spec my machine should be at!

Hi,

It maybe down to your graphics card / and / or/ driver - have you updated them recently? [if you have, try using a slightly older driver]


It could also be due to the graphic card being a M version? [laptop?]


If you are still having issues running the game - I can only;y suggest you contact support - please send them your DXdiag report too - this will help they find the issue.

1. click on "START"
2. click "run"
3. type in "dxdiag" and click "OK"
4. check through the tabs and perform all tests
5. click "Save all Information..." and save the text file to a location of your choice

Please forward that and a description of the issue to support - you may have to select Far Cry 3 as a topic, since Blood Dragon has yet to be added:


www.support.ubi.com (http://www.support.ubi.com)

click the format [pc] and game [FC3] and you should see at the top 'ask a question' - use that to explain the issue and forward your DXdiag

lowmankind
05-14-2013, 12:58 AM
Thanks for the reply, Shade!

I did check to see if new drivers might solve the problem, but sadly they did not (although performance did improve). The game is playable to me, but on strangely low spec and without all the benefits of DX11/10. So I can still experience the game, it just doesn't look as good as it should!

I did some research and I believe you're right about the laptop thing -- the supported gfx cards list states that laptop cards should work, but aren't supported.

Anyway, I have submitted a ticket with Ubi support, with all the dxdiag data, so let's hope they have something to report.