PDA

View Full Version : Assassins Creed 3 Crashes Constantly In Cutscenes



Cookybiscuit1
03-25-2013, 03:08 AM
Been having this problem since getting the game. I'm using the Steam version of the game so I'm guessing it updates itself, but I downloaded 1.02, 1.03 and 1.04 separately and ran them, they all produce the same problem. The game just crashes for no reason in cut-scenes, if I try about 10 times I can get through them but obviously thats not ideal, took me half a dozen tries to get past the van cutscene at the start of the game.

Is there anything glaringly obvious I'm missing, because this is pretty stupid.

Setup is 3570k, Gtx 670 and 8GB of RAM. Drivers are the newest and I've tried running it again with hardware at stock clocks and it makes no difference.

Thanks.

Perk5
03-25-2013, 06:41 AM
I remember having to underclock my card before it ran stable. I have two EVGA factory overclocked GTX 570's, but only used one because the game scaled negatively with SLI enabled. But that was on launch date, pretty **** shameful if you're having to make compromises like that 3 patches later.

Cookybiscuit1
03-26-2013, 02:28 AM
Thanks for the reply. Still can't get it to work. Funnily enough the furthest I've got without it crashing happened to save on a cutscene, about 30 seconds into the game where Desmond puts the weird cube thing into the console. I can play right up until I see his Dad's stupid beard then it crashes. :(

I tried downclocking the card 500Mhz which is as far as the Afterburner slider allows, no avail.

Anyone got any ideas?

Thanks.