PDA

View Full Version : Help AC3 not Working!



jevans3050
01-11-2013, 07:39 PM
Hi not sure if this has be covered else where but i bought and dwnloaded a copy of AC3 direct from the uplay launcher and after several dwnloads/reinstalls i still cannot play the single player game only the darned multiplayer which is great unless u like me want to unlock the additional multiplayer stuff by playing througth the single player game!!! i have been a follower of the AC franchise since day one and have never encountered this problem before and its really making consider asking for my money bk. so please if any1 knows how to fix this then im all ears/eyes and hands. thanks inadvance for all and any help
:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D

Tim_Skijwalker
01-11-2013, 08:55 PM
you are not really specific about what the problem is.
does it crash right when you start?
when you go in-game?
did you try switching to single player out of the multiplayer menu?

I'm just gonna post some other known fixes here that might help you. it's a lot of different things that MIGHT do the trick, i hope one of these things works.. if it doesnt please be more specific about what doesnt work ;)
good luck.


Assassin’s Creed III Black Screen or No Responding – Fix
Solution: Game installing on external hard drive is the gamin cause of this issue. So install the game on internal hard driver to avoid this problem.

I personally had this (My resolution was wrong)

Assassin’s Creed III Resolution Issue
Possible Solution: Make sure your display hardware supports the game resolution you are trying to play in. Please check what resolution your display hardware supports:
For Windows XP and Windows Vista Users:
Go to Control Panel
Locate Display icon, open it
Go to Settings tab.
Locate the resolution slider that says Screen Resolution or the slider labeled Resolution and drag it to the far right.
For Windows 7 Users:
Click on the Start button > Control Panel.
Select Appearance and Personalization > Display.
Select Display > Adjust Screen Resolution.
On Resolution bring down the pull-down menu and slide the resolution pointer all the way up toward High.
Recommended Resolutions for Play Assassin’s Creed III
Standard:
800 x 600
1024 x 768
1280 x 1024
1600 x 1200
Widescreen:
800 x 480
1152 x 720
1280 x 720
1680 x 1050
1920 x 1080
1920 x 1200


Possible Solution 1: Run the game as ‘Run as Administrator’ by right clicking. If you are using Steam then navigate to:
Right click on game.exe and select “Run as Administrator”.
Possible Solution 2: Run the game in compatibility with Windows XP SP3.


Possible Solution 1: Disable all unnecessary background applications before starts the game, especially browser flash-based games. These heavily consume resources which can slow down your gaming experience and just to be sure that nothing is conflicting with the game.
Possible Solution 2: Delete the all temporary files from your computer by donning this
Click Start > Run > type %temp% > OK > click Edit > Select All > Delete.
Possible Solution 3: Disable your anti-virus programs and sure to re-enable them after playing.
Possible Solution 4: Alt + Tab out of the game and check if there is any windows firewall or any other
Possible Solution 5: Download the latest version of your DirectX from Here.
Possible Solution 6: Update you Graphic Card Drivers, for NVidia Graphic Cards, try to download and install the NVidia Latest Driver Version and for AMD (ATI) Graphic Cards, try download and installing the AMD Catalyst.
Possible Solution 7: After the updating the graphic cards and didn’t solve the issue then try to rollback your video card by downloading an earlier version of your video card’s current driver.
Possible Solution 8: If you have a multi-core processor, try disabling them, it might do the trick!
Possible Solution 9: Enable the 3GB switch to - worked for many as of May 18, but please note this is still not a guaranteed solution.
To enable the 3GB switch on Windows Vista™ or Windows 7:
Right-click Command Prompt in the Accessories program group of the Start menu. Click Run as Administrator.
At the command prompt, enter “bcdedit /set IncreaseUserVa 3072?
Restart the computer.
(If it doesn’t work)
To disable the 3GB switch:
Right-click on Command Prompt in the Accessories program group of the Start menu. Click Run as Administrator.
At the command prompt, enter “bcdedit /deletevalue IncreaseUserVa”
Restart the computer.

jevans3050
01-12-2013, 01:15 PM
Hi timskywalker thnx for response.. the issue im having with the single player game is that it crashes as soon as it starts so far i have followed every fix i could find online plus as mentioned before redownloaded and reinstalled several times...

exact error details are: Problem Event Name: APPCRASH
Application Name: AC3SP.exe
Application Version: 0.0.0.0
Application Timestamp: 509f87a5
Fault Module Name: AC3SP.exe
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 509f87a5
Exception Code: c0000005
Exception Offset: 0041ce9f
OS Version: 6.0.6002.2.2.0.768.3
Locale ID: 2057
Additional Information 1: fd00
Additional Information 2: ea6f5fe8924aaa756324d57f87834160
Additional Information 3: fd00
Additional Information 4: ea6f5fe8924aaa756324d57f87834160

Again any help solving this is and will be much appreciated.

Pleasefixmyacc
01-12-2013, 01:20 PM
Sorry OP but the solution to your problem is really simple and you made a mistake. You got the PC version, you should've gotten a console version. But it's fine mate! Just sell your computer and go buy a console!

troll highfive anyone? Come on...p..please.
Btw mods will re-direct you to customer support, be ready for THE ride of your life!

jevans3050
01-12-2013, 06:07 PM
IV ALREADY SENT IN TICKETS AND SO HAVE HUNDREDS OF OTHER PEOPLE WHO HAVE HAD EXACTLY THE SAME ISSUE AND NONE OF US HAVE RECEIVED ANY REAL OR USEFUL HELP FROM SUPPORT WHICH IS WHY IM ASKING THE ASSASSINS CREED COMMUNITY AS THE MIGHT BE A BRIGHT SPARK OUT THERE THAT MAY HAVE A SOLUTION....SO TO THAT EFFECT I REALLY HOPE THE MODS DONT MOVE OR CLOSE THIS THREAD (smiles nicely and says pretty please) :)

Tim_Skijwalker
01-12-2013, 10:33 PM
Thanks for the reply.

Make sure your video card is up to date: (I tried to put the doubtfull fixes latest in this post so start on top)
AMD - http://support.amd.com/us/Pages/AMDSupportHub.aspx
Nvidia: http://www.nvidia.com/Download/index.aspx?lang=en-us

I did some research and this is some of the stuff I came up with;


Assassin’s Creed 3 CTD (Crashes to Desktop) on Steam and Windows while launching:

No matter you are playing this on local Windows computer or on Steam, is the game is crashing right when you double click the Game desktop shortcut icon, then try launching the game from its originally installed location.

On Windows 7, Go to Program Files > Ubisoft > Assassin’s Creed 3> and right click the AC3 EXE file, select “Run as Administrator”

On Steam for 32bit: C:\Program Files\Steam\steamapps\common\ and Right click AC3 EXE file, select “Run as Administrator”

On Steam for 64bit: C:\Program Files (x86)\Steam\steamapps\common\ and Right click AC3 EXE file, select “Run as Administrator”
If still the game is crashing to Desktop while launching from the Desktop than try running the game in Windows XP SP3 Compatibility mode. You can do this by right clicking the EXE file, select Properties, click Compatibility Tab and select “Run this game in compatibility mode for” and select Windows XP SP3.




Assassin’s Screed 3 Crash and CTD Solution:
Most of the time it is the game itself which comes with few bugs that cause the crash and many times it use to be our system which causes these problems. If it is related to the game, developer will surely launch some patches to fix it but we have to first make sure it there is not the problem from our end itself. Hence, follow the below steps:

The very first thing to fix Crash or CTD is to update our graphics driver. Just visit nVidia Official site, enter your OS version, select graphic card, download and install the drivers. If you are using AMD/ATI drivers, then do the same on their official website.

If updating the drivers wont fix than probably you might need to roll back to earlier drivers. It has been observed that rolling back to driver 301.42 and 306.23 has helped many to get rid of Crash as well as improved performance.

Also many times it could be your Antivirus and Firewall that can make it crash. So, if you are facing Crash problems with Assassin’s creed 3 and your Antivirus is enabled, try disabling the same. Especially when you have Norton Antivirus installed.

Most of the crashes with games are associated with Video Cards itself, hence if still you face Crash with the game, then you should try Turning Off SLI / Crossfire, disable anti-aliasing and filtering, disabled V-sync and then restart the game again.

If still the Crash or CTD occurs, make sure you have the latest version of DirectX installed on your system. You can download it from here: http://www.microsoft.com/en-us/download/details.aspx?id=35

Until now your crash problem should have been fixed. In case, it is still crashing then there might be some program running in background that is causing the problem. Just right click your task bar, select Task Manager, click on Process Tab and kill every unwanted process that is not required during playing Assassin’s creed 3.

Also open your graphic cards control panel and turn off one GPU. Yes, run the game on only One GPU. You can also try out running the game in Windows Mode. This will surely fix the Crash problem because if trying above all steps wont work that means your system is not compatible for running AC3 and running in windowed mode will need very less resources which enable you to play the game comfortably.
Assassin’s Creed 3 Crashes on Steam:

Many users around the world also playing Assassin’s creed 3 on steam and they also face Crash problems. If you are one of them, then just follow below steps to fix it:

Launch Steam on your computer.
Go to Library and select Assassin’s Creed 3.
Right click and select Properties. Click on the Local files tab.
Here you will find a button for “Verify integrity of game cache.”
Click the same and wait for few minutes until the job is done.
Once completed, start the game again. Hopefully Crash problem will be gone.



open your nvidia control panel...use default settings...dats it...hope it helps.


guys turn of VSync go to my documents/assassins creed III/assassins3.ini and set it to 0


Download Driver
Start Type: Device Manager
Expand Display Adapters
Right-Click Driver Name, Uninstall
Reboot
Run Driver Sweeper
Reboot
Install Downloaded Driver
Driver Sweeper will scan for any left over files from the old driver, old driver files can cause conflicts with new driver installations. Create a System Restore point beforehand, in case any problems or issues arise.

Driver Sweeper:
Drivers - Clean Left over Files after Uninstalling http://www.sevenforums.com/tutorials/83814-drivers-clean-left-over-files-after-uninstalling.html
Nvidia Download Site:
NVIDIA Driver Downloads - http://www.nvidia.com/Download/Find.aspx?lang=en-us

I really hope one of these things fixes your problem.
Good luck and enjoy the game (If you get in)

jevans3050
01-14-2013, 03:07 AM
Hey tim thnx for the tips sadly iv followed all of the things u suggested above and i still can not get the single player game to work so gonna write the game off as a waste of time and request my money bk from ubisoft as im not gonna lose money for sumthing that dont work....which is a great shame as ubisoft is normally a great company who out of all game companys i trust the most jus seems theres sum kind of issue with AC3 which ubi are unable or unwilling to fix :( anyway again thnx for all the help.

abohamed
01-14-2013, 03:22 AM
Hey tim thnx for the tips sadly iv followed all of the things u suggested above and i still can not get the single player game to work so gonna write the game off as a waste of time and request my money bk from ubisoft as im not gonna lose money for sumthing that dont work....which is a great shame as ubisoft is normally a great company who out of all game companys i trust the most jus seems theres sum kind of issue with AC3 which ubi are unable or unwilling to fix :( anyway again thnx for all the help.

hey hey .. wait :D .. i know its so stupid to ask you this but do you install the DirectX that comes with the game ?!

jevans3050
01-14-2013, 03:31 AM
Hey abo yeah i have installed and updated every darned driver i could think of(display, graphics, sound, directX and so on) the problem isnt to do with my system set up as iv seen hundreds of other people post the same issue on every gaming forum i can think of and if u check out the ubi support page theres even a section on the where sumone with same issue submitted a help request to the support team and their response has been "Thank you for your patience! We understand that you have experienced some difficulty accessing your Assassins Creed 3 PC game, we are currently working on a solution for you and hope to have this available very soon. In the meantime, we thank you for your continued patience and understanding,
Best regards,Ubisoft Customer Support"
the above message was posted by ubisoft support a little over 30days and theres still no sight or sound of a fix. :(

abohamed
01-14-2013, 03:38 AM
shame on them ... anyway there is a patch for PC is coming very soon now ( i think 15 jan or so ) wait and see if this will fix it .. and if it did not just shift + delete this s hit :D

jevans3050
01-14-2013, 03:47 AM
LOL abo kk ill wait for the patch and we'll see if it helps if not i'll be demanding my 42 bk.

Pleasefixmyacc
01-14-2013, 03:23 PM
LOL abo kk ill wait for the patch and we'll see if it helps if not i'll be demanding my 42 bk.

Cant get refund for digital products according to their license thingy.