PDA

View Full Version : AC3 Multiplayer doesn't run (Windows 8 + Steam)



monsimons
12-29-2012, 04:55 PM
Hi,

I''ve searched through the Web for anything addressing this problem but couldn't find anything, so this is my last resort. I have AC3 DE bought from Steam and cannot run mulitplayer at all - the game hangs with a black screen and that's it. The first two times there were crashes but the report logs weren't helpful. I've also asked the same question on Steam's forums where another guy had a similar problem but it was caused by an 'overlay' from another game, which is something I don't have on my machine, and I'm still waiting for an answer there.

The thing is that I'm not sure if it Steam related or only AC3 + Windows 8. A friend of my bought the game on a DVD and his multiplayer worked just fine (he was with W7, though).

I tried setting Win7 and WinXP SP compatibility modes on the ac3mp.exe without any luck. This is really frustrating. Please help me resolve this.

Mr_Shade
12-29-2012, 06:32 PM
Hi there,

Black screens can sometimes be driver related - so please insure your GPU drivers are upto date - the game requires the latest drivers for best support.

If your not using it on a laptop [which can cause a number of issues] - and updating drivers did not fix the issue - please contact support:

www.support.ubi.com

monsimons
12-29-2012, 06:50 PM
Hi Mr_Shade,

I found about the latest drivers fix suggestion two days ago (when I bought the game) and my drivers were updated (310.70) long before I installed AC3. I'm also playing it on a desktop machine with GeFore GTX 570. It is odd that I'm the only one experiencing this problem.

anidais
12-29-2012, 06:52 PM
I'm on Windows 8 and have no problems with the multiplayer.

monsimons
12-31-2012, 12:19 AM
So, it turned out that the problem was something related to the files of the game - running Steam files integrity check and downloading 1.9GB corrupted files fixed it.

o_0