PDA

View Full Version : Far Cry 3 Bug



cadw96
12-01-2012, 11:03 PM
Hello,
I recently got FC3. I played the mission Harvest theJungle. As soon as I came in the "tatau/skills" menu, I saw it was wrong.I get after 5 minutes waiting the text: "Now I will teach you the takedown" I have watched walkthroughs to see what I have done wrong, but I did everything right, but it just doesn't work. My specs (I run 40+ fps, so i guess these aren't the problem, but you never know :p ) :
- Celeron G540 Sandy Bridge (2x 2.50 GHz)
- 4.0 GB DDR3 Ram
- Nvidia GeForce GT 520 (1 GB)

neilgodden
12-03-2012, 09:46 AM
can't get out of that menu either!

cadw96
12-21-2012, 02:47 PM
Does anyone know how to fix this? :'(

MohMurad
12-21-2012, 03:11 PM
Try pressing M, or ESC if you haven't already. Try ALT + Enter as well.

tagadactactac
12-30-2012, 02:33 AM
Same thing, I get to a menu with locked items, and three animals icons in the upper right (heron, shark and spider), impossible to get out of that menu, I tried clicking everywhere, all I can get is a tutorial on attacking someone from the back. Impossible to get back to game.
Tried every key on the keyboard, All I can do is windows (gives me windows task bar) and alt+enter (switch to window mode).
First time launching this game, I think I have last update (1.0.4).

EDIT : Actually, I finally managed : you have to double click on the takedown icon (the one in the middle of the shark screen) so it gives you the menu to acquire that knowledge, after that you can come out of the menu.

ccurtis20
12-30-2012, 02:22 PM
double clicking makes you learn the new skill as "tagadactactac" said