PDA

View Full Version : How to fix consistent crashes and Boston FPS. [Tutorial]



xAdvent
11-24-2012, 06:46 PM
Having been unable to play the game for more than 10 minutes without a crash (black screen and sound looping), I was beginning to lose hope in ever being able to play it. Boston was a nightmare with the frame rate dropping into the 30s inexplicably.

Spent most of yesterday fixing everything and I think I've found a definitive solution that should hopefully fix your issues (at least if you have a similar set up to myself).

I'll start with the crashing as that's the most important fault. I have a GTX580 and having read around, it appears that this card has issues with some DX11 games (strange as I'd never encountered this problem ever before). The issue was down to the voltage on the card being too low and somehow causing the game to crash. To fix this, I downloaded EVGA Precision X (I tried MSI Afterburner but it seems an update prevents EVGA cards' voltages being altered). In the program, I bumped my voltage from the default (1053) up to (1100) and have now played 3 hours of the game with no crashes whatsoever.

Now, to fix the frame rate issues in Boston, you'll have to take to the 'Assassin3.ini' file that you will find in your documents under the Assassin's Creed III folder. By default the game has vsync turned on and has the refresh rate at 60Hz. Now vsync is the main culprit for the low FPS it seems as turning it off near doubled my FPS from 30 into the 60s. To do this, simply change Vsync=1 to Vsync=0.

The refresh rate is down to your monitor, of course. If you have a 60Hz monitor then by all means just save the config and set it to read only (IMPORTANT) and enjoy the game. If you are like myself and have the luxury of a 120Hz monitor then you may also have been experiencing FPS drops due to the game putting you down to 60Hz. I don't understand how this affects the framerate but altering it seemed to fix me. Simply change RefreshRate=60 to RefreshRate=120 and save the file. Set it to read only otherwise the game will default all your settings again.

If you have a processor that has hyperthreading (I have a 2600K for reference) then be sure to disable that in your BIOS as it has been reported that the game really dislikes it and will cause your FPS to absolutely tank in Boston also. I can't give you specific guides on this as it's obviously down to your motherboard.

I hope this was of some help! If you're still experiencing problems, be sure to leave a detailed report below and include all your specs so that myself or Ubisoft employees can decipher what may be the issue.

MrGreenest
11-24-2012, 06:52 PM
putting off the vsync, doesn't improve the fps in boston

erayerdogan
11-24-2012, 06:57 PM
Everytime i see someone opened a new thread called " Solution to FPS Issue In Boston" i get excited.But that moment i see that the solution is again the closing the vsync from the .ini file.Never worked.Wish it had worked.Thanks anyway.

xAdvent
11-24-2012, 07:08 PM
Everytime i see someone opened a new thread called " Solution to FPS Issue In Boston" i get excited.But that moment i see that the solution is again the closing the vsync from the .ini file.Never worked.Wish it had worked.Thanks anyway.

putting off the vsync, doesn't improve the fps in boston

I understand this hasn't worked for some people but for myself and friends with 120Hz monitors, we saw big improvements by turning it off. I'm sorry that it doesn't work for you!