PDA

View Full Version : Buggiest AC game ever released, I'm amazed.



SardaHD
11-23-2012, 03:43 PM
I'm no stranger to the glitches and quarks that this series usually has but my god... this takes the cake. I don't know how you guys pulled it off, but somehow you managed to make every past incarnation look flawless by comparison.

Now I tried my best to put up with it, I made it 25 hours, 48% done, got to sequence 9. So I tried, really. Let me give you a run down of what drove me to shelf this game. Just to give some examples of what I endured... minor if any spoilers.

I start by doing the Homestead missions, I come to this mission were a girl wants me to fetch a doctor in 3 minutes, easy stuff right? No. 2 times i attempted to start this quest, wasn't until the 3rd time it loaded. I had to exit the animus and go back into it and talk to her 3 times to start this. Not good start right? It gets better. I approach the doctor, he gets on his horse, attempts to follow me, gets stuck on a tree, I run out of time or I get to far and fail. Next attempt #4, I got the doctor, go to her husband, he gets on the horse rides in the wrong direction, failed for going to far. Attempt #5, it by some miracle works.

From here I go back to the manor, upgrade my holster to dual holsters... and it bugs out on me. One of my pistols is the correct pistol I choose, my 2nd pistol is the basic starting pistol, even if i change it it will just swap back if I do ANYTHING. I look it up online, and this is a well documented bug from day 1, still unfixed after 2 patched, joy. It comes with a wonderful bonus, I can no longer load my guns manually. So I went from 1 single shot pistol with 16 reloads, to a 2+1 un-reloadable with no way to fix it.

So I decide to explore New York, even incognito everywhere I go guards instantly attack me from 20-40 feet away, even if I'm in a crowd/haybales. Everywhere in NY this happens, I can barely get around with luck, but even attempting missions are impossible here with this. I look it up, once again a day 1 bug called "Random open conflict", 2 patches, no fix.

It's at this point all the other crap I've endured just tips the glass and I can't deal with it anymore. Here's a running list of the 'minor' things I saw just in the 1 hour time frame of the 3 events above. I was attacked by a immortal soldier that took about 2 dozen stabs and 3 bullets at point blank without dying, fell thru the world while climbing a fence, climbed a tree for a vista that's was impossible to complete because of the last jump in relation to were the leaf pile is (lower left of the frontier), had a window pop up saying i recieved a weapon every single time i traveled or looted anything everytime cant get rid of it, optional events fail the second I begin a memory, guards threw rocks thru walls to knock me off a building, the list goes on and on.

If i were to just write the title of glitches and bugs I encountered, e.g. "Dual Holster Bug" I could fill a piece of paper front and back, size 8 font, single spaced and i'd have run out of room long before I got even halfway as far as I did. I'd say this was impossible if I didn't personally play it, you people claimed this has been in development since after AC2 came out yet somehow despite incorporating nearly zero of the features from 2, Brotherhood or Revelations, hell even alot from 1, you somehow produced something with 3x the bugs. How?

I'll give it this atleast, I finally feel like finishing getting 100% in Revelations, its like a whole new view has been shown to me when I look at this now.