PDA

View Full Version : Finally discovered the DX10 problem with the first Assassin's Creed.



TheSnaksolid
11-20-2012, 09:14 AM
OK I've searched the forums quite a bit to see if anyone had ever posted about this problem and I know it's been a long time since anyone has addressed this but it appears that many people (including myself) have had problems with running the DX10 version of Assassin's Creed on Steam. If someone has already posted about this I apologize but I didn't seem to find anyone with a solution. If your on Windows 7 and experiencing the glitch where you see a black screen but the sound is still running just fine then what you need to fix is the DPI scaling for the program if you have increased the DPI in Windows 7. Browse to the location "C:\Program Files (x86)\Steam\steamapps\common\Assassins Creed". There you will find a file called "AssassinsCreed_Dx10.exe". Right click that file, go to properties, then go to the Compatibility tab. Check the option that says "Disable display scaling on high DPI settings". This should fix the issue. Your welcome to the whole 3 people who still actually care about this problem :P

spectatorx
11-20-2012, 10:33 AM
Yes, i've been facing the same problem few days ago :-) And found this solution with dpi scaling somewhere over internet ;-) It works for steam, retail and any other version of the game.