PDA

View Full Version : Assassin's Creed series on Windows 8



Cryiox
10-23-2012, 05:16 PM
I don't know if it's Nvidia's, Microsoft's or Ubisoft's problem.

I just finished Revelations a few days ago, and I must admit, it wasn't on legal ways. But I liked the game so much (and the story), that I went straight to the retailers store and I bought AC1, AC2 and Revelations (Brotherhood was missing, unfortunately).

Anyways, I had no problems with Revelations on Windows 8 x64, on a GTX560 Ti 1 GB, with the drivers 306.97. The thing is...Assassin's Creed 1 isn't working at all in DirectX10, and in DirectX9 I have 3 second-hangs every time I kill someone. If I change the compatiblity, the game won't start in any DirectX. Now, with the bought Revelations, the game crashes also. I can get it to work 2 seconds (via the compatiblity in Windows Vista SP1/W7) in the Ubisoft logo scene, but it still crashes nontheless afterwards.

Is this a know issue, or is it a problem only I exhibit?

Windows 8 x64, updated, all software updates (the latest versions, including betas), drivers 306.97 and 310.33, GTX560 Ti , 4 GB of ram, and Intel Q9550 stock.
It doesn't work on my laptop either. Same software, just the GPU and CPU differ: GT540M 1 GB and Intel Core i3 380M.

andreja110s
10-23-2012, 05:34 PM
Maybe the computer is too strong?

Dizlol
10-23-2012, 11:36 PM
I have the same problem with AC1 on DX10, everytime i kill someone it hangs, for the rest it runs smooth as hell.
thats on:
Intel Core i5-3450 3.10 GHz
Nvidia GTX560Ti
8 GB DDR3 Corsair RAM

ecma4
10-24-2012, 07:48 AM
I'm playing AC1 right now on windows 8 and it runs fine for me, not sure why yours is different, but it is possible.

TheLeoCrow
10-24-2012, 07:38 PM
I've heard that this problem on AC1 is often resolved by disconnecting from the internet while playing it

Cryiox
10-27-2012, 10:11 AM
I don't understand how AC1 would have a problem because of the internet connection, because it's in no way related to it.

I wouldn't want to run the games on a virtual box, because **** it, the games are still new. I consider this gaming generations still "new", and that they should run without problem on XP SP3/VISTA SP2/W7 SP1 AND Windows 8.

Black_Widow9
10-28-2012, 07:55 AM
Hello and welcome to the Forums :D
Please contact Ubisoft Support by following the link in my signature.
Thanks

lostboy233
10-29-2012, 09:58 AM
Well I can confirm the same thing. AC1 running on a Windows 7 X64 i7 core with a GTX460 and was fine until about a month ago and now I have the 3 second lag on any kill animations, walking around is fine, but any animation causes a freeze.

Annd... If I disconnect my internet connection all is right with the world and it plays fluidly as ever... weird

I've had windows updates, Mcafee updates and Nvidia driver updates in the last month so Im guessing its one of those that is causing a conflict or something...

Paouky
10-29-2012, 03:47 PM
Update anything u can? I guess.

TheLeoCrow
10-29-2012, 06:32 PM
The lags are caused because the game "phones home" any time you perform such actions. Disabling your connection or blocking any access the game has to your network through your firewall is the only solution I know

richik98
11-30-2013, 08:48 AM
do you have a 32 bit windows 8? The game will work on 32 bit but won't on64 bit.

Cryiox
12-03-2013, 01:58 PM
Thank you for the response, but it's a little too late.

For one, I know that AC games don't have problems with x64 versions of Windows. For another, I'm running W8.1 x64 now and newer drivers. I haven't tried any AC previous to AC III since then.