PDA

View Full Version : IL-2 1946 randomly crashes after 10-20 mins of playing :(



Newflyer
06-29-2012, 01:46 AM
Ever since I got my new computer I can't play Il-2 for more then 10 mins in one flight or it randomly crashes to the desktop with no warning.
It doesn't crash in menu's, only if I spend a long time in one flight (I only play offline btw) I have windows 7 and the steam version of the game.
I read this guide that told me how to set up IL-2 to work on windows 7 and did everything it said but the crashes still happen :(
that guide is here :http://114th-fighters.team-talk.net/t48-running-il-2-sturmovik-1946-with-steam-in-windows-7-by-donkey_doo

does anyone know why this happens? :( This is the only flight sim I play and I love it so

ytareh
06-29-2012, 10:33 AM
I would suggest overheating or drivers as possible causes.

Tully__
06-29-2012, 11:13 AM
I concur. If you're using mods there might be a memory leak issue too.

Newflyer
06-30-2012, 06:51 AM
Hey I fixed the problem guys. I just changed the graphics settings from openGL to Direct X. :) and no I don't use any mods I don't even know where I can find those lol

EDIT: nevermind it crashed again but this time after about 4 full length campaign missions.. oh well it still crashes way less I guess ill have to live with it

Sillius_Sodus
06-30-2012, 07:37 PM
As the others have said, it's likely an overheating problem, however a few years ago I was having a similar problem to yours and traced it back to a dodgy plug-in usb hub. I don't use them any more and have had no problems since then.

But in the end, I would first look at whether or not your computer or some of its components are overheating. Don't know what kind of rig you have, but it could also be a problem with your power supply or perhaps even an unrelated Windows issue.

I hope you get fixed up soon.

Sillius_Sodus
06-30-2012, 08:03 PM
Further to my last, there is a thread over in Community Help describing your problem and it turned out to be a bad power supply.