PDA

View Full Version : AC2 PC - Stuck in tomb due to possible game glitch - please help!



staccato77
06-27-2012, 10:11 PM
I'm having a weird problem that's preventing me from finishing "Ravaldino's Secret" mission.

I'm at the last chamber and there seems to be a glitch that's preventing me from performing the jump demonstrated here at 7:17 http://www.youtube.com/watch?v=gB1k_lScTeM

i've tried numerous times but as soon as i operate the mechanism, the camera seems to lock into a straight angle and i cannot make the jump. i keep pressing the space bar but the character isn't jumping, it just stays crouched on the ledge. as soon as the timer finishes and the lever goes back down, the camera switches back to normal behavior and i am able to perform the jump.

Has anyone had a similar problem? Restarting the game didn't help.

please help!

MT4K
06-27-2012, 10:22 PM
That's odd. Surely just holding towards your destination (left going by the video) and pressing jump should work. :S. Can you not jump in any direction at all?

xmisery13x
07-09-2012, 01:50 PM
I had a bit of trouble with that part too.
Did a fair bit of cursing as well after awhile. :p
With me the trick was that I needed to specifically press the left arrow button (I normally use my mouse to move around) while the camera was fixed during the timer and press the jump button at the right time.
Try that and let us know if it worked. :)