PDA

View Full Version : Bastardo! I have lost my Turkish assassin armor



Funbun777
02-25-2012, 12:59 AM
I got it by using that gamespot promotion and now it's gone!

any help?

Ps. I'm on xbox

TrueStoic
02-25-2012, 10:52 AM
What teh guy above wanted to tell you, that you cant do anything about it just yet.
gotta wait for a patch, but i think i should add; am on Ps3 and stil have all 3 of my outfits ( Desmond, Old Altair and Turkish assassin) the latter i got from the special edition.

Black_Widow9
02-25-2012, 08:53 PM
Please contact Ubisoft Support by following the link in my signature.

InfectedNation
02-25-2012, 09:28 PM
This happened to me too after the new title update - maybe Gamespot promotions are not permanent.

JumpInTheFire13
02-25-2012, 11:59 PM
Same thing happened to me.

twenty_glyphs
02-26-2012, 12:40 AM
I have the Turkish Armor from the Gamespot promotion too, but it's still there even after the new patch. I will say though that the new patch put the ex****ation point next to Items and Outfits menu items that's supposed to indicate something new, even though none of my unlocked outfits are new. Brotherhood has always had this problem for me too, but it put the ex****ation point on Items, Outfits, and the Raiden outfit in my menu every time I loaded the game (going into the menus clears the ex****ation point until the next time I load the game). This new patch in Revelations doesn't mark any of the 3 outfits as new, just their parent menu items. It's irritating, but not as bad as missing the outfit entirely. Sorry for everyone dealing with this problem.

JumpInTheFire13
02-26-2012, 05:23 AM
I have the Turkish Armor from the Gamespot promotion too, but it's still there even after the new patch. I will say though that the new patch put the ex****ation point next to Items and Outfits menu items that's supposed to indicate something new, even though none of my unlocked outfits are new. Brotherhood has always had this problem for me too, but it put the ex****ation point on Items, Outfits, and the Raiden outfit in my menu every time I loaded the game (going into the menus clears the ex****ation point until the next time I load the game). This new patch in Revelations doesn't mark any of the 3 outfits as new, just their parent menu items. It's irritating, but not as bad as missing the outfit entirely. Sorry for everyone dealing with this problem.
What's so bad about the world "c l a m"?

twenty_glyphs
02-26-2012, 06:41 AM
What's so bad about the world "c l a m"?

Ha, at least some of the other filters make sense. I wish they'd implement the word filter using word boundaries, so it doesn't filter out "bad" words that are in the middle of perfectly clean words.

LightRey
02-26-2012, 10:17 AM
What's so bad about the world "c l a m"?

You'll find out.

JumpInTheFire13
02-26-2012, 08:03 PM
You'll find out. I think this is an appropriate time for the you-know-what...

Funbun777
02-26-2012, 08:51 PM
Update

Hey guys I have it back now!

Its about a 50/50 chance of having your outfits whenever you power your console on and off

RobertDawson
07-13-2012, 04:43 AM
I still havent got mine back either and i already tried contacting ubisoft

Funbun777
07-13-2012, 05:32 AM
I still havent got mine back either and i already tried contacting ubisoft


My thread is resurrected