View Full Version : Torpedoes Stuck After Loading Saved Game v1.1

03-30-2005, 05:39 PM
So I have been playing SH3 for quite some time now and I have the latest patch(v1.1 DVD) installed. Now apart from the few bugs and issues like crew standing under water and not being able to mount the flak or deck gun during a few ripples in the pond, there has been this one other issue that has cost me quite a few reloads and grey hair.

I have shot tubes 1 2 and 3 at at a C3 cargo during career mode, after sinking it I saved the game. Keep in mind that I saved DURING the reload of tubes 1 to 3. (Yes I have anough crew with enough endurance assigned to bow and stern torpedo rooms)

After I reloaded that game I shot a coastal metchant with my aft tube, and made my way to another contact. This time a C2 cargo. After about 60 mins (game time) I was in position for firing at the c2. And to my surprise none of my tubes were reloaded yet. !?!

This is where I found that tube 3 had only 1 minute and 9 seconds to go. But the seconds were not counting down! So I wanted to take a shot with the already loaded tube 4 and my aft tube. Then I saw that all the other tubes, EVEN MY AFT tube was waiting in the queue for reloading!

So i pushed the time compressor to 512 and waited ... and waited and waited.... and none of the torpedos ever loaded. All are waiting for tube 3. And tube 3 stays stuck on 1 minute and 9 seconds.

I tried to move torpedo 3 to one of the stores but that doesn't work (I can move all the others though) I have tried reloading, re-saving, re-saving with re-arranging other torpedo positions. Nothing helps.

Has anyone had the same problem or knows about a discussion of the same sort?

03-30-2005, 06:15 PM
It happened to me once. All I did to reactivate the torpedoe crew was to activate silent running and then deactivate it again.

Et voila, the strike is over.

03-30-2005, 07:11 PM
Something similar happened--they entire box that each torp was in was greyed out--solid grey--and then the whole weapons management screen would flicker and the image became corrupt. Only way to solve it was ending the mission--saving and reloading did not help.