PDA

View Full Version : Uplay errors and problems



mast3rofpuppet
11-21-2009, 04:16 AM
Hello all! I'm not sure if there was a thread about this already but if there was then Mods feel free to do what ever to this one.

So this thread is to talk about problems you are having with Uplay.

My personal problem is that when I "bought" the Premium theme for the PS3 it didn't start downloading, it said "This item is not available" or somethin' like that. Well it still took my 20units for the theme and it's now marked as "already owned" although I don't even have it! When I go and look at the reward it now says "If you want to download this again go to the view downloads in the playstation 3 system menu". My question is how do I get it? Or is it lost for ever?

mast3rofpuppet
11-21-2009, 04:16 AM
Hello all! I'm not sure if there was a thread about this already but if there was then Mods feel free to do what ever to this one.

So this thread is to talk about problems you are having with Uplay.

My personal problem is that when I "bought" the Premium theme for the PS3 it didn't start downloading, it said "This item is not available" or somethin' like that. Well it still took my 20units for the theme and it's now marked as "already owned" although I don't even have it! When I go and look at the reward it now says "If you want to download this again go to the view downloads in the playstation 3 system menu". My question is how do I get it? Or is it lost for ever?

kleaneasy
11-21-2009, 10:59 AM
Please use the UPlay (http://forums.ubi.com/eve/forums/a/frm/f/8121060208) forum, this is an issue we're aware of and a notice has been posted in the forum, thanks