PDA

View Full Version : Centering force on joystick



blakduk
03-03-2005, 09:07 PM
Is there something wrong with my joystick?
I recently patched IL2 (original version) and found to my delight that my Logitech wingman forcefeedback joystick worked!!!! I hadnt realised that it was supposed to have a positive centring force when i reached a reasonable airspeed. It improved my 'feel' for flying and greatly helped me avoid stalls/spins (I'm not sure why, maybe its because i can more easily sense the buffeting start).
But, woe is me, it has returned to its old ways. It now feels mushy no matter what speed i have.
I recently downloaded DCG from Lowengrin (version 3.10). Could this have affected the joystick settings?

blakduk
03-03-2005, 09:07 PM
Is there something wrong with my joystick?
I recently patched IL2 (original version) and found to my delight that my Logitech wingman forcefeedback joystick worked!!!! I hadnt realised that it was supposed to have a positive centring force when i reached a reasonable airspeed. It improved my 'feel' for flying and greatly helped me avoid stalls/spins (I'm not sure why, maybe its because i can more easily sense the buffeting start).
But, woe is me, it has returned to its old ways. It now feels mushy no matter what speed i have.
I recently downloaded DCG from Lowengrin (version 3.10). Could this have affected the joystick settings?

Saburo_0
03-03-2005, 10:16 PM
Not sure if it's related to your problem. I've found -since installing PF IIRC that before running the game I have to go into control panel.. select my stick, hit properties settings and then close it all back up (don't need to make any changes) then it works fine. If I don't do this the centering spring force doesn't work & the stick flops all over the place.

Don't know why this would be but it works for me. Give it a try. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

knightflyte
03-03-2005, 10:23 PM
Make sure power cord is plugged in and not loose. (May as well check your USB connection too)

Go to START/CONTROL PANEL/GAME CONTROLLERS.
Select your Logitec and test/recalibrate it.

In IL2 select the input screen. (The screen where you can change the input throw of each axis) On that screen on the bottom left you will see a toggle for Force feedback. Make sure that is ticked off.

If any of those DO NOT help try to reinstall the drivers.

I had a Logitec and never had a problem with the FF. The rudder alignment crapped out on me but FF was ALWAYS good.....I'd even venture to say great. It REALLY helped to identify stall patterns in the planes.

Tully__
03-03-2005, 10:46 PM
Some USB joysticks benefit from being unplugged and plugged back in before starting the game.

Most FFB sticks will lose their centering if you Alt-Tab to desktop after starting the game.

blakduk
03-03-2005, 10:52 PM
Thanks for that knightflyte- i'll give that a go tonight.
The forcefeedback has always worked- the shaking etc when firing the guns or stalling etc.
Originally it lacked the force pulling the stick to the center. When i patched IL2 up to version 1.2 it suddenly started doing it. I noticed on the readme file for upgrade 1.1 that it referred to fixing a problem where some sticks didnt centre properly- i hadnt realised what they meant.

blakduk
03-03-2005, 10:54 PM
Tully- you're a champion!!!
I realise now that's what i did wrong, i pressed alt-tab to configure the DCG!!!!. If i stop messing around with that i'll probably have fixed the problem.
Cheers!