PDA

View Full Version : Flying AI planes



Frankthetank36
09-25-2009, 09:07 PM
Was playing on Hyperlobby today and noticed that one of the possible planes to fly was a Kate torpedo bomber, which I thought was strange because it was an AI plane. Tried flying it and couldn't control it or get inside the cockpit, so I crashed. Asked about it and one of the guys said that you could get mods that allow you to control AI planes (complete with cockpit etc) but in the heat of combat I didn't have time to jot down the address he posted. So my question is, how do you make these planes flyable?

Frankthetank36
09-25-2009, 09:07 PM
Was playing on Hyperlobby today and noticed that one of the possible planes to fly was a Kate torpedo bomber, which I thought was strange because it was an AI plane. Tried flying it and couldn't control it or get inside the cockpit, so I crashed. Asked about it and one of the guys said that you could get mods that allow you to control AI planes (complete with cockpit etc) but in the heat of combat I didn't have time to jot down the address he posted. So my question is, how do you make these planes flyable?

Wildnoob
09-25-2009, 09:36 PM
hello Frankthetank36!

yeah, with mods, but most not incluid custom original cockpits, rather then that they use a cockpit of another flyable aicraft.

if you like to fly with AI planes that way, you can use the mods, but the forum rules don't allow ask for any mod content download or support here.

perhaps you may find this kind off stuff and support for it searching on the internet.

good luck!

Frankthetank36
09-25-2009, 10:32 PM
That's too bad... I would've liked a B-29 cockpit. And this site doesn't like mods? Hmph... There are like 70 planes in IL-2 that we are missing out on.

Troll2k
09-26-2009, 12:26 AM
In days of yore before mods were invented there was a way to fly AI planes in a dogfight server.However it could only be flown from external view.

Aiming that way in a dogfight was near impossible(except for a lucky shot).However bombing was not that bad.Seat of the pants stuff.No bombsight.

Once you got into a game you had to choose a real plane.I believe you had to at least start the engine(s).Then exit out to the plane choice screen and choose the AI plane.you should now be able to fly it from external view.

This of course all depends if the server has external views turned on.

AndyJWest
09-26-2009, 04:42 AM
We can't post links to mod sites here, (Ubisoft do provide the site after all), but they don't object if we suggest you Google 'All Aircraft Arcade' to find out about such matters.

Right now though, with the new official 4.09 final patch coming out shortly, it might be better to hold off installing mods, as they are unlikely to be compatible with the new patch for the moment. Personally I'm not particularly impressed with the quality of many of the mod aircraft in any case, but whatever rocks your boat, as they say.

If you do want to install mods, be prepared for some huge downloads if you want to do it properly.

Bearcat99
09-26-2009, 06:54 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by AndyJWest:
We can't post links to mod sites here, (Ubisoft do provide the site after all), but they don't object if we suggest you Google 'All Aircraft Arcade' to find out about such matters.

Right now though, with the new official 4.09 final patch coming out shortly, it might be better to hold off installing mods, as they are unlikely to be compatible with the new patch for the moment. Personally I'm not particularly impressed with the quality of many of the mod aircraft in any case, but whatever rocks your boat, as they say.

If you do want to install mods, be prepared for some huge downloads if you want to do it properly. </div></BLOCKQUOTE>

Good advice.. and frankly some of the modded AI flyables are just not that good.. Some are decent... but... to each his own. And for the record frank it isn't that we don't like mods ... I many of them are great.. Like Andy said we just don't allow direct links and we do not technically support them. We have come to tolerate them because they have become a fact of the sim.. and some of them are just pretty darned good to be honest.

Wildnoob
09-26-2009, 08:56 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by AndyJWest:
but they don't object if we suggest you Google 'All Aircraft Arcade' to find out about such matters. </div></BLOCKQUOTE>

hmm, didn't know that could be posted.

sorry for not had provide you with this information Frankthetank36. http://forums.ubi.com/images/smilies/16x16_smiley-sad.gif

Frankthetank36
09-26-2009, 12:25 PM
Troll, it would only let me use external views on the B5N but even then it wouldn't let me control it (and for some reason it started in midair instead of off a carrier like with the Zeroes). So do any of these modded planes actually have their own cockpit (and one that looks good)?

Frankthetank36
09-27-2009, 11:15 AM
Well I googled AAA and didn't find mods to let you fly the FW-200, B5N, and N1K1 (the only AI planes I had seen as flyable options in Hyperlobby), they mostly had planes that were not included in the game in the first place and therefore I imagine that they can't be used online. The N1K seaplane looked pretty cool, but it said that it replaced the Rufe if you got it! So any other places I can google to find flyable AI planes? I've been wanting a carrier-based torpedo bomber for a while now.

TinyTim
09-27-2009, 11:48 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Frankthetank36:
Well I googled AAA and didn't find mods to let you fly the FW-200, B5N, and N1K1 (the only AI planes I had seen as flyable options in Hyperlobby), they mostly had planes that were not included in the game in the first place and therefore I imagine that they can't be used online. The N1K seaplane looked pretty cool, but it said that it replaced the Rufe if you got it! So any other places I can google to find flyable AI planes? I've been wanting a carrier-based torpedo bomber for a while now. </div></BLOCKQUOTE>

Look for a Unified Installer 1.1 there. You can't miss it. It makes most if not all AI only planes flyable via cockpits and gunstations taken from flyable planes. B5N uses cockpit from N1K2, not perfect but playable solution. Beware tho, B5N has flight model so screwed up it's on a verge of unflyable.

Treetop64
09-27-2009, 12:38 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Frankthetank36:
Hmph... There are like 70 planes in IL-2 that we are missing out on. </div></BLOCKQUOTE>

And there's more than 200 that we aren't. Go through and try some out! http://forums.ubi.com/images/smilies/25.gif

Frankthetank36
09-27-2009, 01:51 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by TinyTim:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Frankthetank36:
Well I googled AAA and didn't find mods to let you fly the FW-200, B5N, and N1K1 (the only AI planes I had seen as flyable options in Hyperlobby), they mostly had planes that were not included in the game in the first place and therefore I imagine that they can't be used online. The N1K seaplane looked pretty cool, but it said that it replaced the Rufe if you got it! So any other places I can google to find flyable AI planes? I've been wanting a carrier-based torpedo bomber for a while now. </div></BLOCKQUOTE>

Look for a Unified Installer 1.1 there. You can't miss it. It makes most if not all AI only planes flyable via cockpits and gunstations taken from flyable planes. B5N uses cockpit from N1K2, not perfect but playable solution. Beware tho, B5N has flight model so screwed up it's on a verge of unflyable. </div></BLOCKQUOTE>

So the B5N flight model is fine for the AI but screwed up for human users? Weird. Hope the B6N and Avenger are better. I've been wanting a carrier-based torpedo bomber ever since I got CFS2 several years ago.

Found the Universal Installer but can't get a clear answer from the people on AAA forums as to whether or not you can download UI and then the 4.09 official patch when it comes out so that you can have both flyable AI planes and whatever comes with the 4.09 patch, or if you can just have one or the other.

Frankthetank36
09-27-2009, 02:05 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Treetop64:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Frankthetank36:
Hmph... There are like 70 planes in IL-2 that we are missing out on. </div></BLOCKQUOTE>

And there's more than 200 that we aren't. Go through and try some out! http://forums.ubi.com/images/smilies/25.gif </div></BLOCKQUOTE>

Lol, I'm having plenty of fun in the campaigns flying Seafires and Rufes and Il-10's and Ta-152s and other rare/obscure planes. But it would be nice to not be limited in the few online matches that allow AI planes (wouldn't mind having another four engine bomber either, that Russian one whose name I can't think of looks like it belongs in WWI not WWII).

TinyTim
09-27-2009, 02:12 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Frankthetank36:
So the B5N flight model is fine for the AI but screwed up for human users? Weird. Hope the B6N and Avenger are better. </div></BLOCKQUOTE>

Sadly, the Jill and Avenger fall into the same cathegory as the Kate. Flight models of these planes are very similar - and very bad. I've heard some rumors there are mod packs out that adress this issue.

Frankthetank36
09-27-2009, 02:18 PM
So can those mod packs be used online when you use one of the torpedo bombers or is it just for single-player?

TinyTim
09-27-2009, 02:58 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Frankthetank36:
So can those mod packs be used online when you use one of the torpedo bombers or is it just for single-player? </div></BLOCKQUOTE>

You can use mods online on those servers that allow mod usage. Others however demand a pure, unmodded 4.08 version. Really depends on the server.

Frankthetank36
09-27-2009, 03:19 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by TinyTim:
You can use mods online on those servers that allow mod usage. Others however demand a pure, unmodded 4.08 version. Really depends on the server. </div></BLOCKQUOTE>

So if you use UI to fly AI planes on some servers (even without altering their flight model), would that mean that other servers won't let you fly on them period because your game is modded, even though your flight models are still the same?

Also still wondering whether or not you can download UI and then the 4.09 official patch when it comes out so that you can have both flyable AI planes and whatever comes with the 4.09 patch, or if you can just have one or the other.

Frankthetank36
09-27-2009, 03:53 PM
Well finally got an answer from the AAA guys and it the UI probably won't work with the 4.09 patch although you can just convert it back to unmodded 4.08 and then get the patch but it will take up a lot of room, so does anyone know when the patch is coming out?

TinyTim
09-27-2009, 06:49 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Frankthetank36:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by TinyTim:
You can use mods online on those servers that allow mod usage. Others however demand a pure, unmodded 4.08 version. Really depends on the server. </div></BLOCKQUOTE>

So if you use UI to fly AI planes on some servers (even without altering their flight model), would that mean that other servers won't let you fly on them period because your game is modded, even though your flight models are still the same?
</div></BLOCKQUOTE>

Precisely. There is an easy solution to this though. UI comes with a handy version switcher, so you can switch between modded and unmodded game with a single click. Just search for the "_Switch-408_Mods_On.bat" and similar files in your IL-2 1946 root directory after installing UI, and pick the option that suits the server you are going to join.