PDA

View Full Version : Alt+Tab temporarily fixes low fps



bagpuss88
04-30-2010, 12:17 PM
No matter what level of graphics I use (right from minimum up to 1680x1080 4xAA, 4xAF with all settings turned on, except Vsync), I experience major slowdown in FPS periodically in the game. It tends to happen went entering a large new area.

I have found that this can always be fixed by Alt+Tabbing out of the game and straight back in. Just waiting in-game for the fps to rise again doesn't work!

Anyone any ideas what might be causing this?

<<Solution detailed in post 6>>

Phenom II X4 955
4GB RAM
8800GT 512MB
Win7

bagpuss88
04-30-2010, 12:17 PM
No matter what level of graphics I use (right from minimum up to 1680x1080 4xAA, 4xAF with all settings turned on, except Vsync), I experience major slowdown in FPS periodically in the game. It tends to happen went entering a large new area.

I have found that this can always be fixed by Alt+Tabbing out of the game and straight back in. Just waiting in-game for the fps to rise again doesn't work!

Anyone any ideas what might be causing this?

&lt;&lt;Solution detailed in post 6&gt;&gt;

Phenom II X4 955
4GB RAM
8800GT 512MB
Win7

yohonny101
04-30-2010, 03:01 PM
I've had this problem in other games, it's usually caused by what's known as a "memory leak," where due to poor coding the game starts to eat up more and more RAM until your system runs out and the game starts to chug. Alt-tabbing resets the process, so you get your FPS back, but it's a pain. Same thing happened to me in Far Cry 2. Anyway, this is the kind of thing that can only be fixed via a patch, and seeing as most people can't get the patch that's supposedly already out there, I wouldn't get your hopes up.

SliferFlakes
04-30-2010, 03:10 PM
The hell it actually did work
about 10 fps more in victor mission oO

Ashrien
04-30-2010, 04:52 PM
I honestly doubt a patch was ever released. Only Libini1989, or whatever his name was, reported it. I haven't seen anyone else, anywhere, claim to have received the update.

Xessive
04-30-2010, 08:19 PM
It seems to be doing the opposite for me. When I alt-tab the game comes back with worse frames. Takes about a minute then it's back to normal.

bagpuss88
05-02-2010, 01:43 AM
I've found the solution!

In NVIDIA Control Panel, uncheck the Enable Stereoscopic 3D box. That solved the problem for me, and I think overall FPS are up as well as not dropping substantially periodically.

NOTE: I was not using 3D effects - they were turned off. My solution is to stop 3D being on standby in the game.

Anddos21
05-02-2010, 01:45 AM
ALT tab does not work for me?

bagpuss88
05-02-2010, 02:04 AM
When you say ALT+tab doesn't work for you, do you mean it doesn't solve the slowdown, or you can't taskswitch out of the game?

If the latter, perhaps try Ctrl+Alt+Delete to get the task manager options up, then try going back into the game.

Alternatively, just try disabling 3D as I described above to see if you can solve it!